BIOS Not Autodetecting SATA Drive

Discussion in 'Gigabyte' started by croy, Apr 4, 2013.

  1. croy

    croy Guest

    Mainboard: GA-M55plus-S3G, Rev 1.2.

    Hard drives: Two IDE (80GB and 160GB), one SATA (2TB
    Seagate).

    Problem: After a power-off, the BIOS doesn't auto-detect
    the SATA drive. If I manually tell it to detect it, it
    does, but the drive is still not listed in the boot drive
    order, so I have to save the setup and restart, and then go
    back in and set the drive order.

    The next time the machine sits with power off, the problem
    returns.

    I've replaced the CMOS battery with a new, tested one.

    All other BIOS settings seem to be holding just fine.

    I've tried many different settings in the BIOS, but nothing
    seems to fix this.

    Any ideas?

    --
    croy
     
    croy, Apr 4, 2013
    #1
    1. Advertisements

  2. croy

    Paul Guest

    croy wrote:
    > Mainboard: GA-M55plus-S3G, Rev 1.2.
    >
    > Hard drives: Two IDE (80GB and 160GB), one SATA (2TB
    > Seagate).
    >
    > Problem: After a power-off, the BIOS doesn't auto-detect
    > the SATA drive. If I manually tell it to detect it, it
    > does, but the drive is still not listed in the boot drive
    > order, so I have to save the setup and restart, and then go
    > back in and set the drive order.
    >
    > The next time the machine sits with power off, the problem
    > returns.
    >
    > I've replaced the CMOS battery with a new, tested one.
    >
    > All other BIOS settings seem to be holding just fine.
    >
    > I've tried many different settings in the BIOS, but nothing
    > seems to fix this.
    >
    > Any ideas?
    >


    Are the SATA RAID settings involved in this, in any way ?

    It's possible to set up SATA for RAID mode, then run a
    single disk in JBOD. But you could just as easily, disable
    JBOD on the disk, turn off RAID mode for SATA, and operate
    the disk as a SATA/IDE disk on the SATA port.

    Some motherboards have a 35 second timeout on disk detection,
    and the timer can be adjusted in the BIOS. I don't see anything
    in the manual which corresponds to that adjustment. The ATA/ATAPI
    spec allows up to 35 seconds for a hard drive to signal "ready" and
    accept command requests.

    So on your motherboard, I don't see a lot of controls, other than
    the RAID on SATA controls. You could try disabling the IDE ribbon
    cable controllers, and see if the SATA is detected more reliably,
    but I don't really expect that to make a difference.

    Paul
     
    Paul, Apr 4, 2013
    #2
    1. Advertisements

  3. croy

    croy Guest

    On Thu, 04 Apr 2013 13:34:25 -0400, Paul <>
    wrote:


    Thanks for the reply Paul.


    >Are the SATA RAID settings involved in this, in any way ?



    Here's what I see in the BIOS Setup:

    CMOS Setup Utility (Award)
    SATA-II RAID Config

    SATA-II RAID function [Disabled]

    Serial-ATA-II 1 [Enabled]
    x SATA-II 1 Primary RAID Disabled
    x SATA-II 2 Primary RAID Disabled

    Serial-ATA-II 2 [Enabled]
    x SATA-II 1 Primary RAID Disabled
    x SATA-II 2 Primary RAID Disabled



    >It's possible to set up SATA for RAID mode, then run a
    >single disk in JBOD. But you could just as easily, disable
    >JBOD on the disk, turn off RAID mode for SATA, and operate
    >the disk as a SATA/IDE disk on the SATA port.



    How do I disable JBOD on the disk? [this is a Seagate
    ST23000641AS]. I don't see any jumpers, either on the
    hardware, or talked about in the drive manual.

    --
    croy
     
    croy, Apr 4, 2013
    #3
  4. croy

    croy Guest

    On Thu, 04 Apr 2013 13:34:25 -0400, Paul <>
    wrote:

    > You could try disabling the IDE ribbon
    >cable controllers, and see if the SATA is detected more reliably,
    >but I don't really expect that to make a difference.



    I just tried that in the BIOS, but, as you expected, it
    didn't make a difference.

    --
    croy
     
    croy, Apr 4, 2013
    #4
  5. croy

    Paul Guest

    croy wrote:
    > On Thu, 04 Apr 2013 13:34:25 -0400, Paul <>
    > wrote:
    >
    >> You could try disabling the IDE ribbon
    >> cable controllers, and see if the SATA is detected more reliably,
    >> but I don't really expect that to make a difference.

    >
    >
    > I just tried that in the BIOS, but, as you expected, it
    > didn't make a difference.
    >


    You've exhausted all the options I could see.

    Your BIOS does indeed have the RAID settings disabled.
    So that's not it.

    JBOD only applies if RAID is enabled on the motherboard,
    It's not a jumper on the drive. It is up to the RAID BIOS code,
    to write metadata up near the end of the disk, if the drive
    is to be used in some RAID mode.

    I don't know what else to suggest. I haven't heard of any
    Nvidia issues with SATA compatibility.

    I'd probably check through the M.I.T. page of your BIOS,
    and disable any voltage adjustments or overclocks, and
    see if that changes things at all. The motherboard supports
    changing SB or NB voltages for the chipset, and it's possible
    the SATA interface is tied to one of those settings. I don't see
    any clock signal adjustments, that would figure in the issue.
    The PCI Express clock probably isn't tied into the SATA ports
    any more.

    Paul
     
    Paul, Apr 4, 2013
    #5
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. bigbrian
    Replies:
    1
    Views:
    679
  2. LeeBos
    Replies:
    0
    Views:
    535
    LeeBos
    Jun 24, 2003
  3. Nom
    Replies:
    0
    Views:
    588
  4. h2so4
    Replies:
    5
    Views:
    1,146
  5. Aldo Larrabiata

    SATA & SCSI, SATA link & SATA Raid

    Aldo Larrabiata, Nov 28, 2004, in forum: Asus
    Replies:
    1
    Views:
    949
    Aldo Larrabiata
    Dec 2, 2004
  6. Tony
    Replies:
    3
    Views:
    936
  7. Larry Raynor
    Replies:
    7
    Views:
    12,902
  8. Zem
    Replies:
    4
    Views:
    715
Loading...