1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

BIOS recovery : D845GVSR mobo

Discussion in 'Intel' started by ClueLess, Nov 15, 2010.

  1. ClueLess

    ClueLess Guest

    Cross posted to comp.sys.intel, 24hoursupport.helpdesk


    I have an Intel D845GVSR motherboard which I use mainly for old DOS
    work (the more recent mobo does not work as expected :-( )

    Ok, this board was having problems with the mouse and I wanted to
    upgrade the bios, from the original version 3 to the latest version 20
    at Intel site.

    The upgrading went ok and everything worked well but no USB under Win
    XP SP3! (I need it to copy stuff from one machine to another).

    I thought of going back and tried the bios version 5 (which said the
    mouse problem has been corrected). The Intel bios burning program
    asked me to confirm I really wanted to flash an older version and when
    I hit ok the bios was flashed.

    Now the computer does not boot. When I set the jumper to the
    maintenance setting the bios settings screen comes up and it shows the
    bios version as 5. But any change in the settings are not saved.

    According to Intel, in the recovery mode the system is supposed to
    read the *.bio file in a floppy or CD will be written to the bios. I
    have tried *.bio files from nay versions both in CD and floppy but
    have failed.

    If any of you know a method to flash the bios please let me know. The
    mobo is not dead as the bios settings do display in the maintenance

    Thanks in advance for any help
    ClueLess, Nov 15, 2010
    1. Advertisements

  2. ClueLess

    Meat Plow Guest

    That is the only way to flash the bios. Give me a description of the
    process, any errors you might get.
    Meat Plow, Nov 15, 2010
    1. Advertisements

  3. ClueLess

    VanguardLH Guest

    Was USB support working before?

    If USB support was not there before with the old v3 BIOS, perhaps the
    chipset drivers weren't installed into Windows XP to afford that
    support. Did you follow with an install of the Intel chipset drivers?
    When you did the first BIOS flash update, did the writer program not
    first offer to save a backup of the existing BIOS code to a .bio file?
    I don't recall ever doing a BIOS update where either the program did not
    ask me to backup the existing code or the instructions told me how to do
    it using that same writer program. Do you have the old v3 .bio file to
    flash into your BIOS so you are back to square one?
    What does "not boot" mean? That you don't even get to the POST screen?
    Or that the hardware boot actually completes and it is the load of
    Windows XP that halts, errors, or something else yet to be described?
    What does "failed" mean? That your host won't boot using a bootable
    floppy or CD? Or that the .bio file gets rejected as incompatible with
    your hardware? The writer program can't find the storage media on which
    the .bio file exists?
    After flashing the BIOS, did you short the "CMOS clear" 2-pin header on
    the motherboard? The settings saved in the CMOS may not match those now
    in the EEPROM for the BIOS. They may not even align to the same byte
    positions in the BIOS table to those that are saved in CMOS for the old
    table. If you have customized the BIOS (in the CMOS copy), write down
    all the settings that were modified from their defaults. After doing
    the flash update to the BIOS, clear the old CMOS copy by shorting the
    2-pin jumper for clearing the CMOS. Then do a *cold* reboot.

    If the "failed" problem is that the writer halted or errored during
    writing the new/replacement code into the EEPROM for the BIOS then it
    sounds like the prior flash was incomplete or corrupted. This can even
    result in not being able to boot using floppy, CD, USB drive, or other
    storage media to do another flash attempt. The only recourse at that
    point is to buy replacement EEPROMs for your motherboard (which requires
    extremely good soldering skills and the requisite soldering tools since
    I saw no socketed chips in the mobo pic at http://tinyurl.com/2b335nu).
    You might also try calling Intel support to find out how much it would
    cost to have them replace the EEPROM chips for BIOS (and put in the
    latest *applicable* version for that mobo). From their web site, it
    looks like support has been discontinued for this legacy product so
    you'll probably have to pay them to do the repair.
    VanguardLH, Nov 15, 2010
  4. ClueLess

    ClueLess Guest

    Basically I have downloaded every thing that is available for this
    mobo from Intel site and have carefully gone through the instructions
    before attempting flsh.
    USB worked before and all the drivers including USB 2.0 from Intel
    were loaded.
    When I flashed first the P20 (latest at Intel site for this mobo) I
    used the Win utility and it just updated the bios. Nothing about
    saving the old bios. Everything was ok except there was no USB. Device
    Manager did not show the USB and in BIOS setting all USB settings were
    This is after I tried to flash P5 version of bios (mouse error
    corrected per Intel in this version) this was also done under Windows
    using the utility provided by Intel. A question "Do you really wanted
    to flash an older version of bios" did come up and I clicked yes.

    After this the computer does not boot. Just a blank screen - no video
    output at all (monitor LED is just blinking showing no video input)
    and no beep at all.

    It just does not boot. When I put the jumpers in the maintenance mode
    bios setting comes up with the additional maintenance page (enables
    passwords to be cleared) and the general page indicated the bios
    version as 5. That means bios was flashed with some errors, I believe.
    When cmos jumpers are left open it is supposed to automatically read
    the *.bio files from either floppy or CD and do a silent flash (no
    display of any notice). I have tried both the floppy and CD way. I
    have tried putting only the *.bio file and then tried with all the
    following files in the floppy and CD and still no way. In these cases
    the floppy light stays on and I have kept for nearly 30 minutes; I
    have also tried various later bios including P20.


    I have some stuff like programmer for 8051 under DOS and the later
    faster motherboards with me (eg. ASUS P5KPL-AM/PS) do not recognize
    the equipment. But for this I would have chucked the 845 board.

    I hope that I will get some lead on this problem
    Thanks to the other also who have pitched in to help me.
    ClueLess, Nov 16, 2010
  5. ClueLess

    VanguardLH Guest

    The 2-pin "CMOS clear" motherboard header of which I speak is always
    left open (no shorting jumper) until you decide to wipe the CMOS copy of
    the table holding the BIOS settings (that were copied from the EEPROM
    and then modified in the CMOS copy of the table). When you short the 2
    pins, it is only momentary, like perhaps a few seconds. Then you remove
    the jumper.

    The CMOS clear header isn't just to wipe passwords. It wipes the CMOS
    table. That forces a reload of the BIOS settings from EEPROM into CMOS.
    Well, that's how it works in most mobos. The manual for your mobo is at
    Page 37 shows the "BIOS configuration" jumper. None of the positions it
    shows describes a *clearing* of the CMOS copy of the BIOS. My guess is
    that you need to use the Maintenance setting and somewhere in its
    screens is an option to revert to defaults or to reload the BIOS from
    the EEPROM. That it says "Use this menu to clear passwords" may be just
    one function of the maintenance menu mode. When you go into maintenance
    menu mode, is there any other options other than just clearing
    passwords? On page 49 is described several BIOS config screens.

    If the maintenance mode gives you the config screens shown starting on
    page 47, did you check if USB was enabled as per the settings shown on
    page 63? I couldn't find a reset or reload function in their BIOS
    screens. The closest was "Load Optimal Defaults". Maybe that reads the
    EEPROM to load the defaults into the CMOS table. Personally I would've
    preferred a 2-pin CMOS Clear jumper on the mobo to get back to scratch
    but it doesn't look like Intel gives you that for this mobo.
    VanguardLH, Nov 16, 2010
  6. ClueLess


    Jan 6, 2013
    Likes Received:
    I have exatly the same problem!!
    Can you resolve that?
    maxisvegeta, Jan 6, 2013
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.