Bios upgrade to A09 on XPS D266

Discussion in 'Dell' started by BigNose, Nov 18, 2005.

  1. BigNose

    BigNose Guest

    I think it went fairy well.... (I hade read a lot of posts before
    attempting it)

    The BIOS appears to have taken. The new memory appears to be accepted.
    After fiddling with BIOS setting for a long time - the hard drive and
    the two CD drives (one is a burner) are recognised, but when it comes
    to boot, it insists on doing it from the floppy drive - even if a disk
    is not present in the drive.

    I think although it has recogised the existence of the Maxtor original
    hard drive it cannot navigate to it properly to boot.

    When I do boot from the floppy it gives options for loading windows 98
    - but always ends up at the dos prompt on A:

    Is there another BIOS setting that I need to fiddle with in order for
    the machine to boot from the HD? I feel that things are not too far
    from working, or am I being too optimistic?

    Kev.
     
    BigNose, Nov 18, 2005
    #1
    1. Advertisements

  2. BigNose

    Ben Myers Guest

    The hard drive has to be bootable itself, in order to boot from it. Is it
    partitioned and formatted with Win 98/DOS system files?

    If not, go to www.bootdisk.com and download the Win 98SE boot disk image, make a
    boot disk with it, then boot the computer to the A: prompt. FDISK creates the
    partition, and FORMAT C: /S formats it with system files to make it bootable.

    What is the capacity of the hard drive?

    If the hard drive was previously partitioned and formatted on another system, it
    may not work due to BIOS differences.

    .... Ben Myers
     
    Ben Myers, Nov 18, 2005
    #2
    1. Advertisements

  3. BigNose

    BigNose Guest

    Thanks for helping Ben,

    The HDD is the original one I think it's approx 6 GB and partitioned to
    3 drives (C,D and E)
    it was properly installed with Win98 years ago and always happily
    booted from this disk when at the previous BIOS A04.

    I created a win98 boot disk the day before attempting the flash and
    tested this disk which allowed a full 98 boot.

    I should also mention that I have read posts suggesting a clear of NVRM
    and having done this it has not helped.

    I think although the hard drive is identified during the boot, perhaps
    it does not recognise the file system (I think it may have been FAT32)
    or perhaps the disk controller needs a few pointers? The default
    settings from the A09 load seem to be at odds with my setup. Hence
    having to set things to AUTO to allow it to detect drives.

    regards,
    Kev.
     
    BigNose, Nov 18, 2005
    #3
  4. BigNose

    Ben Myers Guest

    Unless you want to preserve some data on the drive, the most certain solution is
    to reinstall Windows. Windows 98SE is perfectly happy with FAT32 partitions,
    but will not work with NTFS... Ben Myers
     
    Ben Myers, Nov 18, 2005
    #4
  5. BigNose

    BigNose Guest

    Thanks for your reply Ben.

    I do want to retain all the data on that disk. I had not expected any
    disk recognition problems from just upgrading the BIOS to the release
    (from the DELL website) specifically for my machine, which was still at
    the original spec.

    WIn98SE has been my operating system for years on this original drive.
    The only thing that has changed on the machine is the upgrade to A09
    BIOS so that I could put the memory up from 64 to 288. So I don't see
    why my hard drive is unrecognisable when I boot under the new BIOS
    unless it's related to a setting that I have not attended to. (I did
    feel that some of the default values seemed funny)
    I presume that setting it to AUTO would ensure that during the boot the
    drive would be interrogated and appropriate values set


    Kev.
     
    BigNose, Nov 18, 2005
    #5
  6. BigNose

    Tom Scales Guest

    I'm coming in late, but you mention upgrading the memory. Can I assume that
    you are trying to boot WITHOUT the new memory? If not, take it out and try
    again. Could be the memory, particularly if it is double-density (which
    likely will not work).

    Tom
     
    Tom Scales, Nov 18, 2005
    #6
  7. BigNose

    Fixer Guest

    Although it seems obvious try looking in the boot sequence in the BIOS and
    make sure the HDD is enabled to boot from it
     
    Fixer, Nov 18, 2005
    #7
  8. BigNose

    BigNose Guest

    Having seen the new memory accepted and not appear to cause any
    problems, I removed it and returned to the original stick so that the
    boot sequence would be faster, because I have to keep booting to try
    differnt BIOS settings. I'm sure it's just a hard drive recognition
    thing.

    Kev.
     
    BigNose, Nov 19, 2005
    #8
  9. BigNose

    BigNose Guest

    The HDD is set for AUTO recognition - so it wont let you manually
    adjust any of the details that it lists below it, but I assume they are
    correct because they have been autodetected (transfer mode and ultra
    DMA etc). I have tried adjusting the boot order and where it identifies
    "hard drive" below the boot order, it correctly specifies my Maxtor
    disk as the first drive to attempt a boot from.

    Yet still it fails to attempt a boot from disk, whirrs the floppy and
    complains if a floppy disk is not present.

    Thanks to all for your continued suggestions.

    I presume that re-flashing bios will not do any good, because the bios
    appears to have taken and allows me to make adjustments. I have tried
    clearing the nvram and was quite hopefull about that, but it made no
    difference. I am sceptical about resetting factory defaults for this
    new bios because the defaults that were present when it first loaded
    were totally inappropriate. - I will give that a go though.
    Kev.
     
    BigNose, Nov 19, 2005
    #9
  10. BigNose

    BigNose Guest

    OH MY GOD IT WORKED !!!!!!!!!

    I had stupidly assumed that having loaded a new clean BIOS that it
    would be set to factory defaults. What else would it be set to? it
    doesn't know anything about my machine. That's why I was complaining
    that I felt the settings were inappropriate and I had to manually get
    it into AUTO to search for my hard drive.

    Having now selected 'load setup defaults' I think it has interrogated
    the CMOS and setup up for my machine. But having stepped through the
    settings, nothing at all related to the HDD apears to have changed and
    yet it works. There is a couple of other minor adjustments that seem
    completely insignificant, but no matter, I'm now back working!

    I did not see any intsructions stating that you need to enter the bios
    and select default settings - I would have thought that this was an
    easy thing to make it do automatically during the flash process.

    ANYWAY...... thanks to all those that offered suggestions. I realise
    that I am being extremely premature in signing off now, because I have
    not tried the CD or any external peripherals yet, but I will have good
    go at any further problems before bothering the group.

    Regards,
    Kev.
     
    BigNose, Nov 19, 2005
    #10
  11. BigNose

    peterfelgate Guest

    Now if you want to, you can force flash to the Intel P14 bios and go to
    a faster processor if need be, noting that this is essentially a
    one-way process (it is difficult to go back to the Dell bios in other
    words....)
     
    peterfelgate, Nov 20, 2005
    #11
  12. BigNose

    BigNose Guest

    One problem.... The CD Burner, appears to complete the burn, but cannot
    verify cos the disk is empty - it always worked before!. When I try the
    disk in another machine it too finds the disk to be blank (post an
    apparently succesful burn) The red burn light comes on, it takes ages
    and Nero reports success. Could this somehow be BIOS related?
     
    BigNose, Nov 29, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.