Black screen with 6800GT and ASRock 939Dual-SATA2

Discussion in 'ASRock' started by Ian, Jan 4, 2006.

  1. Ian

    Ian Guest


    I had a perfectly good machine (Asus A7V333, Athlon XP 2400+, 1GB RAM,
    Sparkle 6800GT, NVidia 81.85 drivers, Windows XP SP2, Viewsonic VP930 LCD
    monitor, etc.) and it ran all my games ok. However, I wanted more speed, so
    I swapped the motherboard for an ASROCK 939Dual-SATA2 and the processor for
    an Athlon64 3200+. I uninstalled all the VIA drivers for the A7V333
    motherboard - AGP, IDE bus master, etc. and rebuilt the machine in a new
    case with the same 2 hard drives, DVDROM, DVD R/W, floppy drive and power
    supply (Hiper 450W). Everything seemed OK, Windows booted up, it detected
    the "new" hardware, I installed the ULi drivers and re-installed the NVidia

    All seemed to be ok, I could play Doom3 and Quake 4, but when I tried FEAR
    or UT2004 or Halo, I'd get the introductory movies and sound, but only a
    black screen! With Half Life 2, I got a screen, but it wasn't working
    properly, with artifacts in the sky. None of the 3DMark benchmarking suites
    will run properly either. Is it just OpenGL applications that are working
    ok, and DirectX applications that are not? If so, or even if not, what's
    going on? Has anybody else had the same experience and how can I get round
    the problem?

    Ian, Jan 4, 2006
    1. Advertisements

  2. Ian

    Ian Guest

    Hi again,

    I have solved my own problem! Having read a number of posts in this and
    other newsgroups, it looked as though it could be the NVidia drivers that
    were at fault. So, I uninstalled the ULi AGP driver again and the 81.95
    NVidia drivers, rebooted, re-loaded the ULi AGP driver, re-booted and then
    installed the 78.05 NVidia drivers. Success - FEAR now starts OK, I've yet
    to test the others, but they should be the same. What's gone wrong in the
    8x.xx series drivers, then?

    Ian, Jan 4, 2006
    1. Advertisements

  3. Ian

    eventerke Guest

    My AsRock+6800 Ultra are working fine with the 81.x drivers - I even
    took a VIA machine install and moved it over just like you did. I did
    go ahead and do a repair install of Windows, though (not without a
    backup image of the system drive - the same procedure failed moving my
    'work' system over to the old gaming m/b)
    Did you use the chipset drivers from ULi? I heard there were problems
    with the AsRock ones.
    I started with 81.95 and now have 81.98 running - both worked great.

    Good luck,
    eventerke, Jan 4, 2006
  4. Ian

    Ian Guest

    Hi Kendt,

    Glad to hear you're doing fine with the 81.x drivers. I did use the ULi
    chipset drivers (integrated v 2.13)- read the same messages as you about the
    uncertainty in using the ASRock ones.

    It could be that my eventual success in getting rid of the problem was to do
    with the process of uninstalling both the ULI AGP driver and the NVidia
    drivers, and then re-installing in the right order with re-boots in-between.
    Seems a bit like black magic to me; I am a scientist though and like to
    understand what's going on! When I'm feeling brave I might try the 81.xx
    drivers again, but only with a system restore in hand in case things go bad


    Ian, Jan 5, 2006
  5. Ian

    Ian Guest

    Update - it doesn't look as though the problem was with the Nvidia drivers
    after all. I have installed version 82.12 with no black screen problem. It
    looks as though the order in which you instal the Uli AGP driver and the
    Nvidia drivers is crucial. Hope this helps somebody else!

    Ian, Jan 9, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.