Boot problem on a Asrock 939Dual-SATA2

Discussion in 'ASRock' started by Alain, Jun 16, 2006.

  1. Alain

    Alain Guest

    My Asrock 939Dual-SATA2 motherboard seems to have lost the ability to boot
    on the CD rom drive. I have selected the CD/DVD rom drive as first boot in
    the bios, but during the boot process when I am invited to press any key to
    boot on the CD I press some key but the mobo do not seem to detect it and
    then boot on the hard disk.
    My keyboard Logitech is on a PS2 ourlet and works well to open the bios, but
    not to boot on the CD/DVD drive. I tried to boot on other cds I have booted
    on before, but no luck!
    What could cause this problem, how can I make it work?
    I want to install Windows Server 2003 on my computer and I do not know where
    I could find some bootdisks to start the installation.
    Many thanks in advance!
    Alain
     
    Alain, Jun 16, 2006
    #1
    1. Advertisements

  2. Wait! The CDrom is your _first_ boot device and you have to press a key to
    boot it? Something is basically wrong; if the CDrom is present, and if a
    bootable CD is mounted, then booting the CD should happen with no
    intervention whatever.

    Are you sure you have a bootable CD mounted?
     
    Felger Carbon, Jun 16, 2006
    #2
    1. Advertisements

  3. Alain

    Alain Guest

    Of course. I first thougt my CD was not bootable, but when I tried other CDs
    I had booted from without any problem before, I did not get any luck.
    With all my different motherboards I always had to press a key if I wanted
    to boot from a CD.
     
    Alain, Jun 16, 2006
    #3
  4. Some CDs include a patch in their bootstrap that requires you to press a
    key or the boot will fail and the PC will then try to boot from the hard
    disk. This is to avoid problems when rebooting while installing some
    software. Perhaps this is what you are seeing here.
     
    Steven Saunderson, Jun 16, 2006
    #4
  5. Alain

    Alain Guest

    The problem is that the mobo do not apparently detect the pressed key and
    and therefore do not boot on the CD. :eek:( but why? I can enter the bios in
    pressing F2...
     
    Alain, Jun 16, 2006
    #5
  6. I think the file that displays "Press any key to boot from CD" is called
    BOOTFIX.BIN. I have just checked this file. It purges the keystroke
    buffer, displays the prompt, and then waits for a key until it times out
    and loads the hard drive #0 MBR.

    Do you get the prompt and a 5 or 10 second timeout ?

    The other thing I see in this file is that in certain circumstances it
    only checks if the Ctrl key is pressed rather than any key. Does
    pressing Ctrl help you ?
     
    Steven Saunderson, Jun 17, 2006
    #6
  7. Alain

    Alain Guest

    I tried to boot on my different bootable CDs by pressing the Ctrl key, but
    it was ignored just like the other keys.
    I checked the CDs and found boot.bin or bootfont.bin files but no
    bootfix.bin file.
    Some CDs who are supposed to be bootable (like the Win XP 64 bit and Win
    Server 2003 64 bit) do not even have a file with a .bin extention on their
    CD.
    So the mistery is still complete.
     
    Alain, Jun 17, 2006
    #7
  8. Alain

    Alain Guest

    Oh yes, I do get a prompt and about 5 sec timeout.
     
    Alain, Jun 17, 2006
    #8
  9. Alain

    C. Guest

    Maybe pointing to wrong drive.If only 1,do you have a spare sitting
    around?Will these cds boot on another computer?Spare keyboard to try with?

    C.
     
    C., Jun 17, 2006
    #9
  10. Perhaps the file is called something other than BOOTFIX.BIN now. The
    prompt and delay look like the same code.

    You mention that you have a PS2 keyboard. Can you check the BIOS
    options to ensure you are not disabling legacy PS2 devices or possibly
    enabling USB keyboard. I don't know if you have any such options but
    there might be something that disables your keyboard after POST
    temporarily.
     
    Steven Saunderson, Jun 17, 2006
    #10
  11. Alain

    Alain Guest

    I have 2 DVD writers, one NEC 3500 AG and one PLEXTOR PX 740 A on the
    secondary IDE channel.
    This particular bios offer me to boot on the NEC only and therefore I put
    the bootable CDs in that one..
    The strange thing is that I was able to install Win XP recently, booting off
    the CD placed in the NEC without any problem.
    The PS2 keyboard is not desactivated, I am taping this message on it and
    during the boot I can enter the bios by pressing a key.
    No I do not have a spare keyboard.
    You never had this kind of boot problem? I have had it on 2 Abit mobos
    before.
    @+
     
    Alain, Jun 19, 2006
    #11
  12. Alain

    C. Guest

    Never encountered this problem,but never owned an abit board.I have had
    trouble with dvd drives where it either quit reading dvd's or vice-versa as
    they have 2 lasers and one dies.Also with cd's that were not burnt properly.

    You've had this problem before?Did you find a resolution then?I'll stay away
    from abit then.

    What are you trying to boot up?Xp,vista,Linux,???Home burnt or oem disc?Try
    reseating your cables and the memory while you're in there.

    C.
     
    C., Jun 21, 2006
    #12
  13. Alain

    Alain Guest

    I tried to boot from a Windows Server 2003 install CD and when it did not
    work, I tried then to do it from a Windoes XP I was sure about because it
    worked perfectly before and it did not work either.
     
    Alain, Jun 22, 2006
    #13
  14. Alain

    Alain Guest

    I did not find a solution for the Abit Motherboards and since then I am
    staying away from them.
     
    Alain, Jun 22, 2006
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.