Can anyhone help? KV8-MAX-3 and serial sata drives - can't get XP to detect and load onto the drives

Discussion in 'Abit' started by bryer102, Jun 18, 2005.

  1. bryer102

    bryer102 Guest

    Does anyone know if it's possible to get XP to go onto the SATA raid
    array?

    When I put the XP CD in it goes so far press f6 but then it doesn't
    seem to think there are any drives to load onto.

    They don't show up in the bios either.

    The only way I seem to able to get it to work is by attaching an IDE
    drive. XP goes in ok then and when installed I can see and use the
    SATA drives although they still don't show up in the bios for boot
    order. I got to thinking it wasn't possible but now I see in PC world
    they're selling computers with only one serial drive so it must be.

    The system I built is a KV8-Max-3 with an Athlon 64bit 3200 socket
    754.

    Has anyone else had the same problem and can helpt? All that came
    with the board is a floppy with SATA drivers on. I load those but the
    drives still don't show up. TIA

    TOM
     
    bryer102, Jun 18, 2005
    #1
    1. Advertisements

  2. Of course. If it wasn't there'd have been an awful lot of unhappy owners
    these last few years.
    Do you actually hit F6 and load the appropriate drivers?
    If you can't see the drives at any point during the POST sequence, the
    chances are that you haven't enabled the RAID controller correctly in the
    BIOS. I've never played with a KV8, but if it's like pretty much every other
    board Abit have ever made, you'll have to enable the appropriate
    functionality in the BIOS. If you don't, it won't play.

    Once you do get it right, once you've loaded the drivers via the F6 prompt,
    you should be able to install WinXP straight onto your array.
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace nospam with pipex in reply address)

    The UK's leading technology reseller www.dabs.com
     
    Richard Hopkins, Jun 19, 2005
    #2
    1. Advertisements

  3. Yes. I don't have your motherboard but if the bios is similar to the
    NF7-S then you need to do a couple of things; Make sure you enable
    the Serial ATA Controller. Then get into the Raid Configuration
    Utility menu and create your Raid array. (See your Abit manual and
    how to do that)

    After that you should be able to insert your Windows XP CD and reboot.
    Press F6 when asked if you need to install additional drivers and you
    will need to insert that floppy with the proper Sata drivers when
    requested.

    Then it is just a matter of formatting your Raid drive, creating any
    partitions you want and installing the operating system.

    If you want your Raid drive to be drive C: then I suggest unplugging
    any IDE drive that you have in your system before you start. You can
    plug it back in after you have installed the operating system.

    Ak
     
    Alfred Kaufmann, Jun 19, 2005
    #3
  4. bryer102

    Conor Guest

    That's because you didn't press f6 to load the SATA drivers from the
    floppy.
     
    Conor, Jun 19, 2005
    #4
  5. bryer102

    Chucky Guest

    I have that M/B. What I did to fix that problem was Use SATA 3 & 4.
    Leave 1 & 2 empty
    I hope this helps

    Chucky
     
    Chucky, Jun 19, 2005
    #5
  6. bryer102

    Exocet Guest

    Hi Chucky

    Thanks for that.

    I have been trying all afternoon to get XP to load onto the serial
    drives. I get to the press f6 and press but then shortly afterwards
    it tells me there is no hard drives and aborts.

    I've tried every driver on the floppy that came with the board and
    still the drives aren't detected. If I load onto a IDE drive and have
    pressed F6 during installation the serial drives show up perfectly ok
    in winXP disc management.

    I'll try giving your advice a go and see what happens. Fingers
    crossed.
     
    Exocet, Jun 19, 2005
    #6
  7. bryer102

    bryer102 Guest


    Thanks Richard, but still no joy. I'm ok with the F6 thing and
    loading the drivers from the floppy that came with the board but XP
    still aborts saying there's no fixed drives. They do show up
    perfectly well if I put the system onto an ordinary drive but I can't
    see them anywhere in the bios.

    I'm gonna try that lead chucky gave about leaving out 1 and 2 see what
    happens. Thanks for your help it's much appreciated.

    Tom
     
    bryer102, Jun 19, 2005
    #7
  8. bryer102

    bryer102 Guest


    Thanks Alfred - Yes I've enabled the raid controller in the bios but
    still no joy. On start up you get an option to press f4 to enter the
    Raid but if you press it then it just says there is no discs again.

    Chucky apparently has the same board and got round it missing out 1
    and 2 and starting at 3 and 4. So I'll give that a go and see what
    happens. Thanks very much for your help I very much appreciate it.

    Tom
     
    bryer102, Jun 19, 2005
    #8
  9. bryer102

    bryer102 Guest

    Sorry chucky I use the exocet name on another group. Off to try your
    suggestion.....:eek:)

    Tom
     
    bryer102, Jun 19, 2005
    #9
  10. Then you really can't expect Windows XP to install. :-( If the Raid
    Utility says there are no drives then you have check that your drive
    cables, serial ATA and power are connected properly. I can see one
    drive possibly being faulty but not both.

    A long shot - I checked my manual and it says that the Serial ATA
    controller only supports Ultra DMA/ATA-100 or higher. What hard
    drrives are you using?

    Ak
     
    Alfred Kaufmann, Jun 19, 2005
    #10
  11. If the bios does not tell you that you have functional raid drives
    then Windows XP will not install.

    I hope that changing the drives over to different connectors helps.

    Ak
     
    Alfred Kaufmann, Jun 19, 2005
    #11
  12. Double check your bios settings:
    Sata Raid ROM should be enabled
    Onboard Raid Controller should be enabled
    While booting press Ctrl-F4 to get into the bios setup for serial ata
    raid.

    You motherboard has two Sata Raid devices - Via Sata Raid or SIL3114
    Sata Raid. Check the bootable add-in device in the bios. I could not
    see anything in the manual about the connectors making any difference.

    Good luck, I sure you will figure it out and get it working.

    Ak
     
    Alfred Kaufmann, Jun 19, 2005
    #12
  13. bryer102

    bryer102 Guest


    Well the drives are two Samsung SP1213C

    http://www.samsung.com/Products/Har...es/HardDiskDrive_SpinPointPSeries_SP1213C.htm

    and I have now successfully installed XP onto them set up as zero
    array, but only by doing the same as Chuck to get around the problem.
    ie: unplugging them from SATA 1 and SATA 2 on the motherboard and
    connecting them to SATA 3 and SATA 4. Miraculously they showed up
    instantly on start up and pressing F4 instead of the usual no drives
    it gave me the Raid setup and off I went.

    I'm wondering now if possibly there should be some jumper settings on
    the drives themselves effectively making them Master drives in order
    that they work on SATA 1 and SATA 2 ? Does anyone think this might be
    the cause? There is only a small slip of paper with the drives and
    for what looks like the jumper pins it says Jumper pin then in
    brackets (factory use only) So why they won't work in the Main SAtA 1
    and 2 sockets I don't know.

    I've quite had enough for today but as you can imagine I'm really
    pleased at finally getting the system onto the serial drives and I'm
    really grateful for all the help you guys have given me.

    Tom
     
    bryer102, Jun 20, 2005
    #13
  14. I don't think you have Master or Slave drives with Serial ATA.
    It might be because your motherboard has two different raid devices,
    Via and Silicon Image. Maybe somewhere in your bios you can choose
    one or the other.

    Abit makes good motherboards and problems usually have workarounds. My
    motherboard NF7-S v2.0 only has one raid device - Silicon Image and I
    have never been happy with it. Abit had to add a special delay option
    in the bios to stop the data corruption with my Sata Maxtor drives.
    It has always bugged me and I thought with the latest ABit bios and
    Silicon Image Raid drivers it was fixed - I was wrong.

    When it works just be happy. :)

    Ak
     
    Alfred Kaufmann, Jun 20, 2005
    #14
  15. bryer102

    bryer102 Guest


    You're probably right Ak :eek:) I may try contacting Samsung or Abit and
    ask them but as to whether they will reply or not is another thing. I
    may try and find others here who have actually got the same board and
    see if anyone made any advancements such as Chuck - but for now the
    when it works just be happy philosophy is good. :eek:) Thanks for all
    your help.

    Tom
     
    bryer102, Jun 20, 2005
    #15
  16. I'm not sure why you would need to contact Samsung, as they're unlikely to
    be able to tell you anything about the specifics of Abit hardware. As for
    Abit, they might advise you to read your manual, which is, funnily enough,
    what I've just done.

    If you have to connect your drives to SATA3/4/5/6 in order to get a RAID
    array built, you're using the Silicon Image 3114 controller rather than the
    one included in the VIA 8237 southbridge.

    As Alfred says, if you want to use the VIA controller, you need to make sure
    that the BIOS Integrated Peripherals/Onboard IDE Device/SATA RAID ROM
    parameter is enabled. Also, in the Advanced System Setup page, you need to
    make sure that the Bootable Add-In Device (assuming this parameter is there)
    is set to Onchip SATA RAID.

    Once that is done, you will likely have to hit a key combination during the
    POST sequence in order to enter the VIA SATA RAID setup utility and create
    your array.

    Once all that is done, hitting F6 and loading the VIA SATA RAID drivers from
    the floppy supplied with the board should get you in business.
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace nospam with pipex in reply address)

    The UK's leading technology reseller www.dabs.com
     
    Richard Hopkins, Jun 21, 2005
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.