Can boot to Classic but won't run under Tiger

Discussion in 'Apple' started by duklaa, Aug 10, 2005.

  1. duklaa

    duklaa Guest

    I am having a torrid time trying to get Classic to run under Tiger
    10.4.2 on my Powerbook G4 (1 GHz, 512 MB SDRAM).

    Basically, the progress bar comes up. I see the "Welcome to Mac OS"
    screen when the progress bar is about 2%, and then it just hangs there.
    (I have Classic 9.2.2 installed and it works fine if I boot into it.)

    So far I have tried all of the following:
    - Turning off extensions
    - Creating a new user account and running classic from it.
    - Deleting ~/Library/Classic and having Classic create it again.
    - Turning off "Use preferences from Home Directory"
    - Replacing the "System Folder" with one from OS9General.dmg on the
    Software Restore disk.
    - Deleting the Recent Servers, Recent Documents, and Recent
    Applications in the OS 9 System folder. HD->System Folder->Apple Menu
    Items.

    None of the above fix the problem. Now I am clueless as to what else I
    could do.

    Any help on troubleshooting this will be greatly appreciated.

    Thanks!
    -D
     
    duklaa, Aug 10, 2005
    #1
    1. Advertisements

  2. duklaa

    M-M Guest

    Did you open the Classic Pref Pane in X and select your system folder?

    m-m
     
    M-M, Aug 10, 2005
    #2
    1. Advertisements

  3. duklaa

    duklaa Guest

    Yes. It's properly selected.
     
    duklaa, Aug 10, 2005
    #3
  4. duklaa

    Ernie Klein Guest

    Just to be sure we are on the same page... I see the "Welcome" message
    but no progress bar. It then changes the message to "Starting up" with
    a progress bar. Is that what you are getting?

    Assuming so, has it ever worked on this machine with this OS?

    If so, when did it stop working?

    It sure sound like a OS9 extension (even though you started with
    extensions off), I am not sure what that really does when starting under
    classic? I would try moving (temporarily) the extensions to another
    folder. You might have some extension that boots OK but won't run under
    classic.

    BTW, just to keep the terminology correct: OS 9.2.2 is an operating
    system. You boot into OS 9.2.2, not Classic. Classic is an OS X
    process which only runs under OS X and starts OS 9 as an OS X process.

    --
    -Ernie-

    "There are only two kinds of computer users -- those who have
    suffered a catastrophic hard drive failure, and those who will."

    Have you done your backup today?
     
    Ernie Klein, Aug 10, 2005
    #4
  5. duklaa

    duklaa Guest

    Yes, you are right about the terminology. My bad.

    Addressing the questions you raise:

    - The progress bar I refer to is the "Classic" progress bar, that show
    up at the top. Not in the OS 9.2.2. In the OS 9.2.2 part (which I get
    by clicking the "Show Details" arrow), I just see "Welcome to Mac OS"
    screen and then it hangs.

    - It (i.e. Classic) has never worked since I upgraded to Tiger. It
    worked fine under Jaguar. I never needed to try it while I had
    Panther. So I don't know.

    - I have tried moving extensions, but I still have the same problem.

    More suggestions would be greatly appreciated.

    Thanks so much for all the help so far.

    -D
     
    duklaa, Aug 11, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.