Can't access samba share from wireless connection

Discussion in 'Apple' started by blixel, Jan 13, 2005.

  1. blixel

    blixel Guest

    I bought an iBook a couple of months ago. My first Mac ever.

    I have a Linux Samba share on my LAN. The IP address for the Linux
    machine is 192.168.1.3

    My wireless access point is configured so that it puts wireless clients
    on a separate subnet. My wireless clients get an IP address of
    172.16.1.x

    My wireless Linux Desktop has no trouble accessing the Linux Samba
    share.

    My iBook has no trouble accessing the Linux Samba share as long as I
    have the iBook on a wired connection. When the iBook is on the wired
    connection, it is part of the LAN and gets a 192.168.1.x IP address.

    However, when I'm at the other end of the house and using the airport
    card in the iBook, the iBook gets a 172.16.1.x address and can not get
    to the Samba shares. OSX acts as though it has to be on the same
    subnet as the Samba share in order to "see" them. But again, my other
    wireless clients have no trouble accessing the Samba shares through the
    router from one subnet to another. Is this a limitation builtin to
    OSX?
     
    blixel, Jan 13, 2005
    #1
    1. Advertisements

  2. blixel

    blixel Guest

    Hate to reply to my own post, but it's been over 2 weeks since I posted
    this question and I still haven't found an answer on my own. If anyone
    has any thoughts, I would certainly appreciate it.
     
    blixel, Jan 30, 2005
    #2
    1. Advertisements

  3. Make sure that your wireless Linux Desktop is configured as the Master Browser
    for the 172.16.1.x network and that your Linux Server at 192.168.1.3
    has the "remote announce = 172.16.1.255" in its /etc/smb.conf or
    /usr/local/etc/smb.conf file. If your Linux server at 192.168.1.3
    is a wins server, put "wins server = 192.168.1.3" in the /etc/smb.conf on
    your mac.

    See 'man smb.conf' for details.
     
    read_the_signature, Jan 30, 2005
    #3
  4. blixel

    blixel Guest

    Thanks for the help. Is there a way to "tell" the Mac to look at
    192.168.1.3 for the share? In the finder, I have right clicked in the
    empty space at the top, and gone to Customize Toolbar, and have added
    the "Connect" option to my toolbar. But even if I type in the IP
    address directly, it still doesn't connect to it. Is there an
    alternative way to specifiy the IP?

    My samba server is actually a Linksys NSLU2. The only way to configure
    it is through a web interface and it doesn't have the options you
    mentioned. And I can't ssh or telnet directly to the box to configure
    it by hand. I liked the NSLU2 because it was small, didn't make any
    noise, didn't generate any heat to speak of, and only used a small
    amount of power. Since my old Linux server was only a file server, it
    seemed like a huge waste of electricity and physical space.
     
    blixel, Jan 31, 2005
    #4
  5. blixel

    blixel Guest

    Another point I should mention here is this. If I configure my
    router/firewall so that my wireless connections are bridged to my LAN -
    so that the router/firewall doesn't differentiate between wired and non
    wired connections - then I can access my NSLU2 shares wirelessly from
    the iBook.

    So the problem is obviously that for some reason or another, the Mac
    doesn't like being on a different subnet from the file shares. And
    again I'll point out that my wireLESS Linux Desktop has no problem
    accessing the NSLU2 shares from subnet to subnet.

    Is there a config file on the Mac where I can specify the 192.168.1.x
    subnet to be part of the Network search?
     
    blixel, Feb 1, 2005
    #5
  6. I don't know why your Linux NSLU is able to go accross subnets. A look at
    the smb.conf file on both your Linux desktop and NSLU might reveal why.
    All that I can tell you is that you need to propogate your SMB browse
    SMB browse lists from one subnet to the other, see "remote announce" and
    "wins server" in the manual page or find a good samba book.
     
    read_the_signature, Feb 2, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.