Can't boot from SCSI CD-ROM drive when IDE DVD drive present

Discussion in 'Asus' started by Montana Pete, Feb 18, 2005.

  1. Montana Pete

    Montana Pete Guest

    I have a P4C800E with a Plextor SATA DVD drive. I want to run the DVD
    drive in enhanced mode for performance when reading and writing DVD's
    but I also want to be able to boot into DOS to run Norton Ghost. I
    also have a couple of Plextor UltraPlex SCSI drives on this system. Up
    until yesterday everything worked fine. If I wanted to boot from a CD
    I put it in the first UltraPlex drive and rebooted the system. Then I
    hit F8, got the popup boot menu, selected the plextor SCSI CD-ROM
    drive from the list and booted successfully. Today, al of a sudden,
    the system tries to boot from the SATA DVD drive, and since it is
    empty I get a "Put a disk in the drive stupid" message. But, of
    course, if I do it croaks because DOS can't handle a DVD running in
    enhanced mode.

    I have reset the BIOS to it's defaults and then reconfigured all the
    settings. I am running the latest BIOS. I have checked the settings in
    the SCSI controller and it is fine. For some reason, all of a sudden,
    it wants to go to that SATA drive even though I have selected the SCSI
    drive from the list.

    Anyone have any ideas?
     
    Montana Pete, Feb 18, 2005
    #1
    1. Advertisements

  2. Montana Pete

    Montana Pete Guest

    Replying to my own post:

    I found out what was going on . Although the bios on the controller
    card said that the bootable CD had been assigned to drive a: and drive
    a: was now drive B:; it lied, or the bios over-rode it. In any event I
    took the floppy that I used to make the bootable CD and put it in
    drive a:. The system then boots from the floppy and loads the carom
    drivers, makes the carom the default drive and loads Norton Ghost just
    as if it booted from the carom. All works fine. It is just irritating
    that I have to put the floppy in every time I want to take a ghost
    image when the system would actually boot from the CD just a few days
    ago.
     
    Montana Pete, Feb 19, 2005
    #2
    1. Advertisements

  3. Montana Pete

    Nickeldome Guest

    Your cdrom bootdisk will become a: . The content of the cd will become
    whatever driveletter is assigned to it from the system. If you have HD
    partitions c: and d: your cdrom will become e: . When booting from floppy
    your cdrom is not the bootdevice, but will only be reconized as romdrive
    e: because of the drivers loaded from a: . It is possible to just boot from
    cdrom, but you have to make sure the settings are correct in both the
    bios from the scsicard and from the P4C800E. Make sure you see it
    listed in the bootsequence screen and put is just below the floppy.
    Then it should work. If you do not see it listed, there is something
    wrong with the setting of your scsicard bios.

    Nickeldome
     
    Nickeldome, Feb 20, 2005
    #3
  4. Montana Pete

    Montana Pete Guest

    That's the theory alright. Almost all that is happening. The cdrom is
    recognized as a boot disk, then drive A: is assigned the cdrom boot
    disk and physical drive A: is assigned to drive B: (it says) but when
    the system actually tries to boot it can't find the boot disk portion
    of the CD. It then goes down the list and tries to read the physical
    floppy drive A: and then it tries to read the SATA DVD drive. So
    somewhere along the way that assignment of A: to the boot portion of
    the CD is lost. The strange thing is that up until a few days ago
    (last Wednesday to be exact) this used to work. The next day it
    wouldn't work, and I hadn't even touched the computer. I have tried
    every setting I can think of in the BIOS to get this to fly.
    Everything looks ok, the cdrom shows up as an available boot device
    indicating that the bios knows its a bootable CD, it just can't be
    found when it actually goes to boot.
     
    Montana Pete, Feb 22, 2005
    #4
  5. Montana Pete

    Nickeldome Guest

    Well, this is very strange. Especially because it would boot the other
    day and after that it refuses. Strange thing is, you can boot when
    loading the driver from floppy, but you can't when booting directly
    from the bios. You could try to reflash the bios, because to me it
    sounds there is something wrong there, but it's just a long shot.
    I presume you've tried different cd's .....

    Nickeldome
     
    Nickeldome, Feb 23, 2005
    #5
  6. Montana Pete

    Montana Pete Guest

    It is, it is....Strange indeed. Yes, I have tried different CD's. I
    reflashed the bios to the latest one, 1021d-02. I made sure I reset
    all the BIOS settings after the flash. Since then I have tried every
    combination I can think of in the BIOS settings and still no-go. One
    of these days I am going to take a couple of hours and see if I can
    track it down. Thanks for the thoughts.
     
    Montana Pete, Feb 26, 2005
    #6
  7. Montana Pete

    Nickeldome Guest

    One more thougt tho. Have you tried an older bios like 1019
    as well ? You never know....

    Nickeldome
     
    Nickeldome, Feb 27, 2005
    #7
  8. Montana Pete

    Montana Pete Guest

    I was using 1019 when it failed. I just upgraded in the vain hope that
    a newer BIOS would fix the problem. If you think of anything let me
    know..
     
    Montana Pete, Mar 2, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.