Can't Eject a Volume

Discussion in 'Apple' started by Nick Naym, Feb 18, 2014.

  1. Nick Naym

    Guest Guest

    where's you proof that app developers write files nonatomically?

    have you disassembled all of the millions of apps out there? (no)

    or are you talking out your ass, as usual? (yes)
    you're not the only software developer in this world and just because
    you say something does not make it fact nor is it any sort of proof.

    the reality is that it's not anywhere near the disaster you claim it to
    be.

    although it's technically possible that it could happen, actual real
    world experience indicates that it's rare.

    easy to test - force quit and see if anything is corrupted. repeat a
    bunch of times.
    so what? i know a lot of apple engineers and have worked with many of
    them at one point or another.
    notice that *you* haven't offered *any* proof at all.

    nobody said it won't ever happen. you are as usual, moving the
    goalposts.
    i'm not moving a thing.

    apps can crash more than one way. sometimes they are terminated by the
    system and sometimes they hang and need to be force-quit.

    obviously, i'm referring to the latter.

    that's why there is an option to force-quit. if every crash was
    automatically terminated, such an option would not be needed.

    a 'professional developer' would have known that.
    pot meet kettle.

    you have yet to provide any proof. all you've said is it's true because
    you said it's true. it doesn't work that way.

    that makes you a lying hypocrite.
    other than you, that is.

    if we assume what you said above is true, where force-quitting an app
    is almost certain to corrupt files, then it must be a huge problem.

    you can't even keep your own story straight.
    it *can* happen, but it doesn't happen all that often. in fact, it's
    relatively rare.

    real world experience always trumps theoretical possibilities.

    i force-quit finder a couple of times a month because it's a buggy
    piece of shit and i haven't had any problems with corrupted files. i've
    needed to do this since the early days of os x.

    xcode is much worse. on average, i need to force quit it several times
    a day, and it keeps a *lot* of stuff open. not a single problem there
    either.

    i have seen xcode corrupt files *without* force-quitting, simply by
    closing the project from the menus.

    that means what you're saying is wrong. but you'll never admit it.
    more bullshit. none of that is true.
    you said finder is not fragile, without any facts to back up your claim.

    the reality is that finder is very fragile. it's very buggy and apple
    has zero interest in fixing it. some of the bugs have been there for
    over 10 years and it's not particularly hard to make it crash either.
    apple says 'works as designed'. interesting design goal, to crash.

    as i said above, i have to force-quit finder every so often and have
    yet to lose *anything*, and that goes back to the early days of os x.

    that's real world proof.
    i haven't changed anything. you are a liar.
     
    Guest, Feb 22, 2014
    #21
    1. Advertisements

  2. Nick Naym

    Guest Guest

    lots of apps leave files open. that is not the problem.

    the issue is what happens on a force-quit and almost always, the only
    data that is lost is anything changed since the last save.

    many apps autosave so the amount of loss is minimal, if anything.

    it's extremely unlikely that the files will be corrupted.

    that's not to say it can't ever happen, but it's relatively rare.
     
    Guest, Feb 22, 2014
    #22
    1. Advertisements

  3. Nick Naym

    Alan Browne Guest

    What I wrote was in reply your claim:
    "... very unlikely because files are written atomically."

    Some are. Some are not. lsof your system disk with some general apps
    open. Oops. Correction: many are not.
     
    Alan Browne, Feb 22, 2014
    #23
  4. Nick Naym

    Alan Browne Guest

    Clarification: meant "many are not closed".


    --
    Those who have reduced our privacy, whether they are state
    or commercial actors, prefer that we do not reduce theirs.
    - Jaron Lanier, Scientific American, 2013.11.

    Privacy has become an essential personal chore that most
    people are not trained to perform.
    - Jaron Lanier, Scientific American, 2013.11.

    ... it may be that "in the cloud" really isn't the best term
    for the services these companies offer. What they really
    want is to have us "on the leash."
    -David Pogue, Scientific American, 2014.02
     
    Alan Browne, Feb 22, 2014
    #24
  5. Nick Naym

    Lewis Guest

    It's funny how wrong he is, considering he never admits it.
     
    Lewis, Feb 22, 2014
    #25
  6. Nick Naym

    Alan Browne Guest

    Inconvenient truths never stopped him.
     
    Alan Browne, Feb 22, 2014
    #26
  7. Nick Naym

    Alan Browne Guest

    Never liked Safari. My peeve is actually that the "favourites bar" does
    not show site icons. Almost all of my favourites are well represented
    by the icon. Does not take much room so lots of icons.
    Chrome:
    https://www.dropbox.com/s/t1y2o12p8tyiw8u/Screen Shot 2014-02-22 at 12.31.21.jpg

    But no, the idiots at Apple insist on text so it takes longer to find a
    given mark - I do abbreviate them, but still it's just plain ugly.

    I do use Safari to watch Netflix now as Chrome doesn't play perfect with
    Netflix for some content. (I pipe the Mac to the Apple TV to the big
    screen and use the Apple keyboard and mouse (bluetooth) to control the
    mac from that room. Kinda nifty really).
     
    Alan Browne, Feb 22, 2014
    #27
  8. Nick Naym

    Alan Browne Guest

    In my industry such an approach could get you disciplined, fired, fined
    or de-licenced. Criminal charges are not out of the question.
     
    Alan Browne, Feb 22, 2014
    #28
  9. Nick Naym

    Alan Baker Guest

    Better yet:

    lsof | grep <someUniquePartOfTheVolumeInQuestion'sName>
     
    Alan Baker, Feb 22, 2014
    #29
  10. Nick Naym

    Lewis Guest

    You use you mac to watch netflix that you send to your appletv?

    Why not use netflix on the AppleTV?
     
    Lewis, Feb 22, 2014
    #30
  11. Nick Naym

    Alan Baker Guest

    Cool!
     
    Alan Baker, Feb 23, 2014
    #31
  12. Nick Naym

    Barry OGrady Guest

    Have you tried adjusting the volume control? Boom Boom!
     
    Barry OGrady, Feb 25, 2014
    #32
  13. Nick Naym

    Alt

    Joined:
    May 14, 2015
    Messages:
    1
    Likes Received:
    0
    Thanks for the tip. That worked great, without force eject or reboot. lsof reported that Preview (even though Preview was closed) was accessing the remote volume. I opened Preview, opened a random local doc, closed preview again. lsof then reported no open files, and Eject worked great, as it should. Thanks for the lsof ! grep Volumes tip!!!!
     
    Alt, May 14, 2015
    #33
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.