can't enter BIOS on HP-KAYAK

Discussion in 'HP' started by Stephan Weber, Jan 2, 2008.

  1. Hello NG,

    i have here a HP-Kayak-XU800. Some years ago, the original Windows-
    Installation was removed and instead Linux installed. When i now switch
    it on, it shows the HP-BIOS-Screen with the Menu-Point "F2 for BIOS
    Setup", but if i press F2 nothing happens and the Workstation boots
    normaly the installed Linux. I wich to install Windows again, but didn't
    get the maschine to boot from CD.

    Any ideas ?

    with kind regardes, Stephan Weber
     
    Stephan Weber, Jan 2, 2008
    #1
    1. Advertisements

  2. Stephan Weber

    Ben Myers Guest

    There is a possibility that the F2 key has been disabled, sometimes done for
    security to prevent people from tampering with a computer.

    Be careful to disconnect the computer from the electric wall current when
    working inside.

    Open up the chassis and either remove the silver coin-sized battery from the
    motherboard or find the jumper setting on the motherboard to reset the CMOS. If
    you remove the battery, wait a minute or two, then re-insert it. Thereafter, you
    should be able to access the CMOS.

    The other possibility is that the F12 key will give you the option to boot from
    your Windows CD. F12 is a popular choice among BIOSes for this option... Ben
    Myers
     
    Ben Myers, Jan 2, 2008
    #2
    1. Advertisements

  3. * Ben Myers:
    Certainly not. Besides that there is no way to do that on a Kayak, it
    would be idiotic to disable the key that's the only way to enter the
    BIOS. That's why BIOS passwords have been invented.

    Benjamin
     
    Benjamin Gawert, Jan 3, 2008
    #3
  4. * Stephan Weber:
    Yes. It's very likely that your timing just isn't right. On most older
    Kayaks even when the F2 prompt is visible for several seconds the point
    of polling the key is usually very short. Additionally, some monitors
    need some time until they wake up from standby so depending on your
    display you might see the first reaction already when the polling point
    is over. Try this: Switch on the computer, wait say 2-3 seconds, and
    then hit F2 around every second until the F2 prompt changes to "Entering
    SETUP" or something like that. This usually works.

    Benjamin
     
    Benjamin Gawert, Jan 3, 2008
    #4
  5. Stephan Weber

    Ben Myers Guest

    I mis-spoke. Many BIOSes have the option to HIDE the message telling the user
    to press the F2 key and/or the F12 key... Ben Myers
     
    Ben Myers, Jan 3, 2008
    #5
  6. Am Thu, 03 Jan 2008 13:40:21 +0100 schrieb Benjamin Gawert:
    I have tried it: no success ! I tried it more than 5 times, every one
    with a little different timing, but without other results.

    Stephan Weber
     
    Stephan Weber, Jan 3, 2008
    #6
  7. Stephan Weber

    craigm Guest

    Did the PC originally come with a PS2 keyboard and are you using a PS2 or
    USB keyboard? Your BIOS may not recognize a USB keyboard.

    craigm
     
    craigm, Jan 3, 2008
    #7
  8. Stephan Weber

    Ben Myers Guest

    The brute force method is to power up the computer while holding down the F2 key
    and some other keys for good measure. This often forces the BIOS to recognize
    a defective keyboard and to offer the option to enter the CMOS setup.

    Do the keyboard Num Lock, Caps Lock and Scroll Lock LEDs blink as soon as you
    turn on the power? If not, the keyboard is defective, or (as someone else
    suggested) the system does not work properly with a USB keyboard... Ben Myers
     
    Ben Myers, Jan 4, 2008
    #8
  9. * Stephan Weber:
    Ok, then as others suggested check the keyboard (Kayaks prefer PS/2
    types as even the machines with legacy USB support are very sensible
    regarding the type of USB keyboards they accept) or better yet, replace
    it with another one. Check that the Num Lock/Scroll Lock/Caps Lock LEDs
    flash up shortly during the BIOS sequence.

    If that all doesn't work the keyboard controller might be broken. Most
    people think that PS/2 connectors are hot-plug capable when in fact
    they're not (at least not on desktop computers like the Kayak, Servers
    usually have hot-plug capable ports). Removing or connecting a PS/2
    device (mouse/keyboard) when the machine is powered up carries the (very
    high) risk of frying the keyboard controller that's in the chipset. If
    this is the case then all you can do is to hope that the BIOS has legacy
    USB support, that legacy USB support is enabled, and try an USB
    keyboard. Or replace the system board.

    Benjamin
     
    Benjamin Gawert, Jan 4, 2008
    #9
  10. Am Thu, 03 Jan 2008 23:18:59 -0500 schrieb Ben Myers:
    In this case the BIOS shows the keyboard-error with the 2 Options: F1 for
    continue (the systems boots from HD); ENTER to show the detailed error
    information (but no way to enter the BIOS).
    Yes they do ! I tried my standard-used MS-Wireless-Desktop (without Leds)
    over a console switch (which i use right now) and a solo Cherry-Keyboard
    (Din-Connector with PS/2-Adapter and with Leds; i have no USB-Keyboard
    available)

    I tested also the F8-Key (for Boot-Menu, hopping that this offers the
    posibility to booz from CD) without any success. The F6-Key for the
    Adaptec-SCSI-BIOS after the main-bios-screen works fine (i can enter the
    adaptec-BIOS without any problems).

    Stephan
     
    Stephan Weber, Jan 4, 2008
    #10
  11. * Stephan Weber:
    You should get hold of a plain standard generic PS/2 keyboard (no
    wireless thingie which needs a longer initialization phase than a wired
    keyboard, and definitely no AT keyboard with PS/2 adapter as some of
    these keyboards draw more power than the PS/2 ports of these machines
    can deliver) and try again.

    Benjamin
     
    Benjamin Gawert, Jan 4, 2008
    #11
  12. Am Wed, 02 Jan 2008 21:28:33 +0000 schrieb Stephan Weber:
    Got it !!!
    Thanks for the help, now how i made it:

    Open the case, that switch1 to BIOS-Recovery-Mode-on-next-boot, that's
    all. After the next boot i was directly in the BIOS and after setting
    switch1 back, i can now enter the BIOS by pressing F2.
    So there seems to be a possibility to DISABLE the BIOS totaly, probably
    an empty BIOS-Password !? I think i don't want to find out how i can set
    this up, because i'm happy with the actual setting ;-)

    best wishes, Stephan Weber
     
    Stephan Weber, Jan 4, 2008
    #12
  13. * Stephan Weber:
    No, you can't disable the BIOS Setup in any Kayak (and I don't know of
    any PC that allows this). If a password had been set you'd have been
    prompted for it.

    It's much more likely that the NVRAM contents got hosed somehow which
    can lead to unpredictable behavior. By resetting the BIOS you erased the
    NVRAM with default settings.

    Hopefully for you this fix is permanent as such things usually happen
    when the NVRAM is dying.

    Benjamin
     
    Benjamin Gawert, Jan 5, 2008
    #13
  14. Stephan Weber

    Ben Myers Guest

    There were countless NVRAM failures on early Pentium systems caused by Windows
    95, which updated the NVRAM with PnP configuration data every chance it got,
    even if the NVRAM content was unchanged by the update. Since then, the life
    expectancy of NVRAM has gotten better and better along with the advances
    improved flash memory technology. Nevertheless, one should never reject the
    possibility that the NVRAM on a motherboard has failed... Ben Myers
     
    Ben Myers, Jan 5, 2008
    #14
  15. Stephan Weber

    Barry OGrady Guest

    Barry OGrady, Jan 6, 2008
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.