Can't find Ethernet Controller driver for Aspire 5630

Discussion in 'Acer' started by stevadorebob, May 5, 2007.

  1. stevadorebob

    stevadorebob Guest

    Hi,
    I have a new Aspire 5633WLMi which I believe is an Aspire 5630 for
    some purposes. It arrived with Vista installed but the wireless
    adaptor wouldn't connect to my router, so I went back to XP and now
    that works.
    When I went to the Acer Europe site The only drivers I could find were
    for the Aspire 5630. I've installed these and all seems to be in place
    and functioning except for: Device Manager> Network Adapters> Other
    Devices >Ethernet Controller, which has a big yellow ? and !.

    I've tried installing the three Broadcom Lan Driver options available
    in the Acer site, XP drivers folder but each time the Windows "Found
    New Hardware" driver install process fails to find the driver it's
    looking for and the error symbol reappears. Can anyone please help?

    Regards,
    Bob
     
    stevadorebob, May 5, 2007
    #1
    1. Advertisements

  2. do the reinstall o f the drivers with the wifi switch in the off position...
     
    Christopher Syn, May 6, 2007
    #2
    1. Advertisements

  3. stevadorebob

    stevadorebob Guest

    That worked., :)
    Thanks very much.

    Regards,
    Bob
     
    stevadorebob, May 6, 2007
    #3
  4. stevadorebob

    vicarious

    Joined:
    Aug 22, 2007
    Messages:
    1
    Likes Received:
    0
    where did you happen to find that driver name? I have the aspire 5630, and I can't get it to work... broadcoms files arent .exe, they're .cat, which I've NEVER seen before.
     
    vicarious, Aug 22, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.