can't get SATA working on P4G8x Deluxe

Discussion in 'Asus' started by CraiginNJ, Aug 28, 2005.

  1. CraiginNJ

    CraiginNJ Guest

    I can't seem to get SATA drives to be recognized on my P4G8x Deluxe
    board. Can you help? Here's this situation:

    1. I originally had installed the Silicon Image RAID drivers during
    initial Windows XP Pro installation, as per instruction, assuming I
    would someday need that to use SATA at all even if I never used RAID
    features. The current Silicon Image RAID drivers on the PC are the
    current ones available from Asus (version 1.0.0.22 10/17/2002) and
    Windows won't let me update it since it's already current. (BTW, I
    think I tried once a couple of years ago to upgrade to a more current
    version from the SI web site, but it locked up my PC and I had to
    restore my PC from an image backup.) Otherwise, Windows is currently
    up to date with all patches & fixes (SP2 + beyond).

    2. I've plugged in the Samsung sp2504c power cable & SATA cable to
    the SATA1 port on the motherboard.

    3. BIOS is set up for Onboard ATA device = enable and Onboard ATA
    device first = yes. (BTW, I've also tried "no" with the same
    results.) I do not have "SCSI" in the boot sequence because I only
    want this SATA drive as secondary storage right now. There's no sign
    in the BIOS that this SATA drive exists.

    4. SATA Raid firmware can be entered during boot sequence (after the
    BIOS) if the SATA drive is connected. It does list the SATA drive in
    SATA interface position 0 and reports its full capacity size (and
    nothing in position 1), but it won't let me create a RAID set (of 1
    drive) using it, reporting "Not enough single devices to create RAID
    set." Nor will it let me delete any RAID set -- it seems to think
    there is none. It does offer to let me do a low-level format of the
    disk, but I haven't dared try that yet (I don't want to screw things
    up worse).

    5. When I get to Windows, Windows does not recognize the SATA drive.
    What's more, in Device Manager the "Silicon Image SiI 3112 SATA Raid
    controller" is "disabled" and whenever I try to enable it my PC
    instantly reboots. I've seen two things happen after that reboot:
    Either (1) the PC just reboots, and everything looks the same as
    before, including the Silicon Image controller is still disabled, ...
    or (2) the PC stops on reboot because it is no longer able to
    recognize the existence of the boot primary IDE drive (nor the SATA)
    and I don't have an alternative set up (e.g., no boot floppy in floppy
    drive). In the latter case, I can undo this damage by disconnecting
    the SATA drive completely and rebooting; somehow that enables the BIOS
    to see the IDE HD again.

    6. BTW, the Samsung sp2504c has jumper than can be used to force it to
    limit itself to 1.5Gbps instead of automatically adjusting up to
    3.0Gbps if supported. I haven't played with that because it seems the
    drive is seen by the Sil Img firmware already.

    What's up? Is there a solution for me ... other than replacing the MB
    with a completely modern one a little sooner than I'd like?

    Craig in NJ
     
    CraiginNJ, Aug 28, 2005
    #1
    1. Advertisements

  2. CraiginNJ

    KC Computers Guest

    I can't seem to get SATA drives to be recognized on my P4G8x Deluxe

    Some SATA controller chips don't properly work with newer SATA 2 (3.0Gbps)
    unless the drive is jumpered to SATA 1 mode (1.Gbps). I recommend
    changing the drives jumper first to see what happens.
     
    KC Computers, Aug 29, 2005
    #2
    1. Advertisements

  3. CraiginNJ

    CraiginNJ Guest

    Yes, the drive came with a slip of paper mentioning the 1.5 jumper
    being needed in rare cases; but no, using the jumper didn't help --
    same result as I reported above.

    BTW, I also tried using "low level format" (before trying the jumper)
    but it just seemed to freeze up the PC. There was no formatting
    progress indicator and keystrokes had no ... except Ctl-Alt-Del.

    Is there anything else that is supposed to be done to access SATA
    drives from a P4G8x Deluxe? Maybe my MB is simply defective?

    Craig in NJ
     
    CraiginNJ, Aug 29, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.