Can't get USB 2.0 to work on P6x58d-e, running Windows 10

Discussion in 'Asus' started by Deepmojoman, Feb 9, 2022.

  1. Deepmojoman

    Deepmojoman

    Joined:
    Feb 9, 2022
    Messages:
    1
    Likes Received:
    0
    To be more specific: I am running Windows 10 21H2, and have gotten the P6x58d-e up and running pretty well, except for this problem: the USB Ports 5/6 and 7/8 are not working. They are sending power to USB devices (mice, etc.) but not transmitting any info (I am speaking specifically about the ones that connect to a breakout board to the back of the chassis, and going to two ports at the front of the chassis).

    The USB 2.0 ports that come out of the Rear Panel (1/2 and 3/4) all work fine (as does USB 3.0).

    In looking at Device Manager, it is saying that I the system is having trouble updating drivers for Intel ICH10 Family USB Universal Host Controller ("The driver installation file for this device is missing a necessary entry.") I am thinking that this is somehow related to the issue I'm dealing with, but I am scared to start replacing any Southbridge drivers I presently have up and running (and I am assuming the NB/SB drivers are all Win7, seeing as that's the most recent ones written (yes? no?), with any other driver, the effects of which I don't yet fully understand, and in so doing exchange a pretty good situation with a much worse situation, due to unexpected results.

    I was wondering if anybody out there has had anything like this trouble, and how you overcame it, if you did?
     
    Deepmojoman, Feb 9, 2022
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.