Can't install SATA drive on P4C800 Deluxe

Discussion in 'Asus' started by GLeger, Mar 16, 2005.

  1. GLeger

    GLeger Guest

    Anyone else having problems installing a SATA hard drive using ASUS P4C800
    deluxe?
    I checked many things. It seems the drive is ok. At first I thought the
    drive may be defective, in fact, it still may be.
    But I've determined it powers up with no problem. May be something else
    with the drive??

    I downloaded the latest drivers for the Promise SATA378 IDE controller.
    In hardware manager, it shows it as working properly.
    Also when the computer boots, it shows the controller as one of the first
    things, but it says nothing is connected to it.
    So, I can't get the computer to recognize the drive upon bootup or in
    windows!


    Any ideas?

    thanks
    Gary
     
    GLeger, Mar 16, 2005
    #1
    1. Advertisements

  2. When you said you "checked many things", what things did you check? SATA
    enabled in bios? What version of Windows? Cables (both power and data)
    correctly installed and not defective? Hard disk defective?

    I would, if you can, swap out items to try and narrow the culprit down.
     
    Clark Griswold, Mar 16, 2005
    #2
    1. Advertisements

  3. GLeger

    GLeger Guest

    Many things like just what you said. I changed out each cable, power, and
    data.
    SATA is enabled in bios, using winxp. This is what I'm trying to figure out
    if the
    drive is defective. Not sure though.
     
    GLeger, Mar 16, 2005
    #3
  4. GLeger

    Michael S. Guest

    You don't have it connected to the Intel Controller do you (easy mistake to
    make)--just curious??

    MikeSp
     
    Michael S., Mar 17, 2005
    #4
  5. GLeger

    GLeger Guest

    What do you mean, Intel controller? Is there one on this board?
    I recently got this thing to recognize the drive by plugging it into the
    "raid sata connection".
    I was trying to connect it to the "Sata connections". Is this what you are
    talking about?
    I'm not sure to continue using it like this and install os, etc... I
    wasn't trying to use it in a raid configuration.
    Just a normal Sata config.

    Gary
     
    GLeger, Mar 17, 2005
    #5
  6. GLeger

    GLeger Guest

    Mike, are you familiar with this motherboard? Just wondering because when I
    install the drivers for the
    controller, it has 2 choices. One is a Promise 378Raid controller, the
    other is Promise 378ata controller.
    I'm thinking I may have selected the wrong one. I picked the 378ata
    controller. Now in the device manager it shows
    under 'scsi and raid controllers' a "winxp promise SATA378 ide controller".
    I just tried to connect the drive to the Raid connectors on the motherboard,
    which I didn't really want to use a raid configuration.
    But I guess I can. Is this the way it should be? Or should I go back and
    install it with the 'promise 378 raid controller"??

    thanks
    Gary
     
    GLeger, Mar 17, 2005
    #6
  7. GLeger

    Paul Guest

    Drive visibility in the BIOS depends on which chip you are connected
    to, and what mode the chip is running in.

    If a drive is connected to the Southbridge, you should be able to
    see it in the BIOS. Since your board uses the ICH5 (and not the ICH5R),
    there is no need to worry about whether the BIOS is set to RAID
    mode or not, on that chip. When set to [Enhanced Mode] and [S-ATA]
    (the BIOS defaults), either WinXP or Win2K should be able to install
    with no F6 driver needed. The drive should show up in the BIOS
    as third or fourth master.

    On the Promise, you can either run it in RAID mode or not. If you
    enable RAID mode in the BIOS, the RAID BIOS code will be loaded.
    Depending on whether the Promise RAID code needs two drives to
    be present, to load, will determine whether the RAID code will
    allow you to see the drives when you press <cntrl F>. If the RAID
    BIOS code is disabled, you won't see anything in the BIOS.

    If you disable the Promise RAID mode, and get a copy of the
    "ATA" driver for the Promise, you should be able to install on
    a single disk when using the Windows installer. You would need
    to make a floppy driver diskette, and use F6 to load the driver
    during the install. (Same is true when running the Promise in
    RAID mode, it will also need a driver, but a different one.)

    The easiest install should be via the Southbridge. No driver
    should be needed while using the SATA in non-RAID mode on the
    Southbridge. If using the Promise 20378 ports, you can try the
    chip in RAID mode first, and see if the RAID BIOS will load or
    not. If it won't load for you, then get the "ATA" driver and
    make a driver floppy. Sometimes Asus has a "makedisk" program
    on the motherboard CD, to create a driver floppy diskette in one
    step. I see a makedisk in this ATA driver package for the 20378:

    http://www.asus.com/pub/ASUS/misc/ide/pdc20378/378ata_100104528.zip

    Paul
     
    Paul, Mar 17, 2005
    #7
  8. GLeger

    GLeger Guest

    Paul, thanks for the reply. When you say southbridge, which ports
    (connectors) are you talking about?
    Did you read my other replies?

    thanks
    Gary


     
    GLeger, Mar 17, 2005
    #8
  9. GLeger

    Paul Guest

    Next to the Promise 20378 chip, are two connectors SATA_RAID1
    and SATA_RAID2. If you connect a single disk to either of
    those connectors, and use the ATA driver, you get a non-RAID
    drive install. You can install up to four drives in non-RAID
    mode (two SATA and two on the IDE cable labelled PRI_RAID).
    I think the ATA driver will cause a "SCSI emulation" entry
    to show in Device Manager, as that is how foreign controller
    drivers are typically written.

    The SATA1 and SATA2 connectors are connected to the ICH5
    Southbridge. No driver should be needed, and the default
    Microsoft driver should work. No F6 during the install.
    The drives in this case, are clever emulations of an
    ordinary IDE disk drive, and will likely show up that
    way in the Device Manager. (I don't own any SATA drives,
    so I cannot test that for you.)

    If this was my motherboard, I would connect the drive to
    the SATA1 or SATA2 of the Southbridge. The Southbridge
    is not limited by the bandwidth of the PCI bus. You might
    also get more information about how the drive is operating,
    by connecting to that port. That is because the "SCSI
    emulation" used for controllers like the Promise chip,
    tends to hide details of what is going on.

    Paul
     
    Paul, Mar 18, 2005
    #9
  10. GLeger

    GLeger Guest

    Thanks again Paul. I did in fact plug it into the raid connector next to
    the promise chip. Now it does show the drive as being scsi in device
    manager.
    This is the only way I can get the computer to recognize the drive. I
    initially tried to connect the drive to the
    Sata connection but could never see the drive that way. I even tried to use
    maxtor's maxblast software to format and partition the drive while hooked up
    like that, but it didn't even see the drive. It said I had no drives in the
    system, when in fact I had the drive hooked up to the thing you call
    southbridge. (sata1)

    Gary
     
    GLeger, Mar 18, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.