1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

can't open boot label On Blade 1500

Discussion in 'Sun Hardware' started by Daniel Huang, Nov 3, 2004.

  1. Daniel Huang

    Daniel Huang Guest

    Hi,

    I have one Blade 1500 which worked well before, but now it's complaining
    about

    #boot cdrom

    I get error msg after issue boot cdrom, I called Sun Micro support, they
    didn't find any answer till now.

    I also updated the PROM firmware to the latest one. Same thing happens.

    Boot device: /[email protected],0/[email protected]/1/[email protected]/[email protected],0:f File and args: [[ -nowin]]
    Can't read disk label
    Can't read disk label package
    Evaluating: boot cdrom [[ -nowin]]
    Can't open boot device

    Any clue ?

    Thanks in advance.
     
    Daniel Huang, Nov 3, 2004
    #1
    1. Advertisements

  2. Daniel Huang

    Beardy Guest

    If that's the command from a root shell, then you have no
    chance. To reboot from a root shell you should use something
    like "reboot -- cdrom"
    What question did you ask?
    Did Sun recommend that?
    From the OBP ok> prompt, can you type "set-default
    boot-file" (without the quotes), and then try "boot cdrom"?

    I assume that you are actually trying to reinstall this
    system. If it "worked well before", why do you need to
    reinstall?.....

    Also are you installing from Sun media, or home-burned? You
    might have a burning issue...
     
    Beardy, Nov 3, 2004
    #2
    1. Advertisements

  3. You certainly mean

    OK> boot cdrom
    Maybe the cables are wrong, or the jumper on the CD drive is wrong.
    Look at the hardware manual (delivered on CD...).

    --
    Michael Tosch
    IT Specialist
    HP Managed Services
    Technology Solutions Group
    Hewlett-Packard GmbH
    Phone: +49 2407 575 313
    Mail: michael.tosch:hp.com
     
    Michael Tosch, Nov 3, 2004
    #3
  4. Thanks for the reply. All these command were issued in PROM. Have nothing to
    do with Sun OS.

    I tried several installation CDs, these disks were duplicated from oregional
    Sun solaris cd disk. And the cd worked well before.

    The problem is we now have two Sun Blade have same problem like this, and
    they are all like 6 months new.

    I have swap the cd drive and cable, so we are sure the drive and cable are
    good.

    I guess some thing wrong with the NVRam or Prom.

    Still waiting for Sun's support call.


     
    Huang, Daniel, Nov 3, 2004
    #4
  5. Daniel Huang

    Dave Uhring Guest

    You cannot do that with Windows and it is a PITA to do it using Solaris.

    Can you boot the original Software CD 1/2?
     
    Dave Uhring, Nov 3, 2004
    #5
  6. Daniel Huang

    Triffid Guest

    Why not?

    There are no Solaris machines with recorders in our shop, so I have no
    choice but to duplicate on Windows. Never had a problem with a Solaris
    CD made using the 'copy disc' or equivalent function in any Windows
    recording package.
     
    Triffid, Nov 4, 2004
    #6
  7. Daniel Huang

    Dave Uhring Guest

    Windows can read neither the CD's VTOC nor the UFS filesystems on Software
    CD 1/2.
    Perhaps a utility which can read the bits on a CD might be able to
    generate an ISO image. My own experience with Windows CD utilities has
    been decidedly negative.

    That remains the operative question.
     
    Dave Uhring, Nov 4, 2004
    #7
  8. Daniel Huang

    Triffid Guest

    Nor does it need to in order to copy a disc.
    The copy disc function typically reads the bits from the source disc and
    writes them to the destination disc, and therefore requires no
    understanding of the data format or content. AFAIK no Windows utility is
    able to correctly generate an ISO9660 image of a Solaris CD.
     
    Triffid, Nov 4, 2004
    #8
  9. Daniel Huang

    daniel huang Guest

    No sure what you talking about, I've beening using CDRW software on both
    windows and solaris platform to burn solaris installation disk 1 & 2, they
    all use iso9660 FS, never have any problem
     
    daniel huang, Nov 4, 2004
    #9
  10. Daniel Huang

    Dave Uhring Guest

    I wonder what that 600MB file which gets created in one of the TEMP
    direc^H^H^H^H^H folders was. As I had only one CD device in the machine
    and 512MB of memory I wonder how the copy was done bit by bit from one CD
    to the other.

    Let's just keep ignoring that question.
     
    Dave Uhring, Nov 4, 2004
    #10
  11. Daniel Huang

    Dave Uhring Guest

    Solaris Software CD 1/2 has a number of filesystems on it and only one of
    them is ISO-9660.
     
    Dave Uhring, Nov 4, 2004
    #11
  12. Daniel Huang

    daniel huang Guest

    Check sun's website

    http://wwws.sun.com/software/solaris/binaries/singleinstructions.html

    1.. Next you need to create a CD from the .iso images using CD creation
    software. Be sure to use 700MB blank recordable or rewriteable CDs as some
    of the Solaris OS CD images consume more than 650MB of space. Follow the
    instructions for your tool to create a "bootable" ISO image CD. For Windows
    we recommend you use Easy CD Creator. If you use Easy CD Creator, you should
    be able to create a CD by following these steps: 1) Put a blank recordable
    CD in the drive, 2) Start the Easy CD Creator application, 3) from the
    pull-down menu, select File -> Create CD from Disk Image, 4) in the Select
    image file dialog change Files of type: to ISO Image File, 5) select the
    ..iso image file desired and click Open, 6) Click OK on the CD Creation Setup
    dialog. This should start the CD Creation Process to create an ISO Image CD.
    If you are using Nero 5 burning software, choose open, change the file-type
    to .iso, and click on the desired CD Image. Once the image is open in Nero,
    change the "Write Method" from "Track-at-once" (the default) to
    "Disk-at-once/96", and click burn. Check the Nero support site FAQ for more
    details about creating CDs from ISO images.
     
    daniel huang, Nov 4, 2004
    #12
  13. Daniel Huang

    Dave Uhring Guest

    Well, I use cdrecord on either Linux or Solaris x86 since my CD-RW is
    mounted in a PeeCee and I don't run Windows unless I need to provide some
    dumb answer for a client.

    So, are you trying to boot Software CD 1/2 which was "Created from Disk
    Image"? If you read the CD using Windows, what folders and files can you
    see?

    Did you set your OBP parameters to default by powering up the machine
    while holding Stop and N keys until the banner appeared? Your boot
    command seems to have an argument added to it "[[ -nowin]".

    From the ok prompt, what does "probe-ide" tell you? Is the CDROM actually
    at the device "/[email protected],0/[email protected]/1/[email protected]/[email protected],0"? Did you check the
    CDROM cable to ensure that it is oriented correctly and properly seated?
     
    Dave Uhring, Nov 4, 2004
    #13
  14. Daniel Huang

    Coy Hile Guest

    Dave, I think some of the confusion here might be over what exactly the
    OP meant. It is entirely possible, if one has an ISO image of a
    Software 1/2 (such as the one downloaded from Sun), to burn that using
    CD creation software on Windows. What you're saying (and I agree with
    you) is that Windows cannot natively read the CD and copy it.

    Does that differentiation make it a bit clearer?
     
    Coy Hile, Nov 4, 2004
    #14
  15. Daniel Huang

    Dave Uhring Guest

    Quite a few people have used their Windows CD burning utilities
    improperly. That is, they created an ISO image from the ISO image and of
    course that CD will not boot. Both Nero and EZ CD have menu entries under
    "File" called something like "Create CD from Image". This option is not
    always used.
    I think that "boot cdrom" is possibly being invoked incorrectly. Go back
    to the OP and note the optional argument which OBP reports.
     
    Dave Uhring, Nov 4, 2004
    #15
  16. Daniel Huang

    Daniel Huang Guest

    Thank you all for all the replies.

    All the suggestions you mentioned here and before have been tried on the
    first day I noticed the failure. I even tried Prom diagnose, and later
    upgraded the Openboot firmware.

    This is good working installation CD which works on any other Sun
    workstation (I tested it as well)

    Any way, Sun called today and told me they think it's the system board
    failure and they will going to change it on site.

    Thank you all.

    -- Daniel


     
    Daniel Huang, Nov 4, 2004
    #16
  17. Daniel Huang

    Triffid Guest

    Since only one optical drive was available, the software buffered the
    raw bits in a temporary file. It may have added some structure to the
    bits in the process, but it's highly unlikely the temporary file was in
    ISO9660 format.
    I'm not the OP, and therefore not in a position to answer that question.
     
    Triffid, Nov 5, 2004
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.