1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Can't read SS5 serial console with tip

Discussion in 'Sun Hardware' started by Ghazan Haider, Sep 7, 2003.

  1. Hi all,

    I recently bought 5 SS5s from ebay and currently do not have monitors
    or adapters that do 13w3. The systems seem to boot fine and after a
    few seconds, theres some harddisk activity meaning the basic
    cpu/memory system is working fine. I SHOULD get a serial console.

    So I got a DB25 male both ends.. laplink cable.. and have even checked
    the individual pinouts (15-2 13-3 etc) with a multimeter to make sure
    its not a straightthrough or has missing pins. My Ultra 5 desktop
    system has good serial ports, Ive been using them to access some cisco
    routers. The internal jumpers in the SS5s and the Ultra 5 are set for
    RS232, not RS 445 (or something). So I can assume either the hardware
    is all fine, or all the SS5s have bad serial hardware (unlikely?).

    Now Ive tried tip and cu, but I have most of my experience with tip.
    Ive tried tip -9600 /dev/cua/a which always shows 'connected' and then
    nothing. Booting the various SS5s show nothing, zilch, nor does
    sending break. Ive checked the tip setup to be 9600,8,n,1 and have
    tried all Serial B ports on all the SS5s too (both with and without
    hardware flow control), but most of my tests are with Serial A since
    that should be the default.

    Now the machines do not come with floppy or cdrom drives so I cannot
    boot anything blindly, and I cannot use their (SCA1 80-pin) drives in
    my Ultra5. I tried to boot them with tcpdump or arpwatch running on
    the Ultra5 to see if I can get them to remote-boot, but they emit
    nothing. I'm reasonably sure I'm doing something wrong with the serial
    settings, but not sure what.

    Any ideas/suggestions/hints on what else to check or fiddle with to be
    able to read data? I suspect the SS5 port waits for a CD signal while
    the Ultra5 ignores it, but I tried changing ttya-ignore-cd=false on
    the Ultra5 as well. I checked the standard laplink pinouts for serial
    DB-25 cables on the symantec site. I looked around for a jumper to
    reset the SS5 ROM (unsuccessful) and tried blind stop-A serial
    settings on the SS5. Can a veteran suggest anything short of buying a
    Sun monitor?
     
    Ghazan Haider, Sep 7, 2003
    #1
    1. Advertisements

  2. Daniel C. Kreuzer, Sep 7, 2003
    #2
    1. Advertisements

  3. Ghazan Haider

    Greg Andrews Guest

    Adjusting the eepromp settings on your Ultra 5 won't help your
    SS5 machines to work. The tty[ab]-ignore-cd setting must be
    done on the SS5.

    If you can't be certain your cable is providing DCD to the SS5, then
    you probably need to reset the SS5's eeprom parameters to factory
    defaults. For that you need a Sun keyboard plugged into the SS5's
    keyboard connector. You press and hold Stop-N, then power on the
    SS5, hold the Stop-N for at least 30 seconds, then power off the
    SS5, unplug the keyboard, and power the SS5 back on again.

    -Greg
     
    Greg Andrews, Sep 7, 2003
    #3
  4. Thanks it was my mistake. The cable was male to male db25, and
    labelled laplink.. serial cables come in female to female. It was a
    parallel laplink cable. After some sleepless soldering last night I
    have all the machines booting.

    Now for the fancy jumpstart remote mass-installs. Super!
     
    Ghazan Haider, Sep 7, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.