Can't send mail using Mail.app, but can with Thunderbird

Discussion in 'Apple' started by brianarn, Oct 24, 2005.

  1. brianarn

    brianarn Guest

    Hello,

    I am having one heck of a time, and it's killing me. I am new to the
    world of OS X but am adapting well, with one exception - Mail. Here's
    the deal.

    Using Thunderbird, I can send mail out with password authentication.
    I can send it via port 25 normally or via port 465 via SSL.

    I can also telnet to port 25 and see the standard email connection, and
    I can even fake it out using the proper sequence of commands.
    I can telnet to port 465, although since that's SSL I can't easily fake
    key negotiation or anything like that - but, it does establish a
    connection.

    However, Mail just can't do it, using password authentication.
    I've set mail to use port 25 without SSL.
    I've set it to use port 465 with SSL.
    Neither option works.

    I am fortunate in that if I've recently checked my mail via IMAP, it
    authenticates me for sending out for a few minutes, so if I set Mail to
    just not use any password authentication, it works with or without SSL.
    Even with this auto-auth though, if I have password authentication on,
    it simply won't let me send mail.

    I know that the SMTP server works - and I can send mail, although I
    have to have my timing set really low on checking mail in order to
    ensure that any send works right off the bat. I have my workaround, but
    it's rather annoying. Any reason why it wouldn't authenticate with a
    standard password?

    System information:
    iBook G4 1.33GHz w/ 512MB RAM
    Mac OS X 10.4.2
    Mail 2.0.3
    SMTP Server: mail.pixelreflections.com - standard port 25, SSL port 465

    Thanks in advance for any advice/thoughts that you all can offer. I
    hope I'm posting in the right newsgroup for this sort of issue. If I'm
    not, I apologize in advance, and would greatly appreciate a redirect.
     
    brianarn, Oct 24, 2005
    #1
    1. Advertisements

  2. brianarn

    Andy Hewitt Guest

    [Snipped Text]
    Is this for the Gmail account I note you have (in the header)?

    If so, you need SSL for outgoing on port 587, and SSL for incoming on
    port 995. Set Authentication to 'Password'. In Thunderbird this should
    be TLS.

    It is unusual to have SSL set for mail through your own ISP's system,
    have you tried leaving it to default settings?
     
    Andy Hewitt, Oct 24, 2005
    #2
    1. Advertisements

  3. brianarn

    brianarn Guest

    I managed to miss this reply. Whoops.

    It's not for the gmail account I have, no. It's for a server that I
    personally administer.

    As mentioned in the snipped text, I've tried it in multiple
    configurations.

    * I've used the default settings, pointing at port 25 of this server,
    using both server name and IP address.
    * I've turned on SSL, switched the port over to 465, using both server
    name and IP address.

    I even tried again today, after updating to 10.4.3.

    No matter how I've got Mail configured (SSL or no), if I'm trying to
    use password-based authentication for my SMTP server, it doesn't work,
    and keeps re-prompting me for a password.

    It's not been a big deal really, because if I set auth to 'None' and
    just check my mail before sending, I have no problems (yay for
    auto-authentication on checking). It's just a really weird annoyance to
    be unable to authenticate to my server.

    Just for kicks, I decided to set up SMTP auth using the gmail
    information you provided, and I was able to send out mail just fine.
    This is very weird. I'm going to go do some digging and see what I can
    pinpoint. It's very weird that it'll work in other programs, just not
    in Mail.
     
    brianarn, Nov 3, 2005
    #3
  4. brianarn

    brianarn Guest

    I wanted to reply and say that I found what the problem is, although it
    made little sense.

    Based on information found here:
    http://www.directadmin.com/forum/sh...71352fd&threadid=2037&highlight=mac+Mail+smtp

    It seems that my SMTP server (exim) was set up to use either PLAIN or
    LOGIN authentication. This caused Mail.app to be unable to
    authenticate. I'm not sure why. However, being that I can administer
    the box, I was able to easily turn off the PLAIN portion, and so now
    LOGIN is the only means of authentication, and Mail.app works like a
    charm, no more problems.

    Overall, a weird weird problem that I'm glad I found a fix of sorts
    for, but really wish that I understood better. I can't even really tell
    what value there is to AUTH PLAIN over AUTH LOGIN, but whatever - it
    works now, and didn't break any other mail clients (as I can still send
    with Tbird and webmail, and others report to me that Outlook still
    works just fine).
     
    brianarn, Nov 3, 2005
    #4
  5. Brian,

    I believe that AUTH LOGIN sends the login and password base64 encoded
    and AUTH PLAIN sends the login and password in clear text. The Apple
    mail app supports the following authentication mechanisms, you can see
    this in the advanced tab of the mail.app account settings:

    Password, MD5-Challenge-Response, Kerberos Version 4, NTLM,
    and Kerberos version 5 GSSAPI.

    Password must be the base64 encoded authentication if it is now working
    on your machine.

    Many older email clients only support PLAIN such as older copies of
    outlook and I believe many browser email programs such as netscape only
    support PLAIN. So, by eliminating PLAIN, you may be excluding cutomers
    with older clients or clients that support nothing but PLAIN. PLAIN is
    safe as long as it is over SSL.

    I see from your post to the link below that your mail server is a
    FreeBSD 4.8 machine? I have a mail server running FreeBSD 5.4 with smtp
    auth and I have it configured to support the following mechanisms:

    AUTH LOGIN PLAIN GSSAPI DIGEST-MD5 CRAM-MD5

    This allows a wide variety of email clients to use smtp auth on this
    machine. On this machine smtp auth is also required, they may not send
    email through it unless they can authenticate using one of the above
    mechanisms. I also encourage through arm twisting the use of SSL no
    matter what when PLAIN or LONG is used. To see what mechanisms an smtp
    server supports, you can use the "ehlo auth" command after telnetting to
    port 25 on your mail server, just type: 'ehlo auth' and hit return. I
    see that your server only issues:

    250-AUTH LOGIN

    My mail server shows the following when I issue the "ehlo auth" command:

    250-AUTH LOGIN PLAIN GSSAPI DIGEST-MD5 CRAM-MD5

    best regards
    John
     
    John Rushford, Nov 8, 2005
    #5
  6. Brian,

    Forgot to mention it but on a FreeBSD machine with smtp auth, only PLAIN
    works with the password database, the other mechansisms require an entry
    in the SASL password database see, /usr/local/sbin/saslpasswd2, for
    setting the users password in the SASL database. So perhaps your
    problem with PLAIN and LOGIN had more to do with the password stored in
    your database(s), ie wrong password when using PLAIN (/etc/passwd) and
    correct password with using LOGIN with the SASL database.
     
    John Rushford, Nov 8, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.