1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Catalyst 3.8 and Battlefield 1942

Discussion in 'ATI' started by The White Werewolf, Oct 11, 2003.

  1. Ran into an odd problem with the new Catalyst 3.8 drivers from ATI.

    I downloaded them. Uninstalled the catalyst 3.7 drivers using the ATI
    uninstall all app located in the install folder. Then installed the
    new driver set. This required two restarts. Once when i uninstalled
    the first driver set and again when installing the new set.

    I went into testng the new driver with various games and all seemed to
    work fine with the exception of one. Battlefield 1942. I can run the
    game. select a battle, and play just fine. But if i hit escape to go
    back to the menu, the menu is corrupted. moving the mouse around will
    cause further corruption and will lock the system up after a few
    seconds.

    I tried evrything i could think of to fix this. disaled all non
    essential services. I even tried just about every motherboard bios
    setting i have and none of these seem to effect the problem in any
    way. Reverting my motherboard to its failsafe defaults only resulted
    in slowing my ystem down but the graphic corruption still happens in
    BF1942 when going back to the menu from an active map. The map i was
    using for this is the Eagles Nest map that comes with the Secret
    Weapons of WWII expansion.

    Here is a list of my system load out.
    Power supply: Antec Truepower 333 watt.
    Motherboard: Abit KX333
    CPU: AMD Athlon 1600+ running at its default speed
    Memory: 512 megs Crucial brand Registered ECC
    Video Card: ATI Radeon 9600 Pro (ATI Manufactured)
    Hard Drive: Western Digital wd1200JB
    Sound Card: Creative Labs Sb Live 5.1
    CD: Pioneer 117 model DVD rom.
    Nic: 3com 3c905c-tx
    Windows 2000 Pro installed 2 months ago from a full format of the hard
    drive. All drivers (sound card, motherboard chipset, video card,
    ethernet card, etc. .) are the current batch from the hardware
    manufacturers website.

    All system bios are current.

    First off, is anyone else experiencing this problem? And does anyone
    have any recommendation on how to fix this or at least what the cause
    of the problem may be?
     
    The White Werewolf, Oct 11, 2003
    #1
    1. Advertisements

  2. I have the EXACT same problem with the 3.8s. When I hit escape the
    menus are all messed up and I can't see my mouse cursor, then when I
    try entering the game again everything is corrupted.

    I'm assuming the 3.8 Cats introduced the problem, since it only
    started happening after I installed them. I also noticed a severe
    performance hit in BF1942 with the 3.8 Cats. Flying around
    Mimoceques(Secret Weapons map) really lags, and it never did in 3.7.

    I'm none too happy with the 3.8s so far. The saved profiles for
    Direct3D and OpenGl do not work properly either. You select them and
    apply, but it doesn't actually change the settings.

    I'm running,

    Gigabyte 7VAX (F10 BIOS)
    Athlon XP 2100+
    Radeon 9700 Pro
    Win2k Pro SP4

    A revert back the 3.7s will probably fix the issue in BF1942.
    Hopefully their next driver release will fix this.

    Indestructible
    GamerzAlliance.com
     
    Indestructible, Oct 11, 2003
    #2
    1. Advertisements

  3. The White Werewolf

    Gatlin Guest

    I'm having the same problem with a 9800 pro and the new drivers. Must
    be a driver issue. Go back to 3.7, and see if that helps.
     
    Gatlin, Oct 12, 2003
    #3
  4. The White Werewolf

    ginfest Guest


    No problems of that sort here, running the original BF 1942 patched to 1.4x
    Maybe something to do with the expansion packs?
    P4 3.2
    IC7-G
    9800P 3.8 drvs
    WinXP
    etc
     
    ginfest, Oct 12, 2003
    #4
  5. The White Werewolf

    Jason Ash Guest

    So far I'm running the Cat3.8s' with a Radeon 9700Pro, and have no
    problems with BF. However, I do not have the Secret Weapons expansion.
    Just played on-line last night. The only problem with BF I run into
    occasionaly, is a semi-transparent black box at about 2/3 they way up the
    screen, where the "loading" dialog is. However, I have run into this
    before, with older Catalyst drivers, so I think it's a BF issue.

    System Specs:
    Motherboard: Soyo KT400 Dragon Ultra Platinum
    CPU: AMD Athlon 2600+ running at its default speed
    Memory: 768Mb DDR333 generic
    Video Card: ATI Radeon 9700 Pro (ATI Manufactured)
    Hard Drive: 2x40Gb Maxtor in RAID-0 (system drive)
    1x80GB Western Digital (swap and storage)
    Sound Card: Creative Labs Sb Audigy Platinum
    CD: Lite-On 16X DVD-ROM
    Memorex 2.4x DVD+RW
    Nic: Intel Pro1000/MT
    Other: MSI [email protected] TV tuner
    Win2K Pro SP3, re-loaded less than a month ago.
    Motherboards on-board audio is disabled.

    Running BF1942 v1.45, with the Road to Rome expansion pack.

    Jason A.
     
    Jason Ash, Oct 12, 2003
    #5
  6. The White Werewolf

    Frank Weston Guest

    Yep. Same exact problem with 3.8 driver and 9800 Pro. I also had a similar
    problem with Ghost Recon. Reloaded 3.7 drivers and the problem was solved.
     
    Frank Weston, Oct 12, 2003
    #6
  7. The White Werewolf

    SLB Guest

    Same here just tries original BF 1942 (latest patched version)and it
    works fine. I wonder if its a expansion pack issue with the new 3.8
    driver?
     
    SLB, Oct 12, 2003
    #7
  8. I finally got this problem figured out folks.

    The whole problem has to do with your monitor refresh rate. You will
    get this problem if your refresh rate in BF1942 is different than your
    desktop refresh rate.

    After I installed Cat 3.8 BF1942 reset my refresh rate in the game to
    60hz for some reason. My desktop runs in 85hz.

    Seems when you press escape in BF1942 the game flashes to your desktop
    and switches to your desktop refresh rate, then goes back into the
    game menu still in your desktop refresh rate, when the game is
    expecting an altogether different rate. This is what causes all the
    visual garbage.

    Simply set the refresh rate in BF1942 to the same rate as your desktop
    and this problem will go away. Worked great for me.

    You'll have to edit /EA GAMES/Battlefield
    1942/Mods/bf1942/settings/VideoDefault.con and change
    renderer.allowAllRefreshRates 0 to renderer.allowAllRefreshRates 1 to
    give you the ability to choose a refresh rate within the game.

    Hope this helps everyone with the problem.
     
    Indestructible, Oct 23, 2003
    #8
  9. The White Werewolf

    James smyth Guest

    Thanks for that, I've only just upgraded from a 4200 to a Crucial Radeon 9800Pro
    today and haven't been impressed at all. Battlefields is my main game. I tried
    changing the refresh rates and it didn't work so I lowered my desktop res to
    1024x768 and tried with the same res and refresh and thats cured the problem but
    now the desktop looks crap.

    On Tiger woods 2004 there is no in-game menu for AA so the only way to do it AFAIK
    is through the control panel but with AA switched on the screen blanks when you
    take your shot which is really annoying and puts me right off the game, whats the
    point of spending £260 on a graphics card if games change their behaviour for the
    worse in return for improved picture quality. I had the option of playing in
    1600x1200 on the Ti4200 plus switching on Vertical sync in the control panel to
    stop the textures tearing, when AFx8 is switched on, makes the mouse unresponsive
    so it's impossible to play Tiger Woods with either AA or AF. Overall the graphics
    were better with a Ti4200 due to the higher resolution.

    Max Payne 2 runs OK, a little dark at first but changing the Gamma in the control
    panel helped that. I'm going to test Halo and a few more games tonight but I
    wouldn't recommend anyone run out and upgrade if you already have a GF4 Ti4200.
     
    James smyth, Oct 23, 2003
    #9
  10. The White Werewolf

    Andrew Guest

    <snip>.

    Go back to the 3.7 drivers, I don't get any of those problems with
    BF1942 or the TW2004 demo.
     
    Andrew, Oct 23, 2003
    #10
  11. Sorry to hear about all those problems. Now that I think about it
    almost every problem I've had with my 9700 pro comes from an EA
    game...I guess that's another thing I can hate EA for.

    Anyway, I'm sure you'll be impressed with Halo running on your 9800
    over your 4200 Ti. As impressed as can be anyway, Halo isn't the best
    performer even on the highest-end PCs. Make sure you have
    Anti-Aliasing turned off for Halo, it does absolultely nothing due to
    how the engine was coded and just really kills your performance with
    no visual gain.
     
    Indestructible, Oct 23, 2003
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.