CD-RW Drive Won't Work Unless Desktop is Rebuilt

Discussion in 'Apple' started by KC, Jul 20, 2004.

  1. KC

    KC Guest

    Hello All

    I have a Rev C Beige G3 Desktop 266 mhz Mac. It has 834 mb of RAM, and is
    running OS 9.2. It has an HP 9110 CD-RW drive installed in it. Something I
    did has caused the CD-RW to not be recognized by the system unless the
    desktop is rebuilt. Once the desktop is rebuilt the CD-RW drive works fine
    until the computer is turned off. Then, if I want to use the CD-RW drive
    (for reading or burning disks), I will have to remember to rebuild the
    desktop the next time the Mac is booted.

    Any ideas on how to resolve this so I do not have to rebuild the desktop
    every time I want to use the CD-RW drive? Any ideas as to what rebuilding
    the desktop is doing that fixes the problem, and how can I make it a
    permanent fix?

    Thanks in advance for any help you may have.

    Kenn
     
    KC, Jul 20, 2004
    #1
    1. Advertisements


  2. 2 thoughts --

    1.) A desktop rebuild might load extensions in a slightly different
    order. Perhaps the problem is actually an extension conflict and has
    nothing to do with the desktop rebuild. Have you tried only the
    necessary extensions?

    2.) Or, if it really is a rebuild that won't stick, go to the Micromat
    website and download TechTool lite (it is free) to rebuild the desktop.
    That will completely delete the desktop database prior to the rebuild.
    Supposedly the process is more thorough than using the keyboard commands.


    - TNW

    [To e-mail me, remove 12345 from my address.]
     
    TNW7Z7Z7Z12345, Jul 20, 2004
    #2
    1. Advertisements

  3. It could be a problem with directory damage, which is jolted back into
    somewhat useable shape by rewriting the desktop db, but which might
    be better repaired with Diskwarrior 2.x. In addition, do what the other
    guy said and run progressively less minimal extension sets, until you can
    find out what the extension conflict is. There was also some old thing
    in OS 8.x about ObjectSupportLib screwing things up, but that's probably
    not your problem.
     
    George Williams, Jul 20, 2004
    #3
  4. KC

    KC Guest

    Thanks for the advice TNW and George.
    I do have a Disk Warrior 3, and did run it prior to discovering the problem.
    I cannot say for sure I wasn't having the problem before I ran Disk Warrior.
    But at least you pointed me in the direction to start looking.

    Thanks again.
    ..
    Kenn
     
    KC, Jul 21, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.