1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Chameleon POD with Atme AT91RM9200DK board

Discussion in 'Embedded' started by Vadim Lebedev, Feb 12, 2004.

  1. Hello,

    I need advice on using Amontec Chameleon POD to work with AT91RM9200DK

    First the Amontech Chameleon Programmer software is unable to configure
    the device
    on all my Win98  machines.  It only works on my Win/XP machine

    Second when the pod is connected to a Linux or Win/XP machine i'm getting
    either Cable Disconnetcted message or Not in Background message from for
    OcdLibRemote software when trying to connect from GDB.

    The pod is configured as RAVEN 1 MHZ and parallel ports are configured in
    BIOS
    as EPP...

    OCDCommander on Win/XP sometimes is able to connect to the board
    but is unbale to send reset or any other command


    Finally, one of the readers on arm-linux mailing list sent me the latest
    version of Chameleon programmer (V1.0) software which is for some reason
    unavailable from Amontec site.

    I've tried configuration raven-all-speed-no-trst  and raven-1-mhz-no-trst with
    the same result (i'm getting cable disconnected message).


    Another annoying problem with Chameleon Programmer software that it takes
    multiples clicks on OK button to start programming...   Most of clicks on OK
    button are simply ignored

     
    I've double checked the JTAG cable Amontec me and it is OK.

    Thanks
    Vadim
     
    Vadim Lebedev, Feb 12, 2004
    #1
    1. Advertisements

  2. Vadim Lebedev

    Amontec Team Guest

    Hi Vadim,
    Hi readers,

    A)

    The trouble is coming from the onboard rst implementation of the ATMEL
    dev. boards.

    Please try to cut the both nsrst and ntrst, and use the ranve_all_speeds
    configurations of the Chameleon POD.

    Amontec has a special Raven and Wiggler configuration with no reset
    signal activity. nsrst and ntrst are just not driven by the Chameleon
    POD (opendrain output with an output enable fixed to '0')
    Please ask Amontec to receive this new config (These configs were tested
    on a major part of ATMEL ARM7 and ARM9 dev. boards)

    Actually, many software do not implement the nrst and ntrst control. Why
    ? Because is a pain for the debuggers to analyze what to do after these
    asynchronous reset machanisms.

    nsrst can be util for debug from the boot.
    ntrst is used for reseting the JTAG TAP state-machine in the processor.
    With actual new processors, the on-chip JTAG TAP can be reseted by some
    TCK TMS access. This is why the ntrst is *NOT* implemented by all
    popular remote machine.

    Also, both nsrst and ntrst can be cut ... your debuggers and your JTAG
    remote machines will work fine without nsrst and ntrst!

    B)

    The Amontec drivers support only nt \ w2k \ xp (not win98, not winME)

    C)

    About ->
    We cannot re-produce what your are saying.
    Please could you give me the exact OS version you are using.

    Please feel you free to contact Amontec for more info.

    Could you please give a NG feedback of your issue.

    Regards,
    Laurent Gauch
    www.amontec.com
     
    Amontec Team, Feb 13, 2004
    #2
    1. Advertisements

  3. I've finally managed to make the Chameleon

    The only problem is that the setupt gdb - ocdlibremote - pod ssems to not
    work with virtul adresses
    and as i work with Linux it is pretty important to me.

    I'm invetsigating the possibility to remap Linux kernel or SDRAM address so
    that VA=PA for the kernel...

    Any ideas?
     
    Vadim Lebedev, Feb 14, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.