clear CMOS/ reset BIOS on Professional Workstation 5100

Discussion in 'Compaq' started by Richard, Sep 20, 2003.

  1. Richard

    Richard Guest

    (sorry it's a long post but if you read on you may be amused
    at my stupidity and you may be able to help me - I hope!)

    I bought a 2nd hand pw5100 with a single PII 333. I added
    another PII 333 and the relevant VRM, and got a replacement
    18.2GB Wide-Ultra SCSI drive.
    During my building of the machine I disconnected the floppy
    and booted the machine. It recognised the lack of floppy drive
    and changed the BIOS configuration to disable the floppy
    controller.
    I had already copied the Setup program onto the SCSI drive
    and could enter that happily by pressing F10 when the flashing
    blob appeared top-right.
    I then installed RedHat Linux 9, and naively selected the GRUB
    boot loader to boot from the RedHat partition with no option
    of booting the "DOS" partition where the Compaq Setup
    program is stored. I thought I would be able to enter this
    by pressing F10 before RedHat booted. I can't. I have tried
    many times and it always boots into RedHat. I also tried
    removing the Keyboard. This gave a keyb error and halted
    boot - "press F2 to continue". Even then pressing F10 did
    nothing and pressing F2 continued the RedHat boot.
    So I now want to re-enable the floppy drive and sound card,
    and need to access the Setup program to do so. I can't boot
    from the floppy as it is disabled in BIOS. I can't access the
    Setup partition. If I remove the SCSI drive I can boot from
    CD, but even with a different SCSI drive in I can't load the
    Setup program onto the SCSI drive as I have no floppy.

    I think I have the following options.
    1) configure GRUB to allow booting the Setup Partition. I am
    a complete newbie to Linux, so I haven't a clue how to. (If
    anyone can offer help on this then I would be grateful too. Or
    can you tell me where to look for help files about Grub?)
    2) reset BIOS to default settings which I guess would re-enable
    the floppy controller. I know and have used the switch to disable
    the boot password, but is there a jumper or keyboard sequence
    to reset BIOS?
    3) make a bootable CD with the Compaq Setup on. I know it
    will be read-only, but I think this would work, but I don't know
    how to unpack the Softpaqs. I can't even read them from floppy
    on a Windows machine - they appear as non-formatted. Any
    advice?
    4) remove all linux partitions on the SCSI drive. I think this will
    just make the whole disc into a non-bootable non-system disc.
    5) remove the CMOS battery for a few hours. Will this reset
    defaults? Or will it kill the whole BIOS? Or most likely will it do
    nothing except upset the system clock, as probably all Setup
    details reside in EPROM anyway.
    6) put up with the current Setup forever
    7) bin it!

    Looking forward to all your thoughts.

    Richard
     
    Richard, Sep 20, 2003
    #1
    1. Advertisements

  2. Richard

    Richard Guest

    well I finally got this sorted. I had tried numerous times to boot from the
    CD but it always booted from the SCSI hard disc. I left a Linux install CD
    in the drive, and one time (having not run for 2 weeks) it booted from the
    CD. I deleted the linux partitions from the hard disc and got access to the
    Setup partition. All working fine now.
     
    Richard, Oct 14, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.