C'mon, guys! (was: DeskJet 640c under Tiger)

Discussion in 'HP' started by Duncan Langford, Jul 19, 2005.

  1. Not a single response - surely SOMEONE must know the answer?!
    ------------------

    Installed Tiger, and the HP has stopped working properly. Yes, I've read
    the HP web page, and deleted my old DeskJet print queue, and generated a
    new one; 'USB' isn't available as an option unless the DeskJet is plugged
    in, and then the only relevant choice is specifically 'USB DeskJet 640c'.

    BUT - after this, it still prints with every other line screwed up...

    Does anyone have any ideas? I'm reluctant to junk it (having just bought
    new cartridges) but there's not a lot of point in keeping it when it won't
    work!

    In case it's relevant, a G5 under 10.4.2

    - duncan
     
    Duncan Langford, Jul 19, 2005
    #1
    1. Advertisements

  2. Duncan Langford

    Ben Myers Guest

    Well, it could be that very few readers of this newsgroup have DeskJets and are
    running Tiger... Ben Myers
     
    Ben Myers, Jul 19, 2005
    #2
    1. Advertisements

  3. Duncan Langford

    DaveC Guest

    Thus spake Duncan Langford:
    You are using the HP driver downloaded from HP's site?

    As an alternative, you might try the GIMP-print solution. It uses open-source
    drivers for your printer. See here:

    http://gimp-print.sourceforge.net/MacOSX.php3
    --
    Please, no "Go Google this" replies. I wouldn't
    ask a question here if I hadn't done that already.

    DaveC

    This is an invalid return address
    Please reply in the news group
     
    DaveC, Jul 19, 2005
    #3


  4. Can't help. OS 9 here but I will relate my experience.

    When I got the G3 I run now, I had a 680c. I initially copied over
    the extensions from the older 7500 expecting all to work. For the
    most part all applications worked fine - except the printer which was
    acting weird or not at all.

    I went to the HP web site and found there was a new driver for OS 9
    plus a special OS 9 updater - nothing for X by the way. The
    instructions on how to install it were ambiguous but after re-reading
    several times and some trial and error here is what i had to do.

    1) Remove all of the old drivers.

    2) Run the installer for the new driver.

    3) Quit out of the installer at the point it says that it is ready to
    be selected in the Chooser. If you don't stop there you are screwed.

    4) Restart with thefresh driver that has not as yet been associated
    with the Chooser.

    5) Run the driver updater.

    6) Restart again.

    7) Now select the driver in the Chooser.

    From that series of events all was OK.

    It seems that the drivers grab some kind of association with
    theoperating system. You cannot use a driver that was previously
    associated with an earlier OS. The instalation process creates this
    association and dedicates the resultant driver with the OS.

    The second patch for OS 9.2.1 and 9.2.2 could not be run if the driver
    had been associated with theChooser. That creates some other link
    that prevents the updater from running properly. It had to be a
    freshly installed driver that had not as yet been associated with the
    Chooser.

    It seems that a whole new driver for these variations of the OS would
    make sense but that was not HP's thinking, and anything of that era is
    officially no longer supported by HP - or so they claim.

    While I have no experience with X this may give some insight into my
    own problems with HP drivers and how I had to jump through hoops to
    make the older printer work.

    Now, I also have a HP 3550 on my USB line and that was also no waltz.

    After getting it home and installed I had problems. I went to the HP
    web site and found that they had a new OS 9 driver for it that was
    different from the one on the CD.

    Again I dumped all drivers and ran the new driver downloaded from the
    HP web site. It appears that some functionality was lost in the
    process (some menu choices) but it seems these were what was causing
    the problems - not working right for all possible variations of
    installation) so they were removed. The cut down driver works fine
    now.

    I use the newer USB for dress jobs and the older one for the every day
    stuff.

    Best of luck with it.

    DMK
     
    D. Kirkpatrick, Jul 19, 2005
    #4
  5. Duncan Langford

    Bob Headrick Guest

    If every other line is a problem I would suspect a problem with the print
    cartridge. Try running a nozzle diagnostic page as shown at:
    http://h10025.www1.hp.com/ewfrf/wc/...=bpd07098&product=61012&dlc=en&lang=en#N100F1
    If there are regular missing areas in the nozzle pattern try reseating the
    cartridge or cleaning the cartridge contacts as shown at
    http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=bpa02060
    (for a different model cartridge, but the principle is the same....).

    Regards,
    Bob Headrick, not spekaing for my employer HP
     
    Bob Headrick, Jul 21, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.