1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Cobalt Raq 4 OS restoration problems after net-booting restore CD

Discussion in 'Sun Hardware' started by Kralizec Craig, May 25, 2008.

  1. Hi everyone,

    I have succeeded in getting an OS restore CD for my Cobalt Raq 4 to
    net-boot my currently-offline Raq4 via a net-connected PC, and I solved
    one problem surrounding a disk drive for which the net-booted kernel would
    not accept the parameters of when the drive was probed for it's specs. I
    have a console connection to my SB1000 so I can log all the console
    messages that the Raq4 produces.

    However there's still a problem I am not able to figure out yet and that
    is that when the setup script runs to create the partitions on the
    replacement disk, 'mke2fs' appears to give errors about unknown drive
    specifications each time it's run and the partitions don't mount
    read/write when the script gets set up to start trying to copy over
    software packages from the host PC.

    Also, I noticed in the logs some messages about incorrect kernel version
    but that might be a result of the disk partitions not mounting read/write.

    Has anyone come across this sort of problem when attempting to do a new OS
    installation for a Cobalt x86-based web server appliance, and how did you
    solve it?

    The first disk I tried to use is a brand new Seagate ST380215A (Barracuda
    7200.10 - 80 gb), and the drive I'm trying at the moment is a used Western
    Digital 80 gb ide drive that I found in some spare parts boxes. The
    Seagate disk gives invalid (according to the kernel) parameters when the
    net-loaded kernel first boots up to run the install process. The WD drive
    gives good parameters. Both disks appear to give the same problems though
    later on in the process so I suspect there's something else going on that
    I haven't worked out yet.

    The particular OS restore CD I'm using is an upgraded one produced by
    Zeffie, so I wonder if that is the problem? Perhaps there is some
    un-tested condition that is resulting in my particular Raq4 to not do the
    install steps properly. If anyone has tried OS restoration using restore
    CD's from other vendors (Raqport, CobaltSupport, the original Sun/Cobalt
    one, etc.) have you seen the problem when using those?

    One thing I will do to be absolutely sure is re-burn the iso image for
    Zeffie's OS restore CD onto another new CD-R later today and give that a
    go just in case something didn't work right when I burnt the first CD-R.

    Craig.
     
    Kralizec Craig, May 25, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.