1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Company of Heroe's and Opposing Fronts both have ALT-TAB BUG.

Discussion in 'Nvidia' started by Skybuck Flying, Oct 13, 2007.

  1. Hello,

    When switching many times between the game and windows COH develops a "bug".

    When starting a multiplayer game, the game "stutters" !

    Restarting the game solves the issue.

    Bye,
    Skybuck.
     
    Skybuck Flying, Oct 13, 2007
    #1
    1. Advertisements

  2. Skybuck Flying

    deimos Guest

    That's not the alt tab bug, you idiot. That's your cache.
     
    deimos, Oct 13, 2007
    #2
    1. Advertisements

  3. Never heard of such a thing, probably nonsense too.

    I could imagine the processor's cache is emptied, filled with other stuff...
    when alt-tabbing to windows.

    Surely the processor cache will be re-filled with coh code.

    It probably isn't even swapped out since it's running in the background.

    Me thinks it's a timing issue.

    Bye,
    Skybuck.
     
    Skybuck Flying, Oct 13, 2007
    #3
  4. Skybuck Flying, Oct 13, 2007
    #4
  5. Oh well forget that thread.

    Not much info in there.

    I am seeing "stutter"

    Once the "stutter" happens it can't be fixed by alt-tabbing.

    Only restarting the game fixes it.

    To me it seems like:

    1. Threads keep running and aren't cleaned up properly.

    (I could check this in task manager under threads... I'll do that
    sometime... if "dangling" threads is causing this it will show up in an
    increased ammount of threads running)

    2. Timing problem.

    Timing code in the game is not updated properly... however seems kind weird
    since when returning to the game this should be solved me thinks or maybe
    just bad coding or something.

    3. Something else ?

    Bye,
    Skybuck.
     
    Skybuck Flying, Oct 13, 2007
    #5
  6. I have installed the lastest AMD Processor Driver.

    AMD has not updated it's main website... but the driver is on another link.

    I don't think that matters much because it's the same driver I think, just
    installer is different... but who knows..

    One thing I did do is:

    I installed X2 Core Optimizer driver.

    I am gonna play the game with it installed for a while.

    The performance indicator in the game is now on all high.

    Another dude said it solved problems for him as well..

    So who knows.

    I just hope my windows booting time doesnt get bad as it did back in the
    past with this core optimizer driver ;)

    Bye,
    Skybuck ! ;)
     
    Skybuck Flying, Oct 14, 2007
    #6
  7. Skybuck Flying

    Kevin Weaver Guest

    You installed it before and complain about slow bootup times.
    Then say the driver has not changed. Then you Install the same driver again
    and hope it does not slow down your boot time.

    So what's changed from the last time you Installed this driver ?

    Now I know your a troll.
     
    Kevin Weaver, Oct 15, 2007
    #7
  8. I am not certain if the core optimizer was the cause of it.

    I think so, but I am not sure...

    If the boot time becomes slow again then I am pretty sure.

    For now I plan on playing some more COH so it's the possible price to pay.

    If I am done with COH and boot times get worse I simply remove it again ;)

    No big deal !

    If on the other hand boot time remains ok... then maybe other games will
    benefit from it.

    Maybe airborne... but I don't like to play another ww2 shooter... I am done
    with that ;)

    Bye,
    Skybuck =D
     
    Skybuck Flying, Oct 16, 2007
    #8
  9. Well that didn't last long.

    Dual Core Optimizer probably caused the following system crash:


    Microsoft (R) Windows Debugger Version 6.6.0007.5
    Copyright (c) Microsoft Corporation. All rights reserved.


    Loading Dump File [C:\WINDOWS\Minidump\Mini101607-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is:
    SRV*c:\Tools\WinDbg\WebSymbols*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows Server 2003 Kernel Version 3790 (Service Pack 2) MP (2 procs) Free
    x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 3790.srv03_sp2_gdr.070321-2337
    Kernel base = 0xfffff800`01000000 PsLoadedModuleList = 0xfffff800`011d4140
    Debug session time: Tue Oct 16 05:05:16.671 2007 (GMT+2)
    System Uptime: 0 days 4:12:39.478
    Loading Kernel Symbols
    ............................................................................................................................................
    Loading User Symbols
    Loading unloaded module list
    ...................................................
    *******************************************************************************
    *
    *
    * Bugcheck Analysis
    *
    *
    *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck 4E, {2, 10c, 7ffff, 1}

    Probably caused by : memory_corruption ( nt!MiUnlinkPageFromList+7e )

    Followup: MachineOwner
    ---------

    0: kd> !analyze -v
    *******************************************************************************
    *
    *
    * Bugcheck Analysis
    *
    *
    *
    *******************************************************************************

    PFN_LIST_CORRUPT (4e)
    Typically caused by drivers passing bad memory descriptor lists (ie: calling
    MmUnlockPages twice with the same list, etc). If a kernel debugger is
    available get the stack trace.
    Arguments:
    Arg1: 0000000000000002, A list entry was corrupt
    Arg2: 000000000000010c, entry in list being removed
    Arg3: 000000000007ffff, highest physical page number
    Arg4: 0000000000000001, reference count of entry being removed

    Debugging Details:
    ------------------


    CUSTOMER_CRASH_COUNT: 1

    DEFAULT_BUCKET_ID: DRIVER_FAULT

    BUGCHECK_STR: 0x4E

    PROCESS_NAME: System

    CURRENT_IRQL: 2

    LAST_CONTROL_TRANSFER: from fffff800010ab7ca to fffff8000102e890

    STACK_TEXT:
    fffffadf`c90a2ac8 fffff800`010ab7ca : 00000000`0000004e 00000000`00000002
    00000000`0000010c 00000000`0007ffff : nt!KeBugCheckEx
    fffffadf`c90a2ad0 fffff800`010023f2 : fffffadf`c9603240 00000000`00000000
    00000000`00000010 fffffadf`cbd3e8c0 : nt!MiUnlinkPageFromList+0x7e
    fffffadf`c90a2b70 fffff800`0100261e : fffffadf`cbb38d90 00000000`00000000
    00000000`00000000 00000000`00000000 : nt!MiGatherPagefilePages+0x4a9
    fffffadf`c90a2c60 fffff800`013cf9b2 : fffffadf`cecc1040 00000000`00000080
    fffffadf`cecc1040 00000000`00000000 : nt!MiModifiedPageWriterWorker+0x444
    fffffadf`c90a2ce0 fffff800`0124a972 : 00000000`00000000 fffffadf`cecc1040
    fffffadf`cecc1040 fffffadf`c8c83680 : nt!MiModifiedPageWriter+0x1f2
    fffffadf`c90a2d70 fffff800`01020226 : fffffadf`c8c7b180 fffffadf`cecc1040
    fffffadf`c8c83680 00000000`00000001 : nt!PspSystemThreadStartup+0x3e
    fffffadf`c90a2dd0 00000000`00000000 : 00000000`00000000 00000000`00000000
    00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16


    STACK_COMMAND: kb

    FOLLOWUP_IP:
    nt!MiUnlinkPageFromList+7e
    fffff800`010ab7ca cc int 3

    SYMBOL_STACK_INDEX: 1

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: nt

    DEBUG_FLR_IMAGE_TIMESTAMP: 460280f7

    SYMBOL_NAME: nt!MiUnlinkPageFromList+7e

    IMAGE_NAME: memory_corruption

    FAILURE_BUCKET_ID: X64_0x4E_nt!MiUnlinkPageFromList+7e

    BUCKET_ID: X64_0x4E_nt!MiUnlinkPageFromList+7e

    Followup: MachineOwner
    ---------

    So now I have to choose between restarting the game, or restarting my
    computer and crashing during games.

    So I rather restart the game instead.

    End conclusion:

    De-installing dual core optimizer ;)

    Hopefully games in the future stick with windows api and don't use asm and
    rts clock instruction or something like that ;)

    Bye,
    Skybuck.
     
    Skybuck Flying, Oct 16, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.