Compaq Armada 7800 will not start with battery

Discussion in 'Compaq' started by Damien, Jul 21, 2003.

  1. Damien

    Damien Guest

    I have a Compaq Armada 7800. With the power cord connected the laptop runs
    fine and power management reports only 3% of the battery is full and that it
    is still charging when in fact its not. I have a new battery and external
    charger so I know the battery is good and fully charged, also the laptop
    will charge the battery with no problem too. Its when I try to power up the
    laptop with the just the battery, the laptop will boot and I see the Compaq
    screen then the laptop will shut off and will not power up again until I
    remove the battery and slide it back in the laptop will power up again and
    shut off everytime at the Compaq screen. I have tried both bays with the new
    battery just to get the same end result.

    Is the problem in the system board or could it be the power supply. Thanks
    for any help...
     
    Damien, Jul 21, 2003
    #1
    1. Advertisements

  2. Damien

    DEJ57 Guest

    One would think my only solution for any PC problem is reset the CMOS or
    replace its battery. I don't know about the 7800 but some older Compaq laptops
    would not boot if the CMOS battery was dead unless connected to A/C adaptor.
    Might replace that CMOS battery....

    Dale
     
    DEJ57, Jul 22, 2003
    #2
    1. Advertisements

  3. Damien

    - Bobb - Guest

    A few questions first :

    You said that you have " have a new battery and external charger " : did you
    1. have this problem
    and
    2. bought the new battery and external charger to fix it ?

    If so, prior to this , did it also charge to 3% ?

    My reason for asking is that I worked for Compaq for years and it was common
    for a lot of the batteries to " appear fully charged" meaning that the
    customer would press the button on the battery and the indicators would
    indicate that it was fully charged, when it really was a bad battery and
    would not accept a charge. There's 2 "parts of the battery" the "charging
    part" and the "reservoir part". Sounds like your charging section is dead.
    OR the chemicals in there won't hold a charge (too old) = same result = NG
    to you. . If it's something you bought "new" , have them send you another.
    There were a LOT of problems with batteries for the 7400,7800,m700 etc - all
    the same vintage. Often it would prevent the PC from powering up - it would
    pull down the voltage of the laptop. you pop out the battery, power up and
    then reinsert and it was OK - but it wouldn't charge.

    bobb
     
    - Bobb -, Jul 23, 2003
    #3
  4. Damien

    Damien Guest

    I was having this problem before the new battery. With the old ( dead )
    battery it would report no charging. I have tried 3 new batteries with the
    same result, the laptop will charge the battery for around an hour and half
    and then the charge light goes off, with the external charger I charged one
    of the batteries and the same thing happens every time laptop will boot to
    the compaq logo and then shut down. And all 3 batteries reported 3% full and
    charging in Power Management but there is no charging happening and all 3
    batteries reported they were full by pushing the button on them.
     
    Damien, Jul 23, 2003
    #4
  5. Damien

    Damien Guest

    Thanks everyone 4 replying. I have the problem fixed now. It was a BIOS
    thing, after flashing it to the newest version all is well now. I am glad it
    was just that I wasn't looking forward to opening this thing up and
    replacing the MB. Thanks again 4 all the help...
     
    Damien, Jul 27, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.