Compaq Armada M700 Combo NIC driver problem

Discussion in 'Compaq' started by UHAP023, May 24, 2004.

  1. UHAP023

    UHAP023 Guest

    I have installed Win98SE on a Compaq Armada M700 laptop but cannot load
    the drivers for the internal NIC. The NIC is a modem/NIC combo (part no.
    1456VQL10H(INT)). I have downloaded and tried all of the drivers listed on

    http://h18007.www1.hp.com/support/files/Armada/us/locate/4_1009.html#17

    I have also tried the SP12942 driver d/l from driverguide.com which is
    listed specifically for the 1456VQL10H combo NIC -- all without success.

    In Windows, under Control Panel/System/Device Manager, There are modem
    related devices listed under Network Adapters for which Windows has loaded
    the drivers but there are no NIC/Ethernet related drivers there.

    Under Unknown devices, there is an entry 'PCI Communication Device'
    listed. I have tried loading all the above drivers for this Unknown
    device, without success. It is unclear to me why, if this device is the
    NIC component of the combo card, it should be listed here rather than
    under Network Adapter.

    The BIOS config. does not appear to have a NIC enable/disable option...

    Any ideas?

    Thanks
    Tom Crane.
     
    UHAP023, May 24, 2004
    #1
    1. Advertisements

  2. UHAP023

    HH Guest

    What OS was originally installed?
    HH
     
    HH, May 24, 2004
    #2
    1. Advertisements

  3. UHAP023

    UHAP023 Guest

    I don't know -- it came with an erased HD ;-(
    Tom.
     
    UHAP023, May 24, 2004
    #3
  4. UHAP023

    HH Guest

    HH, May 24, 2004
    #4
  5. UHAP023

    Sharmon Guest

    Sharmon, May 24, 2004
    #5
  6. UHAP023

    UHAP023 Guest

    Indeed. I've tried the NIC diver on the URL below -- it is a link
    from their main list of drivers for the M700 which I gave in my first post.

    The thing that puzzles me is that the Windows device driver manager identifies
    no Network Adapters corresponding to the Ethernet card when it boots.
    If the H/W is present it should see it and prompt for the correct driver,
    if its not present on the Windows installer CD. Agreed?

    Tom
     
    UHAP023, May 26, 2004
    #6
  7. UHAP023

    HH Guest

    Not always. Software (controllerless) modems often are not detected by
    Windows at all, or at best as an "unknown" device in Device Manager. That
    may be true of your combo card as well.
    HH
     
    HH, May 26, 2004
    #7
  8. UHAP023

    ITApprentice Guest

    I have the same adapter (1456VQL10H(INT)) in an Armada M300. Still
    can't get the darn thing to work. Has anyone gotten it to work. If so
    are there any tricks to it?
     
    ITApprentice, Jun 24, 2004
    #8
  9. UHAP023

    UHAP023 Guest

    No. I gave up re; Ethernet and bought a cheap PCMCIA card instead. The
    modem part of the combo works OK.

    Tom.
     
    UHAP023, Jun 25, 2004
    #9
  10. Are you sure the mini-PCI card actually _has_ a NIC ? ISTR seeing some
    that have the pysical RJ45 socket, but wired to nowhere. I'd guess when
    shipped the card would have had a blanking plug fitted, which has since
    gone astray.

    In case its still of interest, I'll probably be breaking a M700 shortly.
    (internittent mobo fault :-/ ). One of the items would be the mini-PCI
    ethernet/modem combo (which worked fine with win98se - ISTR its an Intel
    NIC chipset). Just trying to get some money back on it ...
     
    Martin Slaney, Jun 26, 2004
    #10
  11. UHAP023

    Cosmin N. Guest

    The M700 shipped with an Intel 56k/NIC combo mini-PCI, so unless it's
    defective, it should work. It's not supported by the Win2k drivers (not
    sure about XP, never ran that on my old M700), but Compaq has the proper
    drivers for it.

    Cosmin
     
    Cosmin N., Jun 26, 2004
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.