Copying from iTunes to Excel

Discussion in 'Apple' started by Don Tuttle, Jan 11, 2014.

  1. Don Tuttle

    Don Tuttle Guest

    Seems to me I used to be able to click on a tune in an iTunes playlist,
    Select All (with Command-A), Copy, and Paste the playlist into Excel.
    Now I cannot Select All either with the keyboard command or from the
    menu. If I select the first tune in the playlist, then Shift-Click on
    the last tune, then try to Copy, the Copy command is greyed out, so I
    can't copy.

    How can I get an iTunes playlist into Excel? Or is this possible?

    Help appreciated. Thanks.
    Don



    System 10.6.8, iTunes 10.7
     
    Don Tuttle, Jan 11, 2014
    #1
    1. Advertisements

  2. It's not greyed out on my system; I can copy it and paste it into
    Numbers. iTunes 11.1.3
     
    Michelle Steiner, Jan 12, 2014
    #2
    1. Advertisements

  3. I was able to select all songs in a playlist but could not paste them
    into Numbers or Excel. The list isn't delimited by tabs, just spaces.
    It's not even fixed width.

    When I pasted into BBEdit, it was just a list of songs with lots of
    spaces between them. There doesn't seem to be a way to add a delimiter.
     
    Michael Vilain, Jan 12, 2014
    #3
  4. Don Tuttle

    Savageduck Guest

    Are you just trying to get a formatted printout of a play list, or do
    you have a specific reason for importing into Exel?

    If I need a printable format of a playlist to share I highlight the
    first song in the list, select all (command+A) then print as a "Song
    list" and choose the "Save as PDF option.
    That will get me this sort of result.
    < https://dl.dropbox.com/u/1295663/FileChute/Road#4.pdf >
     
    Savageduck, Jan 12, 2014
    #4
  5. I'm running 10.8.5 with iTunes 11.1.3 and Excel 14.3.9. Pasting into
    Excel worked. Pasting into Numbers 2.3 did not work.

    I'm not the OP, just verifying behavior they might see.
     
    Michael Vilain, Jan 12, 2014
    #5
  6. I'm running 10.9.1 with Tunes 11.1.3, and Numbers 3.0.1. It works with
    this version of Numbers:

    <https://www.dropbox.com/s/gf2939rxgxoahdr/iTunes export.pdf>
     
    Michelle Steiner, Jan 12, 2014
    #6
  7. When I select and copy the selected tracks to a text editor like BBEdit
    and look at the pasted text, it's delimited by spaces, not tabs. If I
    paste the contents of the clipboard into Excel, it works fine. If I
    paste into the first cell of Numbers, it displays the text of the first
    line of the paste buffer in the first cell, but that's it.
     
    Michael Vilain, Jan 12, 2014
    #7
  8. When I paste it into TextWrangler, Pages, or TextEdit (in plain text
    mode), the pasted text is tab delimited. When I paste it into TextEdit
    (in RTF mode) or mail.app (in either text or RTF mode), the tracks
    themselves are pasted, and can be played from within the document.
     
    Michelle Steiner, Jan 12, 2014
    #8
  9. I'm on 10.8.5. I just tried it again with a different playlist.

    This selection of 158 songs came out as tab delimited in BBEdit.
    Pasting into Numbers 2.3 allowed for the first field of the first line
    to paste into the first cell.

    Opening the BBEdit tab-separated txt file into a new sheet worked in
    Numbers 2.3.

    I have no idea what the OP is struggling with. It "works for me".
     
    Michael Vilain, Jan 12, 2014
    #9
  10. Don Tuttle

    Don Tuttle Guest

    I am OP. Thanks for all help and comment. What happened seems not to
    have had anything to do with iTunes or Excel. In what I was trying to
    do, Select All just quit working, and Copy didn't work either. I
    restarted, both functions resumed their normal operation, and the
    playlist pasted into Excel.

    Thanks Savageduck for suggestion to obtain formatted printout of
    playlist by printing as a "Song list" and choosing the "Save as PDF"
    option, which will come in handy in the future.

    Re do I have a specific reason for importing into Excel, I want to
    create a document which, for a particular artist, lists albums only,
    not individual tunes. I used to know how to do that in Excel and hope
    to remember, now that my playlist has been pasted into Excel.

    Don
     
    Don Tuttle, Jan 12, 2014
    #10
  11. Don Tuttle

    Savageduck Guest

    If you select the "print album list" from iTunes what you will get is
    the album cover, the artist, and a list of the songs from that album
    found in the play list. There is no option to drop the songs. So it
    will look like this:
    < https://dl.dropbox.com/u/1295663/FileChute/Road #4 A.pdf >
     
    Savageduck, Jan 12, 2014
    #11
  12. Don Tuttle

    Alan Browne Guest

    No problem here.

    iTunes 11.1.3 (8) (Mac OS X Mavericks)
    Excel 12.3.3 (Office 2008 for Mac)
     
    Alan Browne, Jan 12, 2014
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.