Creating a new bootable OS 9.2 disk by copying exsiting System folder?

Discussion in 'Apple' started by Eric Desrochers, Mar 3, 2007.

  1. Hello! A question for the Classic OS pros here! On MacOS 9, if I drag
    a working System folder from an HD to another, is the second HD now
    bootable? Or are there some invisible files that are needed that will
    prevent booting?

    I'm trying to move a system onto a larger HD and wondered if I need to
    reinstall the OS on the new HD or if just copying the existing one is
    sufficient.

    I need to know this before I start. Thanks!
     
    Eric Desrochers, Mar 3, 2007
    #1
    1. Advertisements

  2. Eric Desrochers

    John Byrns Guest

    I'm not sure I understand this "blessing" stuff, and "the custom system
    folder icon" stuff, can someone explain it in more depth? Up until last
    December I used a 14 year old Mac running system 7.5.5 as my main
    computer. With respect to the OP's original question I twice copied the
    system folder to a new or different hard disk and the system worked
    perfectly. The mystery I have is that two or three years ago the "the
    custom system folder icon" disappeared from the system folder, although
    the system continued working just fine. I don't remember for sure but
    this may have occurred after backing the entire hard disk up to ZIP
    disks, reformating the hard drive with two partitions in place of the
    original one, and then copying the backed up files back onto the hard
    drive. The lack of the system icon bothered me so I played around a bit
    and somehow got "the custom system folder icon" to reappear, perhaps I
    accidently "blessed" the system folder as I was playing around. Within
    a few weeks "the custom system folder icon" again disappeared but I was
    unable to repeat my trick of getting it to reappear, so I just went on
    using the computer for the past couple of years without "the custom
    system folder icon".

    I think this thread has given me some ideas for things to try, but can
    anyone explain what is going on here? What is the real deal with the
    system and finder icons?


    Regards,

    John Byrns
     
    John Byrns, Mar 3, 2007
    #2
    1. Advertisements

  3. Thanks all! I should have known that it would be so simple, it's a Mac
    after all! :)

    BTW, the machine is a B&W G3, still kicking after 8 years and counting
    (but the HD is making horrid noise so it will be replaced, hence the
    question).
     
    Eric Desrochers, Mar 3, 2007
    #3
  4. Eric Desrochers

    Eric P. Guest

    I've seen different procedures explained for blessing a System Folder.
    One that I recall having read recently is this: open System Folder,
    drag Finder and System outside that folder, then drag 'em both back
    inside.

    Under System 7.x, I was able to bless a Sysem Folder that had a generic
    folder icon by simply single-clicking on that folder, closing the
    window, then opening the window again. Voilá! A blessed and ready-to-go
    System Folder :)

    I don't know what details dictate which method blesses a given System
    Folder, but I suppose trying different methods till you hit on the one
    that works is sufficient, if not efficient.

    - E


    ==============================================================
    Posted with Hogwasher. Mac first, Mac only:
    http://www.asar.com/cgi-bin/product.pl?58/hogwasher.html
    ==============================================================
     
    Eric P., Mar 3, 2007
    #4
  5. Eric Desrochers

    Jon Guest

    I'm not sure of the technicalities of it (Google is, as usual, your
    friend there), but basically it means getting your Mac to recognize that
    this is actually a valid System Folder. Both the little tricks described
    elsewhere in the thread usually work. Setting the Startup Disk may aloso
    do it, AFAIR.
     
    Jon, Mar 3, 2007
    #5
  6. Eric Desrochers

    John Byrns Guest

    The thing that interests me is why my system works, apparently without
    being blessed? I wonder if "blessing" is only important if there is
    more than one system folder on a disk? I can see that I am going to
    have to sit down with my old Mac and see if I can figure out what is
    actually going on, given the new information I have learned from this
    thread.


    Regards,

    John Byrns
     
    John Byrns, Mar 3, 2007
    #6
  7. Ooops! Maybe not after all! The new HD won't Initialize. Drive Setup
    2.0.7 on MacOS 9.2.2, Western Digital Caviar WD400JB HD. HD is seen but
    Initialize will fail. Norton Disk Doctor 6.0.2 is unable to repair
    majors troubles with the B-tree or something, after several pass.

    I'm doing a Zero all data now and it takes a long time!

    The HD manufacturer, Western Digital, doesn't offer a Mac formatting
    utility either. My blue G3 should support up to 128 GB drives according
    to Low End Macs website.

    Any ideas?
     
    Eric Desrochers, Mar 3, 2007
    #7
  8. Eric Desrochers

    Jon Guest

    Well - as long as the Happy Mac is visible on your System Folder, by
    definiton it _is_ blessed and the MAc boots OK.
     
    Jon, Mar 3, 2007
    #8
  9. Eric Desrochers

    David Empson Guest

    That probably only works if there is no blessed system folder on the
    disk.

    If you have multiple system folders (with different names or in
    different subfolders) and one of them is already blessed, you need to
    drag the System or Finder file out of the desired system folder, then
    drag it back in again.

    (Dragging both of them out might temporarily bless the destination
    folder, which isn't necessary but won't hurt as long as you then bless
    the correct system folder by dragging them back again.)

    The technical method involved in blessing is the updating of some fields
    in the volume header portion of the directory, which point to the
    blessed system folder. When booting from a particular disk, Mac OS (9.x
    and earlier) looks for these pointers to locate the blessed system
    folder, which must contain at least System and Finder files. The name of
    the system folder is not important.

    If the volume contains an unblessed system folder then you won't be able
    to select it in Startup Disk, unless Startup Disk happens to also check
    for a root-level folder called "System Folder" (or its localised
    equivalent) and if that folder contains System and Finder then it
    blesses it for you. I doubt it would search every folder on the volume
    for you.
     
    David Empson, Mar 3, 2007
    #9
  10. Hello and thanks for the help! The error is simply "Initialization
    failed". The HD name in the drives list is <not mounted>. When I start
    the initialization, Drive Setup ask if I really want to erase the disk
    "Untitled". At one time when the initialization failed, the *finder*
    gave another error dialog with an error code, possibly error -127 or
    -147 but I'm not sure.
    The zero did nothing to solve the issue.

    I read elsewhere to try removing the other HD on the ide bus and setting
    the new drive to Master, instead of Slave. I'll try this later.

    Apple's Disk first aid could not repair and produced this error :
    Invalid BTree node size, 3, 0
     
    Eric Desrochers, Mar 4, 2007
    #10
  11. The HD was sold to me a month ago as brand new and was shipping in a
    sealed antistatic bag. Probably OEM because no retail box. I may
    return it but would like to decide if I want a replacement unit or a
    refund. Hence I'm trying to determine if this is a bad unit or an
    incompatible brand/model.

    The Drive Setup "Zero all data" function succeeded.
    The Drive Setup "Test disk" function succeeded and found no bad block.

    Using "Mac OS Standard" or "Mac OS Extended" format or varying the
    number or size or partition did nothing more.

    I read on the Apple support website that Drive Setup won't replace a
    newer or third party driver on an HD. Can this be the problem? What
    firmat, if any, do new HD typicaly have?
     
    Eric Desrochers, Mar 4, 2007
    #11
  12. I walked in late here, but what model drive and Mac was it?

    The Blue and White G3 and Beige G3 Macs could not access hard drives
    over 120 megabytes. Many of the iMacs with CRTs also had the same problem.
    So did the Kanga (3500), Wallstreet (both models) the Lombard and possibly
    the Pismo Powerbooks.

    The Beige G3, Kanga, and Wallstreet will not boot unless the partition is
    within the first 8,000 megabytes, Apple refers to this as 8gb.

    The Blue and White G3 was made in two versions. Apple refers to them
    as revision 1 and revision 2 motherboards. Some people refer to them
    as revision A and revision B, or just the B&W G3 and the revision A.
    If you have one, you should check out Apple's web pages.

    The Beige G3 is odd. They were made up to the time revision 2 B&W G3's were
    sold, so most of them have the same controller chip that is on the
    revision 1 motherboard. They can not access a slave drive on the primary
    IDE controller, and have speed problems with drives over 20 GIG besides
    the small boot partition limit.

    There were some Beige G3s that still have the limit, but can access 120gig
    drives and don't have the speed problem.

    I have no idea of when the iMacs switched.

    Note that the iMacs with a CRT, Kanga, Wallstreet, Lombard, Pismo,
    Beige G3 or B&W G3 will NOT boot from a USB or firewire drive.

    Some third party formating software for OS9 and OSX up to 10.3 had
    provisions for the controller chips with the speed problem,
    but it was not in the Apple disk drivers before OSX, and is only
    in 10,0-10.3.

    The problem shows up reading data.

    If your Mac came from the factory with a DVD drive, or a bracket for
    two primary drives, it does not have the speed problem.

    Geoff
     
    Geoffrey S. Mendelson, Mar 4, 2007
    #12
  13. Initialization *did not* succeeded. Zero data went thru but left me
    with an un-initialized drive. Same thing with Test disk. Merily
    because there are no bad block don't mean the disk is mountable.
     
    Eric Desrochers, Mar 4, 2007
    #13
  14. Hello. That's a new 40 GB Western Digital Caviar SE, model WD400JB in a
    Blue & white G3 with MacOS 9.2.2.

    The other, current startup drive is a 10 GB Quantum from an iMac DV.

    Thanks!
     
    Eric Desrochers, Mar 4, 2007
    #14
  15. A version one motherboard can not work with this drive. The drive is
    too fast.

    from : http://www.lowendmac.com/ppc/g3c.shtml

    The Rev. 2 b&w G3 uses a different motherboard, has an additional drive
    bracket, incorporates a new IDE controller chip (marked 402), and
    includes a faster version of the ATI Rage 128 video card. 350 MHz and
    400 MHz models may have either motherboard; 450 MHz and faster versions
    always have the Rev. 2 board from the factory. The new IDE controller
    improves slave drive support and solves a drive corruption problem.
    It also won't support a second IDE drive on the primary interface.
    It will look like it works, but the data will get scrambled.

    LaCie will let you download Silverling for OS9 for free. You could try it.
    It may be able to detect the controller chip and compensate for it.

    If it's a version two, then you have a different problem.

    Geoff.
     
    Geoffrey S. Mendelson, Mar 4, 2007
    #15
  16. I'm familiar with the article you quoted, I had previously read it. I
    surely have a rev 1 board since I bought the thing in early febuary
    1999, mere weeks after their introduction.

    BUT get this : I run a second 15 GB Maxtor drive as a slave along the
    factory HD on the built-in ATA interface since year 2000 with no
    problem. At the time, rumours of unsupported second slave HD were
    common but I found a website where it was stated Don't listen Apple,
    just do it and it will work, and it did. Of course, the Maxtor is from
    2000 and is surely slower than the current WD. But it proves that a
    second drive is possible, at least is some particular cases.

    Next, the new WD drive is said to be backward compatible with slower
    buses so should work with my ATA 33 interface?

    I'll try setting it as master and disconnecting the other HD.

    I just want to format this drive and copy my previous 2 drives content
    onto it and run from a single HD from now-on...

    Silverling, you mean Silverlining? I'm playing with it right now.
    Plain initialization also failed with this. However, the Test function
    returned positives results. I'm doing a complete "Reformat entire
    drive" now, it will be a while before it completes.

    Thanks again!
     
    Eric Desrochers, Mar 5, 2007
    #16
  17. Or maybe not! I wasn't about to wait 8+ hours before Silverlining
    complete the format entire drive. I cancelled the action and it
    proceeded to the next step, updating the driver and creating a file
    system. And it finally worked! I have a nice HD icon on the desktop!

    Out of curiosity, I re-tried Apple's Drive Setup, that failed again and
    made the HD to un-mount. Re-running Silverklining re-enabled the drive.
    Even created 2 partitions, which I want to have.

    I will now try to make it bootable and report back.

    Do you know if the LaCie stuff needs to stay on the start-up disk
    afterward? The extensions and control pannel?
     
    Eric Desrochers, Mar 5, 2007
    #17
  18. OK, the System folder copied correctly and needed no blessing.
    Restarting from the new hard drive was succesful.

    Now, I'm concerned that my interrupting the Format Entire Drive process
    might have left the drive in a less than perfect state so I will redo it
    overnight before migrating all my files onto the new drive.

    Then I will test drive the new installation a couple days before
    retiring the old HD and setting the new one as master and sole drive.
    My ear needs the rest, as my current HD is whinning so loudly!

    Thanks a lot all that offered help here!
     
    Eric Desrochers, Mar 5, 2007
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.