Creative audio not found on P2B-L

Discussion in 'Asus' started by Markko Hirvonen, Feb 18, 2004.

  1. I've just replaced a faulty motherboard with an Asus P2B-L motherboard
    in a dual-boot Win2K/linux machine. Everything went smoothly, with all
    hardware being picked up as before in both OSes (lan, video etc), with
    the exception of the Creative PCI 128 sound card (CT4810).

    This sound card was working fine in both Win2K and linux (Mandrake
    9.1) with the old motherboard. It is detected in Win2K as "multimedia
    audio controller" or some such generic name, but no amount of coaxing
    with the correct drivers will get it to accept it and work at all. I'm
    a bit of a linux newbie, but it is not properly recognised either,
    only appearing as a generic sound card (that doesn't work).

    So - my question is... is there any simple reason why the sound card
    should work on the previous motherboard but not on the P2B-L? It
    appears to be seated correctly etc, and as I said everything else
    worked first time. Keep in mind that Win2k does recognise it as a
    generic sound card but can't do anything with it. I just thought there
    may have been some onboard setting or something that was disabling it
    or interfering... but nothing I can find, apart from this SB-LINK
    thing which is sort of Greek to me. This board appears not to have
    onboard audio.

    I wanted to ask here before I started replacing the sound card,
    finding replacements to troubleshoot etc.

    Thanks!
    Markko
     
    Markko Hirvonen, Feb 18, 2004
    #1
    1. Advertisements

  2. Try putting it into another slot, preferably one that doesn't share an
    INT line with anything else.

    Stephan
     
    Stephan Grossklass, Feb 18, 2004
    #2
    1. Advertisements

  3. Thanks - a little trial and error in trying different slots and it worked.

    Muchas gracias,
    Markko
     
    Markko Hirvonen, Feb 19, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.