1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Creator 3D UPA card problems on an Ultra 10

Discussion in 'Sun Hardware' started by thick_guy_9, Aug 31, 2006.

  1. thick_guy_9

    thick_guy_9 Guest

    Guys,
    When I first bought the Ultra 10 (440MHz,512MB and no Creator3D), I
    connected to the VGA and minimal installed Solaris 8.

    OBP version = 3.25

    Then I bought a creator 3D card + 13W3 adaptor, installed the card in
    the UPA slot and got myself into the following troubles, when I
    connected the PC monitor via 13W3 adaptor to the UPA card:

    #1. I get this message all the time: Can't find driver for console
    framebuffer

    #2. If I boot off the hard disk (solaris 8) I get to the stage when it
    is trying to launch X desktop, then hangs.

    #3. After searching the web, I realized that perhaps the necessay
    drivers were not installed in Solaris 8. So I tried to install Solaris
    10 6/06. This time I get the error:
    Fast Data Access MMU Miss. I also learnt that this is a very difficult
    error to investigate.

    Please can anyone help me to sort this issue? My goal is to install
    Solaris 10 to learn.
    I have *NO* idea of any of the OBP commands. Any help will be
    appreciated.

    TIA
    AS
     
    thick_guy_9, Aug 31, 2006
    #1
    1. Advertisements

  2. Two comments! Your OBP is not current. The current version is v3.1.
    It has nothing to do with your Creator problem and is not something that
    urgently needs to be fixed. You may, however, want to get that up to
    date after you solve your other problems.

    Solaris 8 has the necessary drivers! If you did less than the "full"
    install they may not have been installed because you did not have the
    hardware installed. Good luck finding out which package(s) install the
    driver; the labor involved in that is why I do the full install in the
    first place.

    See docs.sun.com for OBP documentation.
     
    Richard B. Gilbert, Aug 31, 2006
    #2
    1. Advertisements

  3. thick_guy_9

    Jeff Wieland Guest

    A couple of notes:

    The current OBP release is 3.31, contained in patch-id 106121-18.

    I believe that the packages you'll need for the Creator under Solaris 8
    are SUNWffb, SUNWffbcf, SUNWffbw, and SUNWffbx. If you have the XIL
    runtime environment installed, you might want SUNWxilvl as well. Be
    sure to install any patches associated with these packages, which would
    at least be 108605-37. If you get a second monitor, you can run
    your Ultra 10 dual-headed, but you can't merge the displays into
    one large display (Xinerama mode). At least, I've never been able to
    get it to work. I do know that the color depths have to be the same,
    and since the Creator does both 8 & 24 bit color, and the PGX24 does
    only 8 _or_ 24 bit, that this won't work. I did try using a PGX32
    (which can do 8+24 bit color) and the Creator that way, and they
    wouldn't work either.

    Solaris 8 should run very nicely on your Ultra 10. I've got 1 GB of
    memory in mine, along with SCSI drives, and (yeah I know I shouldn't
    have) I've overclocked the 440 MHz processor to 480 MHz. SCSI makes
    a huge difference in these machines -- the I/O with IDE drives is
    pathetic.
     
    Jeff Wieland, Aug 31, 2006
    #3
  4. Check (pkgchk) that you have the following packages installed:
    SUNWffb.u CreatorGraphics (FFB) System S/W Device Driver
    SUNWffbcf CreatorGraphics (FFB) Configuration Software
    SUNWffbw CreatorGraphics (FFB) Window System Support
    SUNWffbxg CreatorGraphics (FFB) XGL Support
    SUNWffbx CreatorGraphics (FFB) System S/W Device Driver (64-bit)

    If they are not installed, you must install them.

    "Fast Data Access MMU Miss" is a hardware problem. If it persists you
    can try removing your memory DIMMS (use anti-static precautions!), and
    reseating them. If that doesn't fix the problem you need professional
    help and it's probably cheaper to scrap and replace the machine than to
    pay Sun for a service call.
     
    Richard B. Gilbert, Aug 31, 2006
    #4
  5. thick_guy_9

    x Guest

    This sounds like what was originally missing to, as well.
    I believe that the installer will install these automatically
    if it sees the card at install time. If you put the card
    in at a later time. You'll have to add them yourself.

    You may also need to install the OpenGL packages to
    get 3D to work, but these should at least get X (2D) working.
    This also can happen if you make an invalid access from an fcode program.
    This can happen by accessing an invalid pointer/address (a firmware bug),
    or a device that doesn't exist. It's something you'd get a SEGV or Bus Error
    for if Unix was running. So unfortunately, it can mean a lot of things.

    Make sure there is is nothing in your environment explicitly referencing
    something that may have been removed. Like output-device set to
    an old graphics card (reset this to "display), and it'll look for the
    "best" one). Or maybe an old disk/controller or network card.
     
    x, Sep 1, 2006
    #5
  6. thick_guy_9

    x Guest

    For XInerama, you essentially need to have all the graphics cards
    be identical. Or at least nearly so (use the same driver).
    So you could probably do it with an FFB2 and an FFB2+, since
    they both use the same driver. Supposedly the IFB and JFB
    drivers are close enough to intermix, as well.
    The screen resolution needs to match, as well. At least
    at the adjoining edge (so 1920x1200 and 1600x1200 can
    be used side to side, but not top to bottom)
    Also make sure all the cards are configured the same
    as far as depth and color (defdepth, fake8, etc).
     
    x, Sep 1, 2006
    #6
  7. thick_guy_9

    thick_guy_9 Guest

    Jeff,
    What compatible SCSI cards are you using? Used SCSI cards are too
    expensive and hard to come by :-( I will remember for future
    "upgrades". For now I need to get this sorted
    Thanks
     
    thick_guy_9, Sep 1, 2006
    #7
  8. Hi,

    A original Sun SCSI card which you can use for booting and connecting
    inside the U10 is not that expensive, nor disks.

    Ofcourse, depends on where you are located.

    Look on Ebay for Sun Swift PCI,
    http://cgi.ebay.com/SUN-SunSwift-PC...ryZ20328QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

    $27, I have a number of them and they work fine and should be cheap to ship.

    Theu you can connect then using a standard SCSI 68 pol cable(not the one
    used for external use), also cheap ones.

    A normal 68 pol SCSO(not SCA) is also cheap unless you need a huge, so
    it should not cost you that much to upgrade.

    /michael
     
    Michael Laajanen, Sep 1, 2006
    #8
  9. thick_guy_9

    thick_guy_9 Guest

    UPDATE:
    Thanks gentlemen, for all your inputs.

    I spent the best part of this morning and last night to get this sorted
    out. Also posted it on Sun Forums.
    I tried #1 following the suggestion there (I am in Asia TZ, so did not
    see your replies when I left for home):

    1. ok show-displays
    then chose /SUNW:[email protected],0 which is the Creator card.
    Then,
    ok nvalias myscreen ^Y
    ok setenv output-device myscreen

    But still no luck.

    1.1 Then, I tried to reinstall Solaris 8 2/04. This time, I COULD
    NOT get the mouse to work, during and even after the installation was
    complete. I can use the UPA card though, so I assume Solaris 8
    installed the drivers.
    1.2 Then, tried to install Gentoo Linux (to try if it recognizes
    the Mouse and Creator card). After a frustating install trying to
    compile the Linux kernel (with buggy DMA sound programs), when I
    rebooted I get the same MMU Miss issue, after SILO.
    1.3 Solaris 10 6/06 Install CD is stubbornly refused with the MMU
    miss error.

    2. As per you folks' suggestion, I will remove and reinsert the memory
    chips.
    But, what are the NON-STATIC PRECAUTIONS? Any help here please?

    3. Also I plan to remove the Creator card, and try to install Solaris
    10 using VGA card. It will be slow and bring grief to the family,
    because of loss of family time. :-|. But atleast I know that the
    machine does not dislike Solaris 10.

    The QUESTIONS that nags me though:
    1. Why-o-why is the Solaris 10 CD 1 only give the MMU Miss error?
    2. when I do OK PRINTENV, I see PGX24 with a defined value. This system
    was preowned, so I am not sure if this has to be removed.

    Thank you guys...
     
    thick_guy_9, Sep 1, 2006
    #9
  10. At the bare minimum, touch the metal frame of the machine before
    handling the DIMMs. Better is to purchase an anti-static wrist strap,
    connect it to the metal frame of the machine and wear it. An
    electrostatic charge that you would not even notice is sufficient to
    damage some computer chips. The precautions are cheap, replacing memory
    DIMMs, or a mother board is not!
     
    Richard B. Gilbert, Sep 1, 2006
    #10
  11. thick_guy_9

    thick_guy_9 Guest

    UPDATE #2:

    1. I removed the RAM chips and reseated them. I also removed the UPA
    card (it is quite long, almost as long as the machine itself) and
    re-inserted it.

    2. I still have the same issues:

    #1. If I insert and boot from Solaris 10, CD 1, I get the MMU MISS
    error.
    #2. If I insert and boot from Solaris 8 CD, (software CD1), it boots,
    but OPENWINDOWS
    DOES NOT see the mouse.


    Therefore, I suspect, that the MMU MISS error is due to the BIOS
    missing the mouse port.

    So can you guys suggest what I should do next?

    Thanks
     
    thick_guy_9, Sep 2, 2006
    #11
  12. thick_guy_9

    Trinean Guest

    Therefore, I suspect, that the MMU MISS error is due to the BIOS
    Can you try a different mouse and/or keyboard and make sure all the
    connections are tight?
    On the Ultra 10 the mouse plugs into the keyboard and the keyboard plugs
    into the back of the computer.
    So if the port was bad on the system board I'd expect you would have
    keyboard problems as well.
    It could just be a crappy keyboard or mouse or even keyboard cable!
    A new mouse or keyboard is cheaper than a new system board and less work to
    replace.

    If you haven't already done so as in the previous suggestions, then I'd say
    to flash the firmware to 3.31.
    Then at the ok> prompt:

    ok> setenv auto-boot? false
    ok> setenv diag-level max
    ok> setenv diag-switch? true
    ok> power-off

    Disconnect the keyboard and hook a 9600 baud terminal to ttya and see what
    output you get.
    The Ultra 10 will run through the most extensive built-in self-tests it can.
    If you get to the ok>
    prompt with no apparent problems, then do:

    ok> show-post-results

    to see if you missed something. If this confirms all is good, then you can
    set things back down:

    ok> setenv diag-level min
    ok> setenv diag-switch? false

    Trinean
     
    Trinean, Sep 2, 2006
    #12
  13. thick_guy_9

    x Guest

    <>
    <ed7ak1$os6$>
    <>

    Try reconconfiguring your devices (sol8) with:

    reboot -- -r

    Maybe this will fix the mouse problem.

    Is it possible you have the wrong type of mouse ??

    I'd try booting Sol10 using the serial port console.

    You can set output-device and input-device to ttya
    Or you can often just unplug your keyboards, and it'll
    default to serial as a fallback.

    Where does it die in the boot sequence ?
    (You can now capture this more easily if
    you have a terminal emulator on the serial port)

    If serial boot works, you can try:
    input_device ttya
    output_device screen
    (type in terminal, but results are on the Sun display)

    This will test the graphics card bootup, but still
    eliminate the kbd/mouse.
     
    x, Sep 3, 2006
    #13
  14. thick_guy_9

    thick_guy_9 Guest

    UPDATE #4:
    Thanks Trinean and X.

    Actually the mouse works. I panicked, but the mouse moves somewhat
    slowly.

    My problem is to now resolve the MMU Miss error when I boot from
    Solaris 10 CD.

    You guys gave the sugesstion of connecting to the serial console.
    I have a Creator Blaster modem (external) that came with the serial
    cable. Can I use this, or are you guys referring to what is known as a
    null-modem cable?

    Thanks for all your help so far...I am getting encouraged.
     
    thick_guy_9, Sep 5, 2006
    #14
  15. thick_guy_9

    mark Guest

    I may be wrong as it was some time ago, but my U10 also had some sort
    of MMU miss error. The reasson..

    I was booting from a DVD drive and my OBP wasn't up to date.

    I updated the OBP.. and installed from the Solaris DVD fine.

    I had roughly the same setup as you and installed with the creator card
    fitted.

    Hope this helps
     
    mark, Sep 5, 2006
    #15
  16. thick_guy_9

    Jeff Wieland Guest

    Various. I've got some of the old Sun Symbios-22801 based cards,
    the X6540A IIRC correctly. Not all 22801 are created equal. I
    used to have one that was a leter revision, and wouldn't work in
    a Sun -- I gave it to someone to use in a PC. I've got some old
    Intraserver UltraSCSI single channel cards that I picked up off
    Ebay years ago that work fine, too.

    There are a couple of the dual channel cards on Ebay right now
    starting under $20.
     
    Jeff Wieland, Sep 5, 2006
    #16
  17. thick_guy_9

    thick_guy_9 Guest

    UPDATE #5:
    Guys, before venturing into buying the null modem cable, I decided to
    try updating the OBP as suggested by Mark. I am confused by what
    version of patch 106121 to use.

    http://sunsolve.sun.com/handbook_private/Devices/Boot_PROM/BootPROM_Sun4u.html?#U5_10

    What are the values under column U2703? Do I have to open the Ultra 10,
    to see the system board number, or can I cleverly get the value from
    OBP? How can I do so?

    Thanks...
     
    thick_guy_9, Sep 11, 2006
    #17
  18. Don't worry about the part numbers; you need to download patch 106121-18
    which contains the Ultra 5/10 flash prom updater.

    You do this on a running system and you may need to change a jumper
    (check the documentation with the patch for details)

    Casper
     
    Casper H.S. Dik, Sep 12, 2006
    #18
  19. thick_guy_9

    thick_guy_9 Guest

    UPDATE # 6:

    Guys, I updated the PROM to 3.31 successfully.
    This gave me no success. I then swapped the CD-ROM drive for an earlier
    model and here are the errors from several tries:

    TRY 1:
    Short read 0x0 chars read
    disk read error
    boot: cannot find misc/sparcv9/krtld
    boot: error loading interpreter (misc/sparcv9/krtld)
    Elf64 read error
    boot failed
    Enter filename [/platform/sun4u/kernel/sparcv9/unix]: <I pressed ENTER>
    Alloc of Ox400000 bytes at Ox1000000 refused.
    Elf64 read Error
    boot failed
    Enter filename [/platform/sun4u/kernel/sparcv9/unix]:
    boot:failed to allocate 262144 bytes from scratch memory
    panic - boot boot:scratch memory overflow
    program terminated

    TRY 2:
    Short read 0x0 chars read
    disk read error
    /kernel/fs/sparcv9/ufs non-zero sect addr in input file
    ufs error reading sections
    relocation error:20:file /kernel/drv/sparcv9/sd:symbol:eek:ffset
    0x15a018c2d81 is non-aligned
    relocation error:20:file /kernel/drv/sparcv9/sd:symbol:eek:ffset
    0x15a018c2d84 is non-aligned
    do-relocations: /kernel/drv/sparcv9/sol do-relocate failed
    sd error doing relocations
    sd: cannot load driver
    cannot load drivers for /[email protected],0/[email protected],1/[email protected]/[email protected],0:b
    can't load the root file system
    type 'go' to resume

    TRY 3:
    Trap 3e
    boot device: /[email protected],0/[email protected],1/[email protected]/[email protected],0:f

    TRY 4:
    Bad magic # in disk label
    can't open disk label package
    Boot load failed
    The file just loaded does not appear to be executable


    Any help on this please...?
    TIA
    AS
     
    thick_guy_9, Sep 21, 2006
    #19
  20. thick_guy_9

    thick_guy_9 Guest

    oh..

    I forgot to add that I am trying to install Solaris 10, not 9.
    For some strange reason I see the /kernel/...sparcv9 thing.

    ^^^^^^^^^
     
    thick_guy_9, Sep 21, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.