Ctrl-clicking a file in finder takes close to a minute to bring up the context menu

Discussion in 'Apple' started by Peter Møller Neergaard, Feb 17, 2006.

  1. I've had my Powerbook for a year plus. Originally, it had 10.3, but
    I've upgraded to Tiger about two months ago.

    Recently (probably within the last month), I've started to experience
    extreme delays in bringing up a file's context menu in finder: I
    control-click, the ``hour-glass'' (I don't know what else to call the
    rotating color circle) comes up, and somewhere between 30 seconds and 1
    minute later, I get the menu.

    It is caused by something in my user setup, but I've been only to
    locate this. I'm saying this as I've created a separate test user who
    do not see this delay, even when I try to control-click on the same
    file.

    I've also been unsuccessful in locating any suggestions through google.

    I would appreciate any help in how I can locate what is causing the
    hanging.

    Best

    /Peter
     
    Peter Møller Neergaard, Feb 17, 2006
    #1
    1. Advertisements

  2. Peter Møller Neergaard

    Randy Howard Guest

    Peter Møller Neergaard wrote
    (in article
    I haven't had this one happen myself, but it does ring a bell
    somewhere. Something about having had applications running on
    remote or external drives in the past. Maybe it's trying to
    look for formerly registered apps for "open with"? Dunno for
    sure, just a guess.
     
    Randy Howard, Feb 17, 2006
    #2
    1. Advertisements

  3. Peter Møller Neergaard

    Steve Jones Guest

    That's what I was thinking as well. There's an article here on how to
    clean up the launch services database (which is where the "Open With"
    stuff comes from):

    http://www.macosxhints.com/article.php?story=20031215144430486

    Steve
     
    Steve Jones, Feb 17, 2006
    #3
  4. Thank you Steve and Randy.

    My thought as well was that it had something to do with network time
    outs (it's typically the only thing that can take about a minute to
    time out).

    This reminded me that I at one point had connected to a server
    (apple-K). I removed that server, just in case. Unfortunately, no

    I followed the hint from Steve's link, even adding a -f to force
    reregistration. Unfortunately, this did not resolve the problem.

    Given it's central place in the OS, I can't remember Finder, but is
    there a way to completely reset all Finder related settings.

    /Peter
     
    Peter Møller Neergaard, Feb 17, 2006
    #4
  5. Do you have .Mac?

    I had horrible delays when opening the standard file dialog (which
    probably uses some of the same calls as "Open with..."). The solution
    was to turn off automatic sync'ing of my .Mac disk.

    Another wild guess...
     
    James Glidewell, Feb 17, 2006
    #5
  6. I do not have .mac. To play it safe, I've verified that there are no
    attempts to synchronize automatically.
     
    Peter Møller Neergaard, Feb 20, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.