1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Cygnal 8051F310 problem with onchip XRAM

Discussion in 'Embedded' started by John F, Jul 24, 2007.

  1. John F

    John F Guest

    #include <SiLabs IDE>
    #include <Keil uV II>
    #include <F310 dev Board from Silabs>

    Everytime I'm trying to use e.g.

    unsigned char myarray[8][25];

    in a (quite trivial) application I get linkage error with adress
    space. That's OK and working correctly.

    *** ERROR L107: ADDRESS SPACE OVERFLOW
    SPACE: DATA
    SEGMENT: ?DT?VALVE
    LENGTH: 007DH

    so far so good. As usual I added "xdata" and recompiled. The error is
    gone and the app is downloaded to the processor. BUT: the processor
    doesn't do anything at all. (OK... apparently nothing as I can't look
    inside :)

    Nothing I tried helped (changing memorymodel, defining XD(0-3FFH) for
    the linker ...).
    The map file looks OK.

    Up to now I like the cygnal stuff :)
    This is the first time I needed xdata on such a chip and now I'm
    puzzled. Been using Keil for a long time and never

    Right now I'm using a truncated array to store the samples so the app
    is doing OK now.

    Anyone out there to know what I overlooked?
     
    John F, Jul 24, 2007
    #1
    1. Advertisements

  2. John F

    2m Guest

    2m, Jul 25, 2007
    #2
    1. Advertisements

  3. John F

    Thad Smith Guest

    I am not familiar with your debugger, but if it were me, I would start
    single stepping from the reset location and see what it shows.
     
    Thad Smith, Jul 25, 2007
    #3
  4. John F

    Neil Guest

     
    Neil, Jul 25, 2007
    #4
  5. John F

    John F Guest

    Thanks. That's exactly what I did. The problem is that it compiles and
    links without error but doesn't work :)
     
    John F, Jul 25, 2007
    #5
  6. John F

    John F Guest

    I use the demo board with the USB interface for life debugging and do
    not get a connection :)
     
    John F, Jul 25, 2007
    #6
  7. John F

    Andy Peters Guest

    Assuming you're building using the Keil tools within uVision2:

    Right-click on your target and choose "Options for target
    'targetname'."

    Then, under the "target" table of the dialog that pops up, ensure that
    you check the box next to "Use On-chip XRAM (...)" so that the linker
    knows to actually use the internal RAM for things that should be put
    into XDATA space.

    That should work.

    -a
     
    Andy Peters, Jul 25, 2007
    #7
  8. John F

    John F Guest

    I have already added XD(0-3FFH) (I tried 0x0000-0x03FF too) to the
    linker commandline as uV2 does. Doesn't work :)
     
    John F, Jul 26, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.