1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Data transferred via USB ports is broken

Discussion in 'Laptops' started by Stefan Mueller, May 12, 2011.

  1. I've a Compaq Evo N800c laptop with a clean Windows XP installation.
    If I copy a file via the onboard network adapter (Ethernet) and do
    afterwards a compare of the original and the copied file both files
    are identical. But if I do the same data transfer to an USB stick or
    USB harddisk the copied files are not identical to the original files.
    Because I thought it's a problem of the internal USB controller and/or
    USB ports I bought an USB PCMCIA card which I can insert into the
    laptop. Unfortunatelly also the copied files via the new USB card are
    not identical to the original files.

    Does someone have an idea what the problem could be and perhaps how it
    could be fixed?

    Regards
    Stefan
     
    Stefan Mueller, May 12, 2011
    #1
    1. Advertisements

  2. Stefan Mueller

    Roger Mills Guest

    What method are you using to compare the files?

    What happens when you copy:
    a) between two different USB devices
    b) from hard-disk to USB stick and then back to hard-disk?

    The amount of disk space used will probably be different in different
    media because of differences in the format system and/or block size.

    But it's almost certain that the actual *contents* of the files - as
    seen by the applications which use those files - will be the same.

    I suspect that you are chasing a non-existent problem.
    --
    Cheers,
    Roger
    ____________
    Please reply to Newsgroup. Whilst email address is valid, it is seldom
    checked.
     
    Roger Mills, May 12, 2011
    #2
    1. Advertisements

  3. Back in the days of 8 bit CP/M that could have been true but Windows counts
    file sizes to the exact byte and I have never even once seen something that
    you claim to be "almost certain".
     
    Anthony R. Gold, May 14, 2011
    #3
  4. Stefan Mueller

    Roger Mills Guest

    As far as I know, the OP hasn't been back to tell us how he was
    comparing the files.

    I was making the point that, in Windows, a file has *two* sizes - the
    number of bytes of contents and the number of bytes of disk space occupied.

    If you copy a file from one storage device to another, the first of
    these should always be the same - but the second frequently won't
    because it will always be an integral number of blocks, and will thus
    change with blocksize.

    I suspect that the OP's copy is ok (which is what I meant by saying that
    the contents will almost certainly be the same) and that he has been
    misled by some spurious comparison into thinking that he has a problem.
    --
    Cheers,
    Roger
    ____________
    Please reply to Newsgroup. Whilst email address is valid, it is seldom
    checked.
     
    Roger Mills, May 14, 2011
    #4

  5. Thanks a lot for all your replies.
    Unfortunately the copied files are really not identical. I do the
    comparison with the 'comp' command from the Windows command prompt.
    I realized the first time that there is a problem as I tried to open a
    Ghost image which was copied before from my Compaq Evo N800c to my
    external USB harddisk (drag and drop). The Ghost Explorer complained
    that the image file is corrupted.
    I think this problem occurs only while copying huge files and only
    from time to time. But it's very uncomfortable if you can't be sure
    that the files have been copied correctly.
     
    Stefan Mueller, May 14, 2011
    #5
  6. Speaking of Ghost, I found I could never get a verified image of the HDD in a
    Shuttle computer using Drive Image v7, the program that Symantec bought from
    PowerQuest as the basis for Ghost v9 and onwards, onto a USB attached
    external drive Shuttle. There was an issue with the Shuttle motherboard's USB
    port or its driver that I never solved. I never has that problem with any of
    my Lenovo, IBM or HP/Compaq computers and I continue to use DIv7 to this day.
     
    Anthony R. Gold, May 15, 2011
    #6
  7. Stefan Mueller

    ~misfit~ Guest

    Is the USB device formatted FAT32? Could it be that you're running into the
    FAT32 file-size limit? (4GB)
    --
    Shaun.

    "He who fights with monsters might take care lest he thereby become a
    monster. And if you gaze for long into an abyss, the abyss gazes also
    into you." Friedrich Wilhelm Nietzsche
     
    ~misfit~, May 15, 2011
    #7
  8. NTFS.
     
    Anthony R. Gold, May 15, 2011
    #8
  9. Whoops, the tilde in your screen name misled me to believe you were replying
    to me. Please ignore that post.
     
    Anthony R. Gold, May 15, 2011
    #9
  10. No, my external 1.0 TB USB harddisk is formatted with NTFS.
    I'm using the same USB harddisk with all my IBM ThinkPads (T21, T22,
    T23, T30, A31p, T60p) and also with my Compaq Evo N600c without any
    troubles.
    Because I experience the mentioned problem only with my Compaq Evo
    N800c I think it's a hardware problem what was the reason I bought an
    USB PCMCIA card which I can insert into the
    laptop. Unfortunatelly it didn't solve the problem. Now I'm lost.
     
    Stefan Mueller, May 15, 2011
    #10
  11. Stefan Mueller

    Lou Marco Guest

    It's harmless in all but esoteric circumstances. A device doesn't
    really move a file character by character. And if it does, the disc drive
    doesn't save data that way. What's probably happening is that the chunks
    (blocks) that the USB device is using are larger or smaller than the blocks
    something else in the data path is using. When you have to fit 3 20 byte
    blocks into 1 51 byte block (for example) you take the 51 byte block,
    make it into 3 20 byte blocks, and then pad (fill) the empty space with 0 bytes
    (or whatever).

    The operating system knows where the file really ends so the "padding"
    doesn't matter. The program that says they're different is probably just
    adding up the size of the allocated blocks (the blocks that have some part of
    the file).
     
    Lou Marco, May 17, 2011
    #11
  12. Stefan Mueller

    Lou Marco Guest

    Comp isn't a very good way to compare files. They have to be
    exactly the same size for one thing.

    Sounds like you have a bad USB drive, though.
     
    Lou Marco, May 17, 2011
    #12
  13. *** I have not used Windows in some time, but try copying a test
    file at the command line using XCOPY and its `/V' (Verify) switch to see
    what that does. This won't check for file differences, but it will test
    to see if the data can be read from the target drive.

    To see if your XCOPY has this switch:

    XCOPY /?

    For a more powerful XCOPY, get XXCOPY and use its `/V2' switch. This
    will do a byte by byte check.

    http://www.xxcopy.com/
     
    Richard Bonner, May 26, 2011
    #13
  14. *** He might try "FC.com" or "FC.exe" if CMD has it.
     
    Richard Bonner, May 26, 2011
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.