Delayed Write Failed

Discussion in 'Asus' started by Tom, Apr 17, 2011.

  1. Tom

    Tom Guest

    Hello.

    I own a P4C800-E Deluxe motherboard, with Windows XP SP2 installed. I
    realize it's an old motherboard, but I can't afford to purchase a new
    computer. I'm hoping to get a few more years out of this one. :)

    The issue has to do with a little over one year old Rosewill 'R2-JBOD'
    external enclosure (self powered). The Rosewill is configured as JBOD,
    with two Western Digital WD1002FBYS-02A6B0 1TB drives installed. The
    Rosewill is connected directly to one of the motherboard USB ports.
    Windows has the drives configured for quick removal and I always use the
    'Safely Remove Hardware' to dismount the device. The Rosewill has worked
    flawlessly for about a year in it's present configuration.

    About one month ago, I went to defrag the Rosewill drives and several
    minutes into the defrag I receive a pop-up that said there was a
    'Delayed Write Failed', that data was "lost". I tried various things,
    but in the end what I thought solved the issue was a thorough cleaning
    of the inside of the computer case and the Rosewill enclosure. The issue
    immediately stopped after the cleaning. At the time I used the drives
    for approximately a couple more days without issue and the Rosewill was
    then powered down.

    One week ago I needed the Rosewill drives, and used them continuously
    for four (4) days solid, until I needed to reboot the computer. After
    rebooting, I decided to defrag the drives and I once again received a
    'Delayed Write Failed'. I have been defragging the system and USB drives
    with PerfectDisk for years without any issues.

    Typically when there is a 'Delayed Write Failed' it says which folder is
    "lost" and if I check that folder, all the files are gone. However, if I
    reboot the computer, all the files are back and they are completely
    intact. Which folder and which files are missing, change as I reboot the
    computer. It's as if whatever is causing the issue, at that specific
    point in time, is what's "lost". Also, most of the time I can hear the
    Windows drive un-mount chime and immediately the mount chine -- like the
    drive is momentarily dropping and coming back.

    I've used CHKDSK when the 'Delayed Write Failed' has occurred and
    especially when the files are supposedly missing and it reports that
    there is nothing wrong with the drive. It seems whenever I use CHKDSK
    nothing is ever found. Maybe I need better hard drive checking software,
    what would you recommend?

    The only other odd thing to happen recently was during one of the
    reboots I received a BSOD. The error was 'UNMOUNTABLE_BOOT_VOLUME'
    (Stop: 0x000000ED). According to Microsoft they say that this error
    message occurs "When Volume on IDE Drive with Caching [is] Enabled".
    They also say that this issue was fixed with Windows XP SP1, I have SP2.
    I checked the boot drive with CHKDSK and CHKDSK again reports no errors.
    And, it could be a coincidence, since in all these years it has only
    happened twice, with a fair amount of time passing by and with several
    boots in-between.

    Some other things I've tried include:

    1) Moving the USB cable for the Rosewill to one of the other seven
    motherboard USB ports.

    2) I've tried a different USB cable that's currently used for a
    different brand of USB enclosure, which works fine with that drive.

    3) I've removed the outer shell of the Rosewill to allow better air flow
    and the metal hard drive mounting frame is only warm to the touch.

    4) Rosewill fan is enabled.

    5) I've cycled the USB connector into the Rosewill and motherboard ports
    hoping to clear any possible oxidation. In addition, made sure that
    the BIG and JBOD mode switch inside the Rosewill was firmly set to
    JBOD by cycling the switch back and forth.

    Other than these two issues, the computer is working fine. I don't know
    if it's a motherboard (USB) issue or a enclosure (hard drive) issue.
    Hence, posting to two Newsgroups, with followup set. Sorry for the
    length of this post, I was trying to be as thorough as I could. If I
    missed any important details, please let me know.

    Thank you.
     
    Tom, Apr 17, 2011
    #1
    1. Advertisements

  2. Tom

    Rod Speed Guest

    It isnt that old and should continue to work as well as it ever did.
    That last isnt necessarily correct with a defrag, a well written one
    should only adjust the directory entrys after a write has succeeded.
    You dont lose anything when the write fails when the directory
    entrys still list the old location for the data that was being moved.
    That is absolutely guaranteed to be a coincidence.
    Dirty cases cant cause delayed write failures.
    Because its an intermittent fault.
    There is no point in furiously defragging drives at anything like that rate.
    Because there was no fault at that time.

    Defragging works the drives a lot harder than anything else does.
    Because the defragger is written properly.
    Nope, thats an illusion.
    Thats the fault, the drive is going offline for some reason
    and thats whats producing the delayed write failure.
    For the reason I listed at the top.
    Nope, the drive contents are fine.
    CHKDSK is fine as long as it doesnt hang. It can do
    that very occassionally with some drive corruption.
    So the problem they are talking about isnt your problem.

    Your problem is that the drive sometimes goes offline and you can hear that happening.
    Likely the fault has been around for some time and has lately got much worse.
    You need to do more than just do that once when
    its an intermittent fault that doesnt show up very
    often to prove anything about the port being used.

    You need to move the drive to another port and leave it there
    and see if the delayed write failure is ever seen again.
    Ditto with the above.
    It wont be that given it worked fine for years.
    Its better to just put it on a different port with a different cable and
    use it like that and see if the delayed write failure shows up again.
    The way to distinguish between those two possibilitys is to move
    the drive to another USB port with a different cable and leave it
    there and see if the delayed write fault ever shows up again or
    not. If it does, its likely the Rosewell enclosure going bad.
    Thats fine.
    Thats not, I have put them back to the original again so others
    who are interested can see the reply.
    Thats much better than not posting all the detail of what you have tried etc.
    Its pretty good, although we obviously cant know what vital
    info on what you might have tried you havent mentioned.
     
    Rod Speed, Apr 17, 2011
    #2
    1. Advertisements

  3. Tom

    Tom Guest

    Hello.

    Sorry for the delay. Life's unexpected tasks hasn't allowed me to run
    further tests and report the findings until now. Thank you goes out to
    all who have provided responses. I appreciate your interest in this
    issue. I've not set a followup per Rod's suggestion. All tests are
    performed after a reboot.

    First, for those that do not know, the 8 USB ports on the P4C800-E
    Deluxe motherboard fall into two separate clusters of ports. There are
    the four USB ports that are directly attached to the motherboard's rear
    panel, which I will call for the purpose of this post the primary USB
    ports. Then there are an additional four USB ports on a ASUS supplied
    plate that gets attached to one of the expansion slots on the back of
    the case and with two approximately 8 inch cables gets attached to two
    headers on the motherboard, which I will call the secondary USB ports.

    Also worth noting at this point the Rosewill has both M: and N: hard
    drives installed and is attached to one of the primary USB ports. The
    other three primary USB ports are vacant. Attached to the secondary USB
    ports with 3 meter cables are the communication between the computer and
    a UPS, printer, Mouse and the monitor. A quick note about the monitor.
    Built into the stand of the monitor is a two USB port hub. I often use
    the monitor's USB ports as a convenient way to attach Flash drives.

    The first test I ran with the above USB configuration was Western
    Digital's Data Lifeguard Diagnostics software. According to WinDLG, as
    expected both hard drives passed.

    Next, from Device Manager I un-installed the four USB Universal Host
    Controllers and the one USB2 Enhanced Host Controller. Essentially this
    removes the entire USB branch from Device Manager. After a reboot the
    hardware was immediately discovered by Windows without issue. Ran
    PerfectDisk and 6 minutes later received a Delayed Write Failed.

    Next, I removed the N: hard drive from the Rosewill enclosure and then
    attached the hard drive to the Vantec adapter (this device was described
    in my previous reply). Plugged the Vantec's USB cable into the side of
    the monitor. Re-ran PerfectDisk and 45 minutes later without finishing
    the defrag, there was no Delayed Write Failed.

    Next, to see if the previous test was a fluke, I put the N: hard drive
    back into the Rosewill enclosure. Re-ran PerfectDisk and several minutes
    later received a Delayed Write Failed.

    Next, I swapped the location of the M: and N: hard drive inside the
    Rosewill enclosure to see if there was a SATA/Power connector issue.
    Re-ran PerfectDisk and several minutes later received a Delayed Write
    Failed.

    Next, to test the power supply of the Rosewill enclosure, I removed the
    M: hard drive, leaving the N: hard drive. Re-ran PerfectDisk and several
    minutes later received a Delayed Write Failed.

    Next, with only the N: hard drive still in the Rosewill enclosure, I
    moved the USB cable back to the monitor USB port. Re-ran PerfectDisk and
    9 hours later PerfectDisk completed without issue.

    Next, I decided to move the four USB devices from the secondary USB
    ports and connect them to the primary USB ports. Connected the Rosewill
    with the single N: hard drive to a secondary USB port. Re-ran
    PerfectDisk and 5 hours later PerfectDisk completed without issue.

    Next, I put back into the Rosewill enclosure the M: hard drive (now both
    hard drives are installed) and the Rosewill enclosure is still connected
    to a secondary USB port. Re-ran PerfectDisk and multiple hours later
    PerfectDisk completed without issue.

    Although I could be wrong, it seems to me that the issue with Delayed
    Write Failed isn't with the hard drives, the Rosewill's 3 meter USB
    cable (6 meters if you count the monitor's cable), the Rosewill or the
    Rosewill's power brick. That the issue is more likely with the primary
    USB ports. I can't explain why, when I earlier tested the secondary USB
    ports, that there was a Delayed Write Failed, other than to say I pulled
    one cable out at a time. Perhaps a IRQ conflict? I was extremely tired,
    so maybe I dreamed the entire sequence. :)

    Anyway, at this point I can't get a Delayed Write Failed to happen as
    long as the Rosewill sits on a secondary USB port. I've run a couple
    other tests, such as running a MD5 check, which took hours to complete,
    and there was no Delayed Write Failed. It's obvious that something has
    changed with the primary USB ports and not for the better. What do you
    think?

    Thank you.
     
    Tom, Apr 20, 2011
    #3
  4. Tom

    Tom Guest

    This should read:

    Next, to see if the previous test was a fluke, I put the N: hard
    drive back into the Rosewill enclosure and back on the primary
    USB port. Re-ran PerfectDisk and several minutes later received a
    Delayed Write Failed.

    Also, the Rosewill USB cable remained on the primary USB port through
    the next couple of tests, until as noted, was moved back to the
    monitor's USB port.

    Sorry about the confusion.
     
    Tom, Apr 20, 2011
    #4
  5. Tom

    Rod Speed Guest

    Tom wrote
    You cant be sure of that, because the fault is clearly intermittent and went
    away for quite a while just by cleaning the Rosewill and system case.
    You cant be sure of that either given that its clearly an intermittent fault
    that can go away for days.
    Much more likely to just be an intermittent fault fooling you.
    You have seen a problem there in the past tho.
    You cant say that given that you have seen a delayed write failure
    on a secondary port and that you clearly have an intermittent fault.
    That you really need to try something very basic like changing the USB cable
    and see if you ever get any delayed write failures with a different one. And it
    need to work fine for a week or more before you can conclude thats where
    the problem lay. If you get a delayed write failure with a different USB cable
    you then need to use the Vantec adapter for weeks or until a delayed write
    failure shows up with that, to eliminate the Rosewell enclosure being the problem.

    You have already shown that you do get delayed write failures
    on both what you call the primary and secondary USB ports.
     
    Rod Speed, Apr 20, 2011
    #5
  6. I'd be very reluctant to use even a 3m cable with a storage device, and
    6m, even with the hub in the monitor, is too long.

    Try a *good quality* shorter cable - 1m - on the primary USB port and
    see how that goes.
     
    Mike Tomlinson, Apr 21, 2011
    #6
  7. Tom

    Tom Guest

    Ack, that's a typo. I was attempting to convert 3 and 6 feet length
    cables to meters in my head and inadvertently combined both without the
    calculation.

    That should read:

    Although I could be wrong, it seems to me that the issue with
    Delayed Write Failed isn't with the hard drives, the Rosewill's 1
    meter USB cable (2 meters if you count the monitor's cable),

    Sorry about the confusion.
     
    Tom, Apr 21, 2011
    #7
  8. Tom

    Tom Guest

    In you wrote:

    [My Typo Corrected]
    True, it did go away for awhile after the cleaning. The only thing I can
    think of is that it's no longer an intermittent issue. That the primary
    ports (or those two USB controller chips) have now weaken past the point
    of intermittent. My most recent tests showed a consistency whereby,
    using the primary USB ports there was always a Delayed Write Failed
    error and there was no such error that occurred with the secondary
    ports. I'm by no means saying this to establish a conclusion, it's just
    an observation.

    One other observation that might be worthy of note is that despite the
    age of the P4C800-E Deluxe motherboard, the ASUS supplied USB plate was
    put into service about a year ago. Those 4 ports that consist of the
    secondary USB ports, are essentially brand new. While the primary and
    the secondary USB ports are not of the same design, I noticed that it
    requires a little bit more force to plug a USB cable into the secondary
    ports.

    [...]
    As I mentioned, a different cable was tried. The USB cable that I used
    belonged to a different brand and model of USB enclosure. I unplugged
    the cable from the back of the other enclosure and plugged it into the
    back of the Rosewill. Re-ran the test and received a Delayed Write
    Failed error. However, at the time this different cable was connected to
    one of the primary USB ports.
    Tomorrow I plan to take one of the hard drives out of the Rosewill and
    connect it to the Vantec adapter. In the previous test I connected the
    Vantec adapter to the monitor's hub, which in turn was connected to one
    of the secondary USB ports. This resulted in no Delayed Write Failed
    errors. This time around, I'll connect the Vantec adapter directly to
    one of the primary USB ports. I'll leave it like that for awhile and
    report back.
    I'm not so sure that swapping one cable at a time was the best way to
    test all of the ports.
     
    Tom, Apr 21, 2011
    #8
  9. Tom

    Rod Speed Guest

    Tom wrote
    And thats the evidence that it is an intermittent fault, because
    cleaning cant make a delayed write fault go away.
    Intermittent faults dont work like that.
    Chips dont fail like that. And that doesnt explain why you
    have seen a delayed write failure on the secondary ports.
    Thats the problem with intermittent faults, they can fool you on the basics like that.
    The physical port connectors dont age significantly.
    Thats just basic clearance stuff. Its not significant.
    OK, it wasnt clear that thats what you had said.
    The USB port doesnt matter because you have
    seen a delayed write failure on both types of ports.
    That does indicate the problem is with the Rosewell enclosure,
    if it continues to work fine in that config for say a week or two.
    It doesnt matter which port its connected to because you
    have seen delayed write failures on both types of ports.

    And you do need to do defrags frequently like say daily too.
    There is no need to test all the ports since you have seen
    delayed write failures on both primary and secondary ports.

    So far it looks like the problem is with the Rosewell enclosure
    and you need to run without it for a while and see if you ever
    see any delayed write failures when it isnt being used.
     
    Rod Speed, Apr 21, 2011
    #9
  10. No worries, but I still suggest you try a shorter, quality USB2 cable
    (borrow one?) and try again.

    Ignore anything Rod Speed has to say, he's the group idiot.
     
    Mike Tomlinson, Apr 21, 2011
    #10
  11. Tom

    Paul Guest

    While your problem is likely interconnect, there is one other thing you
    can play with.

    In Device Manager, the "USB Root Hub" entries have an item in Power Management:

    "Allow the computer to turn off this device to save power"

    You can try removing the tick from the box, and see if things improve.

    Paul
     
    Paul, Apr 21, 2011
    #11
  12. Tom

    Arno Guest

     
    Arno, Apr 21, 2011
    #12
  13. Me too, or people using cables supplied with USB1 devices with USB2
    devices. USB2 cable is of a tighter specification. The answer is to
    use the cable supplied with the device.

    http://www.everythingusb.com/forums/showthread.php?threadid=809
    Certainly is. Never see anything he posts unless someone quotes him.
     
    Mike Tomlinson, Apr 21, 2011
    #13
  14. Tom

    me Guest

    Your enclosure is bad as I had the same thing happen. Just buy a new
    enclosure or see if Rosewill will swap it out. A relative had the same
    problem and didn't know it and could have lost all data. I suggested he
    buy a new enclosure and it worked perfect and didn't lose a byte. Good
    Luck.



     
    me, Apr 22, 2011
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.