Delayed Write Failure on Promise Controller HD - P4PE

Discussion in 'Asus' started by kgf, Jul 24, 2004.

  1. kgf

    kgf Guest

    I've got an Asus P4PE that's been running fine for two years. Now all of a
    sudden I've got the dreaded "delayed write failure". Here's the specifics:

    WinXP Home
    P4PE running 1005 bios
    IDE 1: WD 120GB special edition - works fine as my C / Boot drive
    IDE2: DVD-RW and DVD-R drives
    OnBoard SATA: Running a WD 200GB special edition, using the Promise
    controller, as a Raid 1, Stripe 1+0 (i.e. running 1 IDE drive off the
    promise controller). This is my D-drive
    512MB RAM (1 PC2700 module)
    NVIDIA GeForce4 Ti 4200

    Everything was fine until I recently backed up some data from the C to D
    drive, and ended up filling up the 200GB drive up to maybe 80% of capacity.
    All of a sudden I'm now getting the delayed write failures on my 200GB
    drive. I cleaned the drive up (removed a bunch of video files), but still
    have the problem. I've got the latest Microsoft updates, using an 80pin
    cable, have the latest drivers to enable large hd support. Looks like there
    are millions of versions of this problem.

    My 200GB hard drive is my video capture drive, so I didn't want to make it a
    slave drive on the IDE controller. Is there a different setup I should
    consider between my two hard drives and DVD/DVD-RW drives that would help?
    I've also got a IDE controller card that came with the 200GB hard drive I
    guess I could try (probably a Promise card) whose intent was to support
    large hard drives.

    I can still access the data on the 200GB drive, but the write speed is super
    slow now.

    Thanks,
    Kevin
     
    kgf, Jul 24, 2004
    #1
    1. Advertisements

  2. kgf

    kgf Guest

    PS. I just upgraded to the latest ATAPI.SYS after this error occurred.
    Looks like I was using an older version when the problem first happened -
    one that maybe didn't support drives larger than 137GB?

    Would replaceing my 200GB IDE with an SATA drive accomplish anything???
     
    kgf, Jul 24, 2004
    #2
    1. Advertisements

  3. kgf

    Georg Guest

    Hi,
    I'm not a pro, but had a similar problem. Had the same "delayed write"
    error after I installed a new hard drive. Same error message came up.
    Thought it might still be a bad drive or the IDE connector so I got a
    Promice SATA card and 2 SATA drives. One worked fine, but the other one had
    the same error. Called Promice. Support walked me thru and switched the
    cables on the 2 SATA drives. The problem jumped to the other drive.
    Support said it might be a power supply problem, but mine was large enough.
    I then ran the computer with the case open and played with all of the cables
    to the drives and noticed that one drive "clicked when I jiggled the power
    connector to that drive. Replaced the power cable and have not had a
    problem since.
    Hope this helps.

    Georg
     
    Georg, Jul 24, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.