Dell Dimension 2400 USB Drive Problems

Discussion in 'Dell' started by jarettweber, Dec 27, 2007.

  1. jarettweber

    jarettweber Guest

    Ben, Stew and all the guys on here, your info has been greatly
    appreciated and I've learned a ton and solved many problems with your
    knowledge. Finally I have ran into something that I cannot seem to find
    a fix for. I was doing some work on a friend's business computer (runs
    Windows XP). They need to back up their Quickbooks and the files are
    too large for standard floppys now. So they went the USB thumb drive
    route instead. Thing is, the drive is not accessible. It shows up as a
    drive in my computer (f:), but no information can be written to the
    drive. Here is what I have done:

    I have tried 2 USB drives, both which work in my computer at home. A
    Sandisk Cruzer mini 1GB and a Verbatim Store N Go 8GB. Both drives have
    a test.txt file on them from my computer, just for testing purposes
    (getting data to and from). Both have the same problem as mentioned
    above when inserting into the work computer.

    I did research via google and the tech support forums and came to the
    conclusion that the 2400 has some serious USB issues with thumb drives.

    So I downloaded every update available to Windows XP, went to Dell's
    support site and did the same. I even tried some chipset updates that
    people suggested that were not part of the 2400 series. Still nothing,
    so...

    I went into the device manager. The drive shows up as a "generic
    storage volume" instead of the proper name (Sandisk Cruzer and Verbatim
    Store N Go) as they do on my home computer. I tried the whole uninstall
    device/reinstall device via the device manager. Still nothing, so...

    I went through all the USB components in the device manager and updated
    drivers and did the install/uninstall on all of them. Still nothing...

    Finally, I tried every other USB port on the computer (thinking it was
    a problem with the 2 front ports), but still get the same result. The
    computer currently has a mouse, printer and wireless interface connected
    to the USB ports in back, all which work flawlessly.

    I may end up trying a USB hub connected to one of the rear ports, but
    I'm afraid I'll get the same results.

    I'm sure I did some other basic tech support things, but can't remember
    them right now. So any suggestions, tips, flames, etc. would be greatly
    appreciated. Thanks for your time and keep up the good work.

    -Jarett
     
    jarettweber, Dec 27, 2007
    #1
    1. Advertisements

  2. jarettweber

    S.Lewis Guest

    Jarrett -

    1) I do wonder if this is a USB port/power overload issue. I've read (as
    have you) more than a few posts regarding the 2400. For testing purposes,
    it would be nice if a PS2 keyboard and mouse could be attached to see if
    there's any different response.

    2) I use generic thumb drives (no software required), so please pardon my
    ignorance; do either of the drives you're using require an accompanying
    software application/install? I've always had some predjudice against such
    software as the flash drive should just be a plug and go under Windows XP.

    3) I would also try formatting both drives (again) just to be sure there's
    no file system corruption going on here. Doubtful, but a possibility.


    I do keep a couple of pair of old PS2 externals here (to work on older
    Win98/Me machines) and if it were me, that'd be the first thing I'd try. You
    did well by checking the rear USB ports also, as they are integrated into
    the board versus the cable used to connect the front USB ports.

    Do post back.

    Stew
     
    S.Lewis, Dec 27, 2007
    #2
    1. Advertisements

  3. jarettweber

    jarettweber Guest

    Stew,
    Much appreciated on the feedback. The overload idea is a good one, and
    yes I do have some PS2 periphs (full of dust, I'm sure) that I could
    test your idea out with.

    I'm with you on the whole generic thumb drive. I deleted the U3 crap
    on my Cruzer and use it as a generic-type USB drive. But the Verbatim
    does have some V-something software on there. I think it's more for
    security (passwords for the drive and such). The Verbatim is not my
    drive, so I was reluctant to delete everything on there. They will
    probably be cool with me deleting it, so I will definitely give it a
    try.

    If all else fails, I will reformat the drives. But I'm thinking your
    overload idea may be the culprit.

    Would a non-bus powered/ AC adapter type USB hub possibly solve the
    problem? Rather than leave them with one of my archaic, grungy looking
    PS2 keyboards, I'm thinking they would bite the bullet and buy the hub.
    I have no experience with a AC powered hub, let alone any USB hub.

    I'll try out your ideas this weekend and let you know what I figure
    out. Thanks a ton for the help. It made my day to see your reply to
    this post.

    -Jarett
     
    jarettweber, Dec 28, 2007
    #3
  4. jarettweber

    S.Lewis Guest


    Jarett -

    I can see your point about the PS2, as it's no permanent or desirable
    solution (if it even works). So, yeah, I guess my next shot would be to try
    a *powered* USB hub (though I don't think I've ever bought one) and test it
    at your place and then set it up onsite and try it.

    It's kind of preposterous that you should have to go to this extreme, as the
    machine should just accept the flash drives. But a quick search and scan of
    the web does show this sort of behavior with various desktops of both OEM
    and home-built varieties. I didn't realize that jump drives could be so
    finicky.

    Heck, you might even grab a "super-generic" flash drive (memorex, etc with
    no U3 or encryption) and try it with the idea of eating it or giving it away
    also:
    http://www.buy.com/retail/product.asp?sku=202743330&adid=17654&dcaid=17653

    Be interested to see what you find. Best of luck.

    Stew
     
    S.Lewis, Dec 28, 2007
    #4
  5. Could this system be old enough to have USB 1.x ports? I don't know the
    date for the transition, but I seem to recall Dell being Johnny on the spot
    to move from 1.x to 2.x USB ports on their systems.

    Wouldn't think a thumb drive would draw much power, but I've never really
    checked the specs either.
     
    Kevin Childers, Dec 28, 2007
    #5
  6. jarettweber

    S.Lewis Guest

    It's 2.0:
    http://support.dell.com/support/edocs/systems/dim2400/en/sm_en/specs.htm
     
    S.Lewis, Dec 28, 2007
    #6
  7. jarettweber

    Ben Myers Guest

    The Intel 845 chipset is pretty much the start of USB 2.0. Older Intel 850
    chipsets were USB 1.1. The last 850 chipset is USB 2.0, which is why a
    Dimension 8250 is nicer to have than an 8200. All those ugly Socket 423 systems
    and any Pentium 3 systems are USB 1.1. It is all baked into the motherboard
    chipset.

    The Dimension 2400 is USB 2.0... Ben Myers
     
    Ben Myers, Dec 29, 2007
    #7
  8. jarettweber

    RnR Guest

    You know Ben, I've seen that question asked a lot and I've wondered
    too, how you could tell which USB version one had on a given pc or
    laptop. In my case it was usually 2.0 but that's only because I
    spec'd it out or read it in this newsgroup but without either, I
    wasn't sure ... even looking at the device manager. Perhaps there
    is another way to check like Belarc or further into the control
    panel ???? I wish it was something that stood out like saying USB 2.0
    or 1.1 in the device manager or such.
     
    RnR, Dec 29, 2007
    #8
  9. jarettweber

    Ben Myers Guest

    The only way to be even close to being sure is to read and memorize the chipset
    specs, then burn them.

    I never have used Belarc to any great extent, but it is possible that it
    tabulates enough information to tell the difference between USB 1.1 and USB 2.0.
    Windows 2000 or later sure knows, so the info is buried in the registry
    somewhere. Okay, you can also read and memorize the specs for the Windows
    registry and burn them. That'll get you the info you want... Ben Myers
     
    Ben Myers, Dec 29, 2007
    #9
  10. jarettweber

    S.Lewis Guest



    Pardon if I'm butting in, but if you go into device manager and see an entry
    for "USB enhanced controller", I believe that ("enhanced") is almost
    universally indicative that it's 2.0.

    I have not yet found this to be false, fwiw....
     
    S.Lewis, Dec 29, 2007
    #10
  11. jarettweber

    RnR Guest


    thanks Stew. I think you are correct (see my other post) !!
     
    RnR, Dec 29, 2007
    #11
  12. jarettweber

    Ben Myers Guest

    How silly of us all. Of course "USB enhanced controller" means USB 2.0, same
    as "Human Interface Device" means either keyboard or mouse. Darn, I still
    haven't learned the jargon! ... Ben Myers
     
    Ben Myers, Dec 29, 2007
    #12
  13. jarettweber

    S.Lewis Guest


    "you......will......be........assimilated." g

    "All your base are belong to us."

    heh
     
    S.Lewis, Dec 29, 2007
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.