Dell Inspiron E1505 will not boot after memory upgrade

Discussion in 'Dell' started by yasaswi, Jun 16, 2008.

  1. yasaswi

    yasaswi Guest

    Hi,

    I have a Dell Inspiron E1505 whose warranty expired a few months back.
    I decided to upgrade the memory in it and replaced the 512 MB RAM
    sticks in it with two 1 GB PC2 5300 sticks and now my laptop will not
    boot up! I took all the required precautions like grounding my hands
    before handling the RAM and laptop etc. I even tried replacing the
    older RAM sticks back into the laptop but even that does not seem to
    help either!

    Here are the symptoms that I notice: After I power on the laptop, all
    that happens is that I hear the fan run, the green LED behind the
    small "9" icon next to the power button stays solid green and the LEDs
    behind the "A" icon and the down arrow icon blink continuously for
    about 30 seconds or so and the laptop powers itself off.

    The only thing I can think of is that the RAM is not seated properly
    in its slot and the circuit is complete somehow. But I do not hear any
    beeps from the laptop. I checked the RAM twice and retried with the
    new RAM twice but nothing works! The outcome is the same no matter
    which configuration I use. I am kind of out ideas and feeling pretty
    helpless right now.

    I was wondering if anyone can possibly think of what might be wrong or
    what I can do to diagnose what is wrong with the laptop without having
    to pay someone or Dell a lot of money. Any help/advice will be greatly
    appreciated. Thank you very much in advance for your replies.

    Yash
     
    yasaswi, Jun 16, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.