Deskpro: can't boot from hd, or run setup from floppy; not newbie, have rtfm

Discussion in 'Compaq' started by gana1nm, Nov 27, 2006.

  1. gana1nm

    gana1nm Guest

    Posting to c.o.l.s because machine runs only Linux, to a.s.p.c because
    it's clearly a Compaq firmware issue, and to c.o.l.h because the
    firmware might
    as well be hardware, since I don't (yet) know how to change it.

    This problem is not for the faint of heart. I have read the manuals on
    the Compaq
    website, tried the obvious remedies (see below for gory details) and
    they haven't
    worked. My other Linux machines work just fine :)

    The Problem Machine is one of the Compaqs from about 1997/8 without a
    "real"
    BIOS. It's a compact desktop Pentium II 233Mhz 96MB 2.1GB+2.4GB.
    There is
    no obvious way to tell its exact model number, but at boot time the
    screen displays
    "Deskpro 4000", a category containing at least 20 models.

    When I installed Linux on this machine, it had its original HDs which
    had been used for Windows 9x. I deleted the Diagnostic/ Setup
    partition,
    not knowing any reason not to :), repartitioned and reformatted for
    Linux.
    There was no problem - Linux booted fine from the first HD or floppy or
    CD.
    When I wanted more HD space, I replaced the first HD (HD0, or /dev/hda)

    with a known good one containing a bootable Linux, and also replaced
    the
    second HD with a larger one. (The first HD is now a Maxtor 10GB, and
    the second a Western Digital 10GB. I mention the manufacturers because
    I have heard rumors of boot-time incompatibility of certain pairs of
    drives, but I have no definite info. 10GB is also , I think, greater
    than a magic number - 8.x GB? - in certain kinds of BIOS firmware.)
    There are no MSDOS or Windows partitions.

    Now the Compaq firmware won't boot from the HD ("1790 - Disk 0 error"),
    and it wants me to run the Compaq setup utility (at one point it
    displayed
    "If you are running Unix, you still need to use the Compaq utility to
    configure
    the hard disk").

    The new first HD is in fact present and functioning, because I can boot
    its active partition from a SmartBootManager floppy, or mount, read and
    write it when booted from a Linux CD. No problems with the second HD
    or the floppy drive either, once booted. So I didn't _obviously_ botch
    the
    hardware replacement, though there may still be something subtly wrong.
    The new first HD was the first HD of two on the same controller in its
    previous machine, and also in its current machine. I just left its
    jumpers
    as they were, though I have no key for how they should be.

    OK. I downloaded the self-extracting archive sp8126.exe (PC Diagnostic
    and Setup Utilities) from the Compaq website, verified it using unzip
    -vt
    on another Linux machine and ran it under dosemu (because I don't have
    an
    MS machine). The resulting 2 setup/diagnostic boot disks will happily
    boot to menus on this other machine, but on the Problem Machine, they
    each just give "Starting MS-DOS" followed by a hang. FWIW, soft reboot
    (shutdown -r now) also hangs (and always did) under Linux on the
    Problem Machine even if I've booted from a CD which remains in the
    drive.

    The floppy drive is OK, because I was able using the "other" machine to
    create two different bootable floppies (FreeDos and SmartBootManager)
    which successfully boot on the Problem Machine.

    I found an apparently similar case on the net where someone claimed
    that the problem could be solved (and the setup utilities could be run)
    by moving the floppy drive to "the other connector on the ribbon cable,
    the one without the twist". On the Problem Machine, there is no such
    other connector, and never has been, and if there were, it is not clear

    how it would help, because it would presumably move the floppy drive
    to the B: role (/dev/fd1), which is not supposed(?) to be bootable at
    all,
    whereas I can currently at least boot SmartBootManager or FreeDos
    from A: (/dev/fd0).

    I'm fairly indifferent about actually restoring the setup partition,
    since
    Compaq says the setup can be run from floppies, and I don't expect
    to need to run it often; but I would _really_ like to be able to boot
    the Problem Machine from its present HD.

    Any clues will be much appreciated.

    -D
     
    gana1nm, Nov 27, 2006
    #1
    1. Advertisements

  2. [Many possibly relevant details deleted.]

    Which boot loader are you using on the problem machine, LILO or GRUB?

    How do you have the partition(s) on the 1st hard drive laid out?

    What partitions do you have on the 2nd drive?

    What happens if you have only 1 of the 2 drives connected to the
    cables?

    What happens if you replace the 1st drive with the old 2.1GB drive?

    Is the 1790 error message from the BIOS?

    Are there "drive parameters" set in your BIOS?
     
    Chris F Clark, Nov 27, 2006
    #2
    1. Advertisements

  3. gana1nm

    Bill Marcum Guest

    ["Followup-To:" header set to comp.os.linux.hardware.]
    Have you tried a memtest86 floppy?
    On some machines it was possible to swap the A: and B: drives in the BIOS,
    so you could boot from either 3.5 or 5.25 inch floppies. If your machine
    never had a second floppy, it's unlikely that the drives would be swapped.
     
    Bill Marcum, Nov 28, 2006
    #3
  4. gana1nm

    gana1nm Guest

    On hda, Lilo; of course, when I boot a floppy or a cd, these use
    whatever they have on them.
    hda1: 20MB ext2 kernel images and boot maps; placed first in case the
    BIOS has the
    cylinder 1024 problem; ext2 so I can use kernels too small to
    have ext3 builtin.
    hda2: ~3GB ext3; active; Linux root
    hda3: ~128 MB Linux swap
    hda4: extended partition containing:
    hda5: ~3GB Linux data
    hda6: ~3.6GB Linux data

    This is off the top of my head; I'm not at home right now.
    Pretty similar. I like this sort of layout because you can just move
    it to the hda position in another machine and it's ready to go.
    These are last-resort questions I'll investigate if I can't find a
    software solution. The mechanical design of the machine is compact
    (read as "awkward and cramped"), and it has to be dissassembled like a
    sliding-block puzzle just to get at some of the disk connectors; to
    actually replace the disks is no fun at all.
    It's from the resident stub of the boot firmware. There's no ROM BIOS
    such as most pc clones have. That functionality lived on the
    manufacturer-provided 2MB partition on the original hda, which I
    overwrote :). The Compaq utility I downloaded claimed to provide
    equivalent functionality by either restoring the setup partition
    (destroying the existing partitioning in the process) or creating setup
    floppies.
    The "drive parameters" seem to be stored in NVRAM, but the user
    interface to change them isn't resident; at one point I got a message
    saying "drive 0 has changed - you must re-run setup". This is what I
    am now attempting to do. I got the machine second-hand, without
    manuals or software, and just used the configuration it came with.
     
    gana1nm, Nov 28, 2006
    #4
  5. I had Deskpro 2000's of a similar vintage that had an 8GB BIOS bug and refused
    to boot if a hard disk greater than that was installed. They also issued the
    1790 (or maybe some other 17xx) message.
     
    Trevor Hemsley, Nov 28, 2006
    #5
  6. Actually all floppy drives are jumpered as "B" or second drive by default.
    The twist in the end connector converts that "B" drive back to an "A."
    The middle jumper has no twist so the drive connected there already is
    detected as a "B" drive. This was done so that OEMs or users would not have
    to change jumpers. Some floppy drives have the jumper connections
    permanently soldered together.
     
    Earl F. Parrish, Nov 28, 2006
    #6
  7. The layout looks good. I do similar things myself (and also to the
    2nd drive so that the drives are "portable") just like you have done.
    I ask because of Trevor's reply. I've heard that was a common problem
    with machines of that vintage. I have a DELL from that time, that
    simply truncates the disk to 8GB if it is larger, but I never tried
    booting from the larger disks, just used them for 2nd "data" drives.
    My guess is that this software has specific functionality to enable
    "large" (e.g. 2 GB) disks. You may not be able to boot the machine
    (from the hard disk) unless that software is loaded, and thus it needs
    to be in the MBR of the hard disk. That is, of course, only a guess.
    Well, that sounds like a good thing to try.

    At this point, I think you know more about your problem and potential
    solutions than I can offer, so I'll just wish you the best of luck.

    Cheers,
    -Chris
     
    Chris F Clark, Nov 29, 2006
    #7
  8. BTW, it *does* have a BIOS and it *is* flashable. The bit that resides on that
    weird partition is the configuration utility for it, not the BIOS itself. From
    your description of it as a P-II, 233MHz I would guess that it's one of these
    models -
    http://h18007.www1.hp.com/support/files/Deskpro/us/family/8.html?lang=en&cc=us
    and probably the 6233X or 6233MMX since a 5233MMX is a Pentium I not a II. If
    you take the link from that page for the 6233X then you can choose MS-DOS as its
    o/s on the next page and the first thing listed is a flash BIOS for it - you
    want the 3rd link down which will create a boot diskette and flash your BIOS.
    You might need to unplug your big hard disk first since one of the issues listed
    as fixed is " Adds support for hard drives larger than 8 gigabytes.".
     
    Trevor Hemsley, Nov 29, 2006
    #8
  9. gana1nm

    gana1nm Guest

    Well yes; I was trying to be brief, and "real" seemed better than "of
    the kind we're familiar with from most other pc-clones".
    Ah! Thank you; I didn't know that. Maybe I needed a different setup
    utility, though sp8126.exe seemed to claim very general applicability.
    I spent a while at the Compaq site searching without success for a list
    of the attributes of the models so as to identify which one I had.
    Does anyone know what distinguishes the X from the MMX?
    Having lost some functionality by acting without all the necessary
    information (gasp!), and having had one possible fix inexplicably fail,
    I'm reluctant to do something irreversible which could destroy the
    remaining functionality if done less than perfectly. Remember, I don't
    have a real MSDOS (although I had one in 1997 that's probably still in
    my junk^H^H^H^Harchives), so thus far I've done all the DOS stuff in
    dosemu or FreeDos, which risks subtle incompatibilities. That said,
    thanks again, and I'll look into what's at the location you cited.

    (Does any one know if Compaq incorporate extensive sanity/applicability
    checks into their BIOS upgrade software, thus reducing the likelihood
    of User Error being catastrophic?)

    (Does anyone know a way to recover from a BIOS upgrade later determined
    to be bad, other than taking the PROM/NVRAM off the motherboard and
    using a special device to reprogram it?)
     
    gana1nm, Nov 30, 2006
    #9
  10. gana1nm

    gana1nm Guest

    The current hda is a Maxtor, jumpered as Master-with-slave-present; I
    know this is how it is jumpered because it booted properly in that
    configuration in its previous machine, but I don't know how to jumper
    it as Single-drive (jumper configs not shown on faceplate, don't have
    manual, though this info is probably _somewhere_ on the net, sigh).
    Various of my other reclaimed junk boxes have bioses which can't handle
    the size of disk now installed, but I just tell the bios the disk is
    smaller, and put my kernel image in the part the bios can see, and it
    doesn't check, and boots anyway; once Linux is running, it doesn't care
    what the bios thinks about the disk. With the Deskpro, the bios tries
    to check the disk size, and won't boot it if it sees a discrepancy.
     
    gana1nm, Nov 30, 2006
    #10
  11. That page for the 6233X lists SP16085.exe as does the page for the 6233MMX for
    the Personal Computer Diagnostics utility. The machines list a different BIOS
    though.

    I suspect that it's the 6233X as that has an 8GB bug and I'm pretty sure the
    model I dealt with hung during boot with a > 8GB drive in it. You may find the
    diagnostic diskette will boot if you unplug it first.
     
    Trevor Hemsley, Nov 30, 2006
    #11
  12. gana1nm

    gana1nm Guest

    SP16085.exe is said on that page to contain the Test+Diagnostics
    utility, but _not_ the Setup utility. As far as I can see, the Setup is
    essential and may be sufficient to fix my problem, but the
    Test+Diagnostics appears to be entirely optional; everything works if I
    boot from a CD, so there _probably_ isn't another hardware problem in
    the boot pathway (perform good-luck ritual of one's choice here :).
    Thanks, I'll try that.
     
    gana1nm, Dec 1, 2006
    #12
  13. gana1nm

    Ben Myers Guest

    More than a bug, the BIOS of most Pentium and Pentium MMX systems limits hard
    drive capacity to 8GB. Some BIOSes, but probably not Compaq's, allow a
    workaround for Linux and software "drive overlay" programs by selecting a "Type
    1" hard drive in the BIOS setup.

    The other alternative is simply to get an inexpensive IDE controller, e.g.
    Promise brand, to which the drives are attached instead of to the system board.

    .... Ben Myers
     
    Ben Myers, Dec 1, 2006
    #13
  14. gana1nm

    Alan Adams Guest

    In message <>
    The majority of Maxtor drives I have encountered don't distinguish
    between master and master with slave. The three options are master,
    slave, cable select.

    A google search of the model number and Jumper usually finds the
    information.
     
    Alan Adams, Dec 2, 2006
    #14
  15. gana1nm

    gana1nm Guest

    Yes! With the 10GB drive unplugged, I was finally able to boot the
    Compaq Diagnostic floppy, determine the ROM family, get the correct
    ROMPaq, and flash the new BIOS.

    Many thanks, Trevor, for the clue that made this possible. It is so
    counter-intuitive that I wouldn't have thought to try it :-(

    For the benefit of anyone else with this problem, I should mention that
    there were definite difficulties writing the ROMPaq boot disk under
    dosemu (using the current version);
    it repeatedly claimed that there was disk failure with the A: drive,
    even though before, during and after these attempts, it was possible
    without problems to mount, read and unmount MSDOS-formatted disks in
    the same physical drive under Linux. Of course, I didn't try to use
    the drive under Linux while the ROMPaq extractor was active under
    dosemu.

    After many tries, the ROMPaq boot disk finally got written; I have no
    clue what made the successful attempt different. I saw the same
    behavior earlier when preparing the Diagnostics and Setup floppies
    under dosemu.

    Plugged the 10GB drive back in, ran Setup, and it is correctly
    recognized. Still won't boot, though it booted in its previous machine
    and I don't think I've done anything that would change the boot data on
    the disk. I ran the Diagnostics, and they found no problems with the
    disk, controller, cables or anything.

    I have a few more things to try; I just ran out of time last weekend
    getting this far.

    Thanks again, Trevor (and Chris, and others).
     
    gana1nm, Dec 4, 2006
    #15
  16. gana1nm

    gana1nm Guest

    In case it helps someone, here is an account of what it took to get the
    Deskpro booting Linux again from its new hard disk. I didn't always
    find out the exact nature or cause of the incompatibilities, but I did
    get round them. This may not be the shortest or most logical sequence,
    but it's what I did and it worked. You need to understand what these
    commands do; don't just follow them blindly.

    1) Flash the latest BIOS, so that disks larger than 8GB are recognised.
    In my case, this required extracting the RAMPaq boot floppy under
    dosemu, and disconnecting the large hard disk, which allowed the Compaq
    boot floppies to actually boot. Then reconnect the hard disk; the BIOS
    now recognizes its size correctly.

    2) Run Setup from the Compaq boot floppies. It's unclear what this
    actually achieves, since the large drive is already correctly
    recognized, but Compaq says you've got to do it.

    3) (Actually I did this earlier, but that doesn't matter.) Boot Linux
    (I did this from a CD) and back up the important parts of hda onto
    something else. I backed up the /boot and / partitions separately onto
    a partition of hdb; I ended up not needing the backup of /, but it was
    reassuring to have it available. Run fdisk -l /dev/hda and save the
    output.

    4) [Optional] If you don't currently have a Compaq Diagnostics
    partition, create one. This can be tricky and hazardous. The Compaq
    utilities will not let you create the partition if the beginning of the
    disk is already part of a partition.

    [In my case, there was an additional complication: hda had a "protected
    data area" at the end. This caused cfdisk to refuse to run at all
    ("partition ends after end of disk"), so I used fdisk; this is not
    problem-free, as it can produce layouts which require special treatment
    from Lilo; see below. Andries Brouwer has a utility "setmax" which
    claims to, in effect, remove the protected data area, but I found that
    it doesn't remove it completely enough; it's safer just to keep your
    own partitions clear of the protected area.]

    What I did was to boot Linux, delete all the partitions of hda, create
    a Compaq Diagnostics
    partition, type 0x12, as hda1, then create hda2 to occupy the remainder
    of the old hda1; then recreate the remaining old partitions on the same
    boundaries that they formerly had, though they will now have different
    numbers. If you previously had four or more partitions, you will need
    to move one of the primaries into an extended partition, but you can
    still use the same cylinder boundaries. If you get it right (be
    paranoid), you will find all your filesystems and data in hda3 and
    higher numbers preserved after you reboot.

    One further paradox: the Compaq utilities don't recognize a new (empty)
    Compaq partition created under Linux, so after reserving the space for
    it, you have to delete it, write the partition table, boot the Compaq
    Diagnostics floppy, and let _that_ create the Diagnostics Partition and
    populate it from the floppies.

    Then reboot, check that pressing F10 brings up the Diagnostics from the
    hard disk; exit; boot Linux from CD; restore the former contents of
    hda1 to the current hda2; verify using e2fsck that the filesystems are
    still intact in hda3 and higher; edit the fstab of the / partition to
    reflect the new partition numbers.

    5) Under Linux, run lilo -M mbr /dev/hda to install a master boot
    loader; I have no idea what happened to the one previously there; maybe
    the Compaq utilities overwrote it (?); modify /etc/lilo.conf to reflect
    the new partition numbers, and run lilo -t -v2; if it complains about
    the partition table - it did in my case, something about
    incompatibility between the CHS and LBA data - then run lilo -P ignore,
    to tell it to ignore the partition table; else just run lilo. After the
    kernel gets control, it uses the partition table without having the
    trouble that lilo had.

    Good luck. This took me about 3 hours of trial and error and manpage
    reading _after_ I got the BIOS flashed.
     
    gana1nm, Dec 5, 2006
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.