disabling Promise RAID controller on A7V333

Discussion in 'Asus' started by Dale I. Green, Jul 24, 2003.

  1. Hi.

    I have the Asus A7V333 motherboard with the on-board Promise PDC20276 RAID
    controller (BIOS Rev. MBFastTrak133 "Lite" BIOS v 2.00.1.23). However, I
    have no drives connected to this controller and would like to disable it in
    order to eliminate the long "Scanning IDE drives..." portion of the boot
    process.

    I've read the manual and searched this newsgroup and understand there is a
    jumper labeled RAID_EN which should allow me to disable the controller.
    However, I tried this and it did NOT eliminated the "Scanning IDE
    drives..." from the boot. I've also checked the BIOS setup, but could find
    nothing to help.

    So, can anyone tell me whether disabling the Promise controller via the
    RAID_EN jumper is supposed to eliminate "Scanning IDE drives..."? If not,
    then is there any way to eliminate it? Might a system BIOS update help (I
    have Rev. 1006)?

    All suggestions and/or advice greatly appreciated!
     
    Dale I. Green, Jul 24, 2003
    #1
    1. Advertisements

  2. Dale I. Green

    Egil Solberg Guest

    On page 87 in your manual it says something about a BIOS setting: "Load
    onboard ATA BIOS". Can you find that one and disable it within BIOS?
    Could not find it on BIOS screenshots by reading the online manual, though,
    but those manuals are seldom 100% accurate.
     
    Egil Solberg, Jul 24, 2003
    #2
    1. Advertisements

  3. Thanks, but I tried that, and it actually disabled the main IDE channels,
    thus preventing the machine from booting.
     
    Dale I. Green, Jul 24, 2003
    #3
  4. Dale I. Green

    Egil Solberg Guest

    http://www.anycities.com/user/mainboards/asus/asus.html

    Here there are listed modified BIOSes for the A7V333. Take a look at those
    listed as "UDMA fastboot". If the IDE scanning at startup annoys you so
    much, you could consider trying one of those 2 BIOSes listed.
     
    Egil Solberg, Jul 24, 2003
    #4
  5. Dale I. Green

    Paul Guest

    Egil,
    Why would the original poster want to flash to a hacked BIOS? Dale indicated
    that he does not have anything connected on the RAID ports so why even bother
    with anything pertaining to the RAID controller/drivers?

    Dale,
    Are you 100% certain what you are seeing is the RAID controller scanning for IDE
    drives? I am sure you know that the standard IDE controllers can "scan" for
    drives with each boot cycle as well. If you are in fact seeing the RAID
    controller doing it's scan, then you have not got the RAID_EN jumper in the
    disabled position. My board has it disabled and I have not seen the RAID
    controller even once try to do it's scan since I moved the jumper.

    Paul
     
    Paul, Jul 25, 2003
    #5
  6. Dale I. Green

    Paul Guest

    But if he has truly disabled the RAID controller, as he wishes to do so, then
    there is no "scanning" performed by the RAID controller. It would then be a
    waste of time to flash to the hacked BIOS.
     
    Paul, Jul 25, 2003
    #6
  7. Dale I. Green

    Egil Solberg Guest

    That seems very logical, yes. Of course he could be confused with the
    scanning of IDE-devices by the standard IDE-controller.
    I haven´t tested the board in question (just the plain A7V333), so I cannot
    tell exactly what happens when the controller is disabled with jumper.
    I don´t consider flashing with this special BIOS too risky, but if it was my
    board, I would just have put up with the "scanning IDE devices"-message. I
    would not have flashed. Just mentioned it to show the possibility.
     
    Egil Solberg, Jul 25, 2003
    #7
  8. Dale I. Green

    Paul Guest

    I do have the board and got tired of the delay inflicted by the RAID controller
    scanning each time it is booted. I disabled via the RAID_EN jumper and it never
    announced itself again. Also, I am still using the standard BIOS.

    The only time I would even consider going to the hacked BIOS is if I needed to:
    a) put a ATAPI device onto one of those ports or b) I wanted to use a couple of
    HDD's on this controller and did not want to by annoyed by the insistent
    scanning of the "Lite" version of the standard BIOS.
     
    Paul, Jul 25, 2003
    #8
  9. Hi All

    For the record, I'm using the "Lumberjack Full hacked" 1016 BIOS on my
    A7V333-Raid.

    Regards the boot delay, on this BIOS the RAID boot delay is the same
    duration as the Lite one so if thats all you want you'll be disappointed!

    To skip the Boot delay on both the Lite & full versions just press DEL on
    the numeric pad.

    If after disabling the RAID controller and you find it's still functioning
    ensure you have a good jumper to start with.
    sounds silly but it's not uncommon for the jumpers to have the contacts
    missing.... know this from experience.

    If that fails I would guess you have a faulty Mobo.....
     
    Baron Von Black, Jul 25, 2003
    #9
  10. Dale I. Green

    Paul Guest

    -- snip --
    Response inline...
    Thanks for that insight. I have been led to believe the hacked version bypasses
    the delay...it is good to know this fact.
    Yes, I myself have had problems with jumpers being bad. The odd thing about it,
    the only jumpers that have been bad are the ones which came with my Asus mobo's.
    No other product that I have worked on has had bad jumpers--just the Asus
    mobo's.



    Paul

    -- snip --
     
    Paul, Jul 25, 2003
    #10
  11. Dale I. Green

    tomcas Guest

    The "Pure UDMA" version of the Lumberjacker hacked bios (and driver) for
    the A7V333 promise controller is supposed to scan quicker that the
    promise lite version or at least it was claimed so in earlier releases
    (I'm using 1.008). The "UDMA Fast Boot" version of Lumberjacker is
    suppose to skip the scan of the promise controller altogether which is
    why you can't boot from a CD drive that's connected to it.
     
    tomcas, Jul 25, 2003
    #11
  12. Hi all.

    Sorry for the delay in posting back... ISP problems.

    Anyways, for no apparent reason, the RAID contoller scanning has magically
    stopped!

    I cannot explain it. To my knowledge, I have not done anything to cause
    it. I certainly have not done anything inside the case or with the BIOS
    setup since I started this thread.

    It's as if it just took awhile for the disabled RAID_EN jumper to be
    recognized.

    The only explanations I can think of are:

    1) the jumper shunt/contacts are flakey

    2) due to (1), the system had to heat-up enough before good
    connections were made

    3) bugs in the RAID BIOS

    Basically, though, I have no idea what happened.

    In any case, this issue is closed. The POST test has been reduced from
    about 20 seconds down to about 3 seconds!

    Thanks to all who have responded. All of the information was (is) useful.
     
    Dale I. Green, Jul 27, 2003
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.