1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Disappointing upgrade: Sempron 2200+ --> Phenom II 4X 840

Discussion in 'AMD Overclocking' started by DK, Jan 5, 2012.

  1. DK

    Paul Guest

    I was looking for something with graphs, but you're right,
    memtest86+ will give the answer. I was thinking maybe the
    shape of the graph would be important. I'm not sure whether
    memtest86+ determines the numbers by actually disabling cache levels,
    or uses an inflection point method.

    Maybe my results would have looked better if I had the graph in
    linear mode rather than log. That could have been why it
    didn't look too good.

    http://fileshosts.com/intel/Asus/P5....5-2.4-1.4-1.55-1.2/sandraxi/cache_mem_tn.png

    Paul
     
    Paul, Jan 6, 2012
    #21
    1. Advertisements

  2. DK

    Rodney Pont Guest

    Being colour blind I prefer the AIDA 64 benchmarks:

    http://www.aida64.com/product/aida64-extreme-edition/overview

    The blue section at the left shows the performance, the faster it is
    the longer the blue section.
     
    Rodney Pont, Jan 6, 2012
    #22
    1. Advertisements

  3. DK

    Darklight Guest

    you should have looked at cpu passmark

    cpu passmark
    for $109.95 £85.52 JBO solutions phenom x4 840 3.2 ghz rank 190
    for $109.99 £96.99 Ebuyer phenom x4 960T 3.0 ghz rank 160
    for $109.99 £83.99 overclockers uk amd FX-4100 x4 3.6 ghz rank 141

    Phenoms AM3
    FX AM3+

    second question whats your PSU
     
    Darklight, Jan 6, 2012
    #23
  4. DK

    Darklight Guest

    for £60 to £65 Athlon x4 640 AM3 rank 193 cpu Passmark
     
    Darklight, Jan 6, 2012
    #24
  5. DK

    Krypsis Guest

    I used to have a Sempron 2800+. It was a dog! Just about anything would
    run rings around it. I gave the whole computer away a year or two back
    after having it in storage. It is still in use today. Did put a braver
    video card in it for the new owner though.
    I upgraded to a @6600 Quad in a Gigabyte G33M-DS2R motherboard with an
    NVidia 8500GS video card (now Nvidia GeForce GT430) and 2 Gig of RAM
    (now 8 Gig). It was way overkill for what I do these days.

    For my day to day stuff, I use a Pentium 4 HT @ 3 GHz with 4 GB of RAM
    and that seems to cope more than adequately with my workload. The
    Quadcore rarely even gets turned on
    On board graphics are always a bit of a dog though there have been some
    significant improvements in recent years. I will always favour external
    graphics adaptors even if, in my usage, it only provides for snappy
    screen updates.
    I have found that what I need to be done fast is handled adequately by
    my P4. For the rest, I have plenty of time so I can afford to wait. I
    could overclock my Quadcore and get an even greater speed boost. In
    fact, that was one of the reasons I picked this particular CPU as it has
    loads of headroom but, apart from some experiments when new, it has
    always run at a standard clock speed.

    If I was into some serious gaming, I daresay the Quadcore would be more
    useful.
     
    Krypsis, Jan 6, 2012
    #25
  6. DK

    DK Guest

    What version of 7Zip do you have? The old 4.6 beta only
    uses 33% of the 4 cores and they are definitely not sybchronized.
     
    DK, Jan 6, 2012
    #26
  7. DK

    DK Guest

    I thought that AM3 offers more choices of inexpansive mobos and CPUs.
    Also, I got the 840 for $86. I like keeping things frugal.
    Nexus Value 430. I bought it for its inaudible fan. Has been rock solid in
    the previous setup and all voltages in the current are as expected and
    stable.

    Dima
     
    DK, Jan 6, 2012
    #27
  8. DK

    SC Tom Guest

    4.65. It doesn't say Beta, so I assume it's the standard released version. Which reminded me to check for an update.
    I'll let you know how 9.20 goes once I install and test with it.
     
    SC Tom, Jan 6, 2012
    #28
  9. DK

    DK Guest

    Even more weird. 4.65 is what I had before and it was definitely not
    using all cores. I now tried 9.2 and in it I can at least see options that
    Paul said he had in 4.60. In the 9.2m it has "Number of CPU threads"
    but bor some reason only 1 and 2 shows in the pulldown list. The CPU
    utiization with 2 threads is 40% and consequently the compression
    rate is a little faster but nowhere near yours. And we have identical
    MB and RAM, same OS (XP SP3, right?) and very similar albeit
    not identical CPU.
     
    DK, Jan 7, 2012
    #29
  10. DK

    SC Tom Guest

    I installed 9.20 and ran the benchmark on it. Pretty much the same as before- 8.7MB/s and all 4 cores synchronized
    within 3 or 4% of each other. It would start at ~60%, then ramp up to 100% and stay there until the next pass. Memory
    used was 851MB (forgot to mention that on the last reply).

    I ran the 1GB "create a 7z file" as in one of the other sub-threads. Mine took 3 min. 35 sec. to complete, with the 4
    cores fairly balanced from 48-53%. Towards the end of the compression, core number 1 (I think) dropped off to about 10%.
    But that may have been because OE6 was checking for new mail. The other cores picked up the slack, increasing usage by
    about 7-8%.

    I did mistakenly start creating a .zip file instead of a .7z one and it took considerably longer, even though it still
    used all 4 cores, fairly balanced across them all. I quit it after 6 or 7 minutes with it being about 50% done. Don't
    know why there would be such a disparity in time, unless 7ZIP doesn't create WinZip files that well. Is that possibly
    what you did that took 18.5 minutes?
     
    SC Tom, Jan 7, 2012
    #30
  11. DK

    SC Tom Guest

    Yep, I'm running XP Home SP3. The only "tweaking" I've done to my system is unlocking the other two cores (like I posted
    earlier), and changing my RAM timing from 9-9-9-25-34 to 8-8-8-21-31, but I don't see where that would make as much
    difference as there seems to be between our two systems. The only other real differences I see are that I'm running an
    add-in video card (GT 240) and SATA HDD instead of PATA. Do you have the latest BIOS and other drivers from the ASUS
    site?

    Here's a greatly snipped text report from CPU-Z for comparison, if you want:

    CPU-Z version 1.58

    Processors
    -------------------------------------------------------------------------
    Number of processors 1
    Number of threads 4

    Processors Information
    -------------------------------------------------------------------------

    Processor 1 ID = 0
    Number of cores 4 (max 4)
    Number of threads 4 (max 4)
    Name AMD Phenom II X4
    Codename Deneb
    Specification AMD Phenom(tm) II X4 B55 Processor
    Package Socket AM3 (938)
    CPUID F.4.3
    Extended CPUID 10.4
    Brand ID 29
    Core Stepping RB-C3
    Technology 45 nm
    TDP Limit 160 Watts
    Core Speed 3215.1 MHz
    Multiplier x FSB 16.0 x 200.9 MHz
    HT Link speed 1004.7 MHz
    Instructions sets MMX (+), 3DNow! (+), SSE, SSE2, SSE3, SSE4A, x86-64, AMD-V
    L1 Data cache 4 x 64 KBytes, 2-way set associative, 64-byte line size
    L1 Instruction cache 4 x 64 KBytes, 2-way set associative, 64-byte line size
    L2 cache 4 x 512 KBytes, 16-way set associative, 64-byte line size
    L3 cache 6 MBytes, 48-way set associative, 64-byte line size

    Chipset
    -------------------------------------------------------------------------
    Northbridge NVIDIA GeForce 7025 rev. A3
    Southbridge NVIDIA nForce 630a rev. A2
    Graphic Interface PCI-Express
    PCI-E Link Width x16
    PCI-E Max Link Width x16
    Memory Type DDR3
    Memory Size 4096 MBytes
    Channels Dual, (Unganged)
    Memory Frequency 669.8 MHz (3:10)
    CAS# latency (CL) 8.0
    RAS# to CAS# delay (tRCD) 8
    RAS# Precharge (tRP) 8
    Cycle Time (tRAS) 21
    Bank Cycle Time (tRC) 31
    Command Rate (CR) 1T
    Uncore Frequency 2009.4 MHz

    Memory SPD
    -------------------------------------------------------------------------
    DIMM # 1
    SMBus address 0x50
    Memory type DDR3
    Module format UDIMM
    Manufacturer (ID) G.Skill (7F7F7F7FCD000000)
    Size 2048 MBytes
    Max bandwidth PC3-10700 (667 MHz)
    Part number F3-10666CL9-2GBXL
    Number of banks 8
    Nominal Voltage 1.50 Volts
    EPP no
    XMP no
    JEDEC timings table CL-tRCD-tRP-tRAS-tRC @ frequency
    JEDEC #1 6.0-6-6-17-23 @ 457 MHz
    JEDEC #2 7.0-7-7-20-27 @ 533 MHz
    JEDEC #3 8.0-8-8-22-31 @ 609 MHz
    JEDEC #4 9.0-9-9-25-34 @ 685 MHz

    DIMM # 2
    SMBus address 0x51
    Memory type DDR3
    Module format UDIMM
    Manufacturer (ID) G.Skill (7F7F7F7FCD000000)
    Size 2048 MBytes
    Max bandwidth PC3-10700 (667 MHz)
    Part number F3-10666CL9-2GBXL
    Number of banks 8
    Nominal Voltage 1.50 Volts
    EPP no
    XMP no
    JEDEC timings table CL-tRCD-tRP-tRAS-tRC @ frequency
    JEDEC #1 6.0-6-6-17-23 @ 457 MHz
    JEDEC #2 7.0-7-7-20-27 @ 533 MHz
    JEDEC #3 8.0-8-8-22-31 @ 609 MHz
    JEDEC #4 9.0-9-9-25-34 @ 685 MHz


    Display Adapters
    -------------------------------------------------------------------------
    Display adapter 0
    Name NVIDIA GeForce GT 240
    Revision A2
    Codename GT215
    Technology 40 nm
    Memory size 512 MB
    PCI device bus 2 (0x2), device 0 (0x0), function 0 (0x0)
    Vendor ID 0x10DE (0x1043)
    Model ID 0x0CA3 (0x8328)
    Performance Level Default
    Core clock 135.0 MHz
    Shader clock 270.0 MHz
    Memory clock 135.0 MHz
    Performance Level 2D Desktop
    Core clock 405.0 MHz
    Shader clock 810.0 MHz
    Memory clock 324.0 MHz
    Performance Level 3D Applications
    Core clock 550.0 MHz
    Shader clock 1340.0 MHz
    Memory clock 1700.0 MHz
     
    SC Tom, Jan 7, 2012
    #31
  12. DK

    Paul Guest

    Just out of curiosity, have you looked at your BIOS screen recently ?

    First, you should have "full screen logo" disabled, in case the
    motherboard presents an image instead of text. (A couple of my
    motherboards default to presenting the full screen logo, so this
    has to be disabled.)

    Next, I'd want to check the BIOS declaration of the processor identity.
    Is the processor mis-identified, or is the model information and
    frequency right ?

    Either 7ZIP is only offering "1" and "2" as options, because the program
    can only handle two threads of execution. (Some algorithms can't be
    "divide and conquer" indefinitely.) Or, the program might be offering
    those options, because it thinks the processor only has two cores.
    And it might get that information from the operating system.
    I understand as well, from watching Linux boot screens (dmesg), that
    the BIOS passes information about the number of cores in some kind
    of table. So it might be possible for the BIOS to mis-inform the OS.
    This wouldn't be a problem, if the OS also had its own identification
    procedures. So it's a matter of whether the OS places all its trust in BIOS
    tables, or whether it also does some of its own detection.

    For example, when I boot Linux in a virtual machine on my PC, Linux
    complains that the BIOS table "reports one core" which is correct,
    but "the core number is 1 instead of 0", implying the virtual BIOS
    isn't passing "core0" as the identity of the virtual processor. That's
    how I know that at least with Linux, Linux is inspecting some info
    from a BIOS table, and in that case, did not like what it saw. Linux
    didn't crash or anything, and the message was more of a warning than
    an error. It didn't actually affect the operation of the OS.

    Paul
     
    Paul, Jan 7, 2012
    #32
  13. DK

    DK Guest

    Sure. More than I initially planned to, in fact :(
    Hate this and disable right away.
    All seems to be perfectly correct.
    Specificaly, this is how it looks:

    Number of CPU threads: [pulldown list] /4

    In the pulldown, the only choice is 1 or 2, so I take it that 7ZFM,
    like all other programs and OS, sees 4 cores but for some reason
    offers to use only two.

    Various programs happily see four cores here. Prime95 benchmarks
    are very much along the line of what's listed in, say, Wikipedia, and
    Passmark CPU scores, according to its "PerformanceTest" suit, are
    nothing out of the ordinary among the tested systems with the same
    CPU and OS (3236 in my case with a range of ~3100-3300 for XP
    and ~3700-4000 for Win7). My Passmark RAM scores are also not
    hugely out of the line among those with 4 Gb.

    As suggested at some point in one of the ASUS forums, I'm tried
    running the CPU with VCORE = 1.235 V (over 0.1V below default). Also
    disabled C'n'Q. None made any noticeable difference so far. The system
    is stable, with Prime95 running on all 4 cores continuously. (Before
    you think of it: I do close it before running any performance tests :))

    Haven't fooled around with RAM settings yet because in BIOS they
    look different from what I am used to and 3/4 of options I don't even
    recognize.

    Dima
     
    DK, Jan 7, 2012
    #33
  14. DK

    DK Guest

    Now THAT I find incredibly perplexing! We have very similar setups
    and yet not only the test results vary widely but also a particular program
    runs on them in the most utterly different ways. Crazy.
    No, I've done this test many times now with three different versions
    and in all cases it was the 7z.

    I will restore pristine XP SP2 image over weekend to see if it's
    the OS issue in some way, shape or form. My CPUZ report is
    expectedly very similar to yours save for the type of CPU and
    video (I really will have to buy something; the intergated one
    here totally blows - it work about as well as Radeon 7500 ten
    years ago).

    Dima
     
    DK, Jan 7, 2012
    #34
  15. DK

    Darklight Guest

    here read this:

    http://www.techpowerup.com/reviews/AMD/Phenom_II_X4_840/
     
    Darklight, Jan 7, 2012
    #35
  16. DK

    Yousuf Khan Guest

    You were indeed lucky to be able to unlock not just one, but two whole
    cores on your X2. I had a Phenom X3 prior to this one (X6), and when I
    used the Asus unlocker to get just a single additional core, it locked
    up. It was indeed a bad core and not just a core locked out for
    marketing purposes, it could not be unlocked.
    When you use the Core Unlocker (i.e. Unleashed mode) it's been suggested
    that you should not use CnQ in combination of Unleashing. You should
    also disable Turbo Core (if available on your processor), and C1E
    support, while unleashed.

    Yousuf Khan
     
    Yousuf Khan, Jan 12, 2012
    #36
  17. DK

    Yousuf Khan Guest

    <snip>

    Slightly on a tangent, I've been disappointed with all of my CPU
    upgrades after my first one. My first processor was an 8088-10MHz on a
    PC-XT clone. My first processor upgrade went from that, straight to a
    386DX-25MHz! It felt like I just strapped a rocket to my machine --
    everything felt faster, even the typing! Every other processor upgrade
    since then has felt somewhat unworthwhile. I never noticed the
    performance in day-to-day work.

    Even though my current processor is probably literally at least a 1000
    times faster than that first processor, they all seem to just barely be
    noticeable from the previous processors, in my opinion. And I'm not one
    to upgrade every year either, I usually wait about 3 years between
    processor upgrades. So 386/25 was still the biggest kick in the pants
    ever, even after all of this time.

    Yousuf Khan
     
    Yousuf Khan, Jan 12, 2012
    #37
  18. DK

    SC Tom Guest

    As it turns out, I'm not running the software, but it is enabled in BIOS. Seems to work just fine that way. I don't have
    Turbo mode enabled- I figure it's not going to give me that much of a boost for what I run anyway.

    I haven't seen too many failures on the Phenom II x2 CPU's. I believe there were more instances of non-working extra
    cores on the x4's. If I have a problem with any of them, I can always turn one or two cores off. Until that time, I'll
    enjoy what I have. I'm glad I upgraded my PSU a while back since the 4 cores double the power requirement.
     
    SC Tom, Jan 12, 2012
    #38
  19. DK

    geoff Guest

    In 1985, I had an IBM XT and used it to run an assembler for Motorola 6809
    code. It took about 20 minutes to complete. A few years later, my company
    bought us Compaq Deskpro 40 machines. BIGGGGGGGGG DIFFERENCE! The
    assembler took about 30 seconds.

    However, I've never experienced that kind of upgrade joy since.

    --g
     
    geoff, Jan 12, 2012
    #39
  20. DK

    Yousuf Khan Guest

    Yeah, I know what you mean, things were going so fast, you almost felt
    that maybe it didn't work right or something. These days, you might see
    something go from 30 seconds down to 15 seconds, it'll feel like a nice
    boost for a little while, but after two days you'll already be used to it.

    I think it took me months to get over how much faster the new system was
    over the older one.

    Yousuf Khan
     
    Yousuf Khan, Jan 18, 2012
    #40
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.