1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

DiskOnChip 2000 problems

Discussion in 'Embedded' started by msg, Oct 11, 2007.

  1. msg

    msg Guest

    Greetings:

    Some DiskOnChip architectural and installation questions:

    I purchased a DoC2000 96MB high-profile DIP from a third
    party; it is installed in a PC-104 Aaeon SSD-2000 module.
    The Aaeon board has very little documentation and
    what there is seems to differ from reality, for example
    selecting DoC #1's 8k address window as D000 using the DIP
    switch results in data appearing at D200 and it seems
    that after power-on-reset, the user must write to
    the board's I/O base register to select one of 16 64k
    windows (used with SRAM, but seemingly necessary for DoC
    also) or invalid data appears in the 8k window. Using
    msdos 'debug', one can write 'FF' to the I/O base register
    and a valid '55 AA' signature appears at 'D200:0'. If
    one reboots the CPU at this point, the BIOS scan finds
    the 'ROM' code but hangs since it isn't a legitimate boot
    loader from my inspection of the disassembly.

    Inspection of the entire 8k window confirms a working
    DoC device according to the M-Systems specs; there is
    a repeating 64 byte (1st half) boot record for the first
    2k followed by a repeating 64 byte (2nd half) boot record
    for the next 2k followed by all zeros for the next 4k
    assuming the device is in 'reset mode'.

    Running 'dinfo.exe' against this system (when '55 AA'
    is readable at the start of the window) shows 'no
    DiskOnChip devices found'. Note that there are no
    identification strings of any kind in the boot (IPL)
    records on this device.

    Running 'dformat.exe' against this system produces
    the same error message.

    What conditions are necessary for the utilities to
    recognize a valid DoC device?

    How can one replace the IPL code when the device is not
    recognized by the utilities? Writing to the IPL area
    is discussed in the DoC SDK API documentation for low-level
    services; I don't have the SDK, (would like to find it) and
    hope that sinking time into custom development isn't necessary
    just to reprogram a device.

    I would appreciate replies from anyone with DoC experience;
    surely this must have happened to other folks.

    TIA,

    Michael
     
    msg, Oct 11, 2007
    #1
    1. Advertisements

  2. msg

    msg Guest

    msg wrote:

    The DiskOnChip module itself is working; I installed it on
    an ISA SMC8000 Ethernet NIC in the bootrom socket which I
    modified to connect pin 31 to B11 of the ISA connector.
    I was able to fdisk, format, install a system and boot
    from the device.

    In 'debug', I cannot see any difference between the PC-104
    SSD-2000 installation and this kludged one when inspecting
    the memory window data; I suppose the next step would be
    attaching a logic analyzer to the bus but before doing this
    can anyone relate any experiences in dealing with Aaeon
    components or communicating with the company? Support
    for this product is absent from their website and the
    product name and board silkscreen codes produce no hits
    in their search engine.

    Regards,

    Michael
     
    msg, Oct 12, 2007
    #2
    1. Advertisements

  3. msg

    Jim Stewart Guest

    The only thing I can add is that that you
    must be able to write to the DOC before
    it will boot. Is it possible that the
    Aaeon board is write-protecting that socket?
     
    Jim Stewart, Oct 12, 2007
    #3
  4. msg

    msg Guest

    Jim Stewart wrote:

    In Re: Doc 2000 not working on Aaeon SSD-2000
    The Aaeon documentation says to write any value to the base i/o
    addr+1 of the board, which I have done, to unprotect it ; there are
    also DIP switches to unprotect various windows which I have tried.

    Since I have a working kludge (on the ISA NIC); I can scope pin 31
    (/WR) on the DoC during boot as a reference (and look at it on
    the Aaeon for comparison). I suppose in a pinch could reroute
    that pin directly to /SMEMW (B11) on the bus but why have the
    Aaeon board then at all?

    I am beginning to suspect that this board was OEM for some
    special application if in fact it is not defective and its
    behavior is intentional.

    Thanks for the tip,

    Michael
     
    msg, Oct 12, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.