Disks/disk images don't eject on first try

Discussion in 'Apple' started by Daniel E. Sabath, Dec 20, 2004.

  1. I was wondering whether anyone else has had these symptoms. For both
    removable media and mounted disk images, when I go to eject the disk or
    disk image, I usually first get a message saying the disk is in use, and
    then on the second try it ejects fine. This happens on all my computers.
    It's not a horrible problem, just slightly annoying.

    Anyone else seeing this? Ideas?

    Thanks,

    Dan
     
    Daniel E. Sabath, Dec 20, 2004
    #1
    1. Advertisements

  2. We had a similar but more annoying incident a few days ago: the CD had
    been used in iPhoto, I think, but all applications had been closed and
    still the system insisted that the CD was in use and could not be
    ejected. So I was dragged out of bed to do something about it.

    Disk was shown in Finder side panel, but Finder would not eject it.
    There was no application to close. The command that worked in the end
    was diskutil unmount force /Volumes/Whatever. Then the eject button on
    the keyboard worked.

    There seems to be no obvious way to say "please" to Finder.

    Sorry, no ideas, really.
     
    Jussi Piitulainen, Dec 20, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.