1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

dmesg problem

Discussion in 'Sun Hardware' started by Michael Moeller, May 25, 2014.

  1. Hi,

    after replacing the nvram chip of an SS5 dmesg shows some strange
    behaviour. It displays stuff as usual, then restarts and after the
    first few lines dumps a screen of non-ascii rubbish and terminates.
    After reinstalling Solaris due to a disk replacement the problem
    persisted. Anything else works as expected. Any ideas?


    Regards,
    Michael
     
    Michael Moeller, May 25, 2014
    #1
    1. Advertisements

  2. Michael Moeller

    DoN. Nichols Guest

    First -- what are the first four characters of your HostID.
    (Maybe just the first two, I forget where things stop mattering). I've
    got two SS5 machines still running. One starts with "8089" and the
    other with "8087", so it is probably just the first two characters. If
    it is not right, the OS will think that it is some other system board,
    and expect to find things at other locations.

    The other thing is to ask whether you did a reset-defaults after
    installing it -- and then added any other settings which differed from
    defaults?

    If those don't work, I don't know for sure what the problem is.

    It might also be of interest to see just where it starts
    printing gibberish. If you just run dmesg (or anything else which might
    spit out raw binary data) it will often switch the terminal program into
    weird displays. However, if you pipe the output through "less", it will
    display the binary data as something like "^A" (to indicate a control-A
    -- hex 0x01) or perhaps a two-character hex number, if in the extended
    part of the ASCII character set, and this form of display avoids
    confusing the xterm (which requires a soft reset in the window's
    "Options" selection at the least to get back to normal display.) (The
    "Options/Soft reset" is present in CDE -- not sure about other window
    managers.

    Good Luck,
    DoN.
     
    DoN. Nichols, May 26, 2014
    #2
    1. Advertisements

  3. Try stop-N (this should erase all user settings of the NVRAM and
    returns to factory state).

    Did you reprogram the hostid?

    Casper
     
    Casper H.S. Dik, May 26, 2014
    #3
  4. Thanks for your quick answer.

    The first byte determines the architecture. '80' for SS5. It's set
    correctly.

    I did a reset-defaults, then entered the host ID using mkpl, after
    setting the diag-switch? to false. I didn't touch anything else.
    This always worked with my other machines.

    Compared to the old outputs of '/usr/sbin/prtconf -vp' there always are
    lots of different entries after a replacement. Since this wasn't an issue
    I always ignored it.

    After comparing dmesg outputs from different machines before and after
    replacement of the original nvram I can be almost sure now the strange
    behavior is due to 'stray' control bytes like ^M. Only machines with
    an original chip are free from this in their dmesg outputs.

    It doesn't look like this can be fixed easily and at the same time
    I doubt the correctness of my replacement procedure at hand.

    Could it be each individual byte (or at least some of them) must be
    set by mkp at the boot prompt 'til the output looks exactly as before?


    Regards,
    Michael
     
    Michael Moeller, May 26, 2014
    #4
  5. I never tried this cause the S5 Service Manual isn't very specific
    about what this exactly does and my procedure for nvram replacement
    doesn't use it at all. Seems like I have to try this next time.
    Yes.


    Regards,
    Michael
     
    Michael Moeller, May 26, 2014
    #5
  6. I just deleted /var/adm/messages and rebooted the machine.
    I don't know if this actually was the solution to the problem
    but the error seems to be gone. I am none the wiser but at
    least things work as expected.


    Regards,
    Michael
     
    Michael Moeller, May 26, 2014
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.