Does newer Security Patches include older ones?

Discussion in 'Apple' started by Steinar Moum, Oct 13, 2010.

  1. Steinar Moum

    Steinar Moum Guest

    From my notes I see that Apple released their first Security Patch for
    Macintoshes - for 2010 - at January 19, 2010. And the last (so far) at
    September 20.

    I believe that if this Mac was updated to 10.6.4 the relevant security
    patches would be installed.

    If for some reason the Mac would still use MOSX 10.6.2 would it be
    possible to update a security patch issued after 10.6.3 were released?

    In short, if a Mac is missing 2-3 of the latest patches, will updating
    with the last one be sufficient?

    Yours

    sm
     
    Steinar Moum, Oct 13, 2010
    #1
    1. Advertisements

  2. The patches _up to when 10.6.4 was released_ would be installed.
    That depends on which patch and what it patches. Some patches apply to
    older problems. Some to newer ones. The write-up that comes with the
    patch will usually tell you which version of the OS that patch works
    with. However, it should be noted that usually you won't be able to
    apply the patch if you don't have the right version installed, and that
    if you have the wrong version installed and force an install anyway you
    may have problems. This especially applies to patches for the previous
    dot version of the OS; Apple will suport 10.5, for instance, but only
    10.5.8. Patches may not install on 10.5.6 or 10.5.7, and may not work
    properly if they do install.
    No. The only way to just install the last patch and go is to update to
    the current version of the OS, 10.whatever.new.

    Why not simply update the the latest version?
     
    A Non E Mouse, Oct 13, 2010
    #2
    1. Advertisements

  3. Steinar Moum

    David Empson Guest

    Note that the numbered updates (such as 10.6.4) also include security
    fixes that don't exist in any separate "Security Update". The separate
    Security Updates contain additional security fixes that are released
    between numbered updates of Mac OS X.

    If you install 10.6.4 Combo Update on any earlier version of 10.6, it
    includes all security fixes included in 10.6.1, 10.6.2, 10.6.3, 10.6.4
    and all separate Security Updates that were released prior to 10.6.4.
    (It obviously doesn't include any Security Updates released after
    10.6.4.)

    If you install the standard 10.6.4 update on 10.6.3, it includes
    security fixes in 10.6.4 and in the Security Update(s) that were
    released between 10.6.3 and 10.6.4 (Security Update 2010-003).
    In general, no. Almost all Security Updates require you to first install
    the latest numbered update of Mac OS X. For example, you must install
    10.6.4 before you can install Security Update 2010-005 or 2010-006 for
    Snow Leopard.

    If you were currently running 10.6.2 you would have to install the
    10.6.4 Combo update (or the 10.6.3 update then the 10.6.4 update), then
    install both Security Update 2010-005 and 2010-006 to be completely up
    to date.

    If you use Software Update, it will offer the updates to you in the
    order in which they must be installed: 10.6.4 Combo, then (after restart
    and running it again) the two Security Updates.

    Most Security Updates incorporate all previous security updates (back to
    the most recent numbered update of Mac OS X).

    This is most obvious when Apple stops releasing numbered updates for a
    major version of Mac OS X, such as 10.5.8. All subsequent Security
    Updates for Leopard (up to and including 2010-005) require 10.5.8 to be
    installed, and include all previous Security Updates that were released
    after 10.5.8. This is obvious if you look at the file sizes, which
    usually get bigger with each security update.

    As Apple is still releasing numbered updates of 10.6, the Snow Leopard
    Security Updates only very occasionally incorporate earlier security
    fixes, in cases where Apple has released at least two full Security
    Updates between numbered versions of 10.6. I can't see any case where
    that has happened yet.

    There are occasional exceptions to this pattern. An example is Security
    Update 2010-006, which fixes one specific security issue (insecure
    password handling for Apple File Protocol). That bug exists in all
    versions of Mac OS X 10.6 up to and including 10.6.4, but you can only
    apply Security Update 2010-006 if you first update to 10.6.4.

    Security Updates 2010-005 and 2010-006 for Snow Leopard are actually
    independent and can be installed in either order, but both require
    10.6.4 to be installed first.
    You cannot install the latest Security Updates unless you first install
    10.6.4. If you try to install them manually, the installer will refuse
    to proceed.
     
    David Empson, Oct 13, 2010
    #3
  4. Steinar Moum

    Steinar Moum Guest

    Thanks to both of you.

    sm
     
    Steinar Moum, Oct 13, 2010
    #4
  5. Steinar Moum

    Lewis Guest

    Not the one from September.
    The security patches for each major version (10.6, 10.5) include all the
    security patches for that version. This is why the 10.5 ones keep
    getting bigger.
     
    Lewis, Oct 13, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.