Dragon 2 V1.0 reports 3.0GHz CPU as 2.8

Discussion in 'Soyo' started by Dai, Dec 17, 2006.

  1. Dai


    Dec 17, 2006
    Likes Received:
    I have the P4I875 Dragon 2 V1.0 and it reports my 3.2 GHz as being 2.8. When I try to update the bios, I get a message similar to this:

    Bios Image File Check Sum Error
    !!You can't update this image file!!

    Check your FDD or HDD for corruption

    I have tried both the icw24aa3 and icw24aa4 upgrades. I have tried different floppies. I have tried both methods for flashing and I get the same thing.

    I emailed tech support, listing the steps I took to flash the BIOS and they told me that I needed to follow the steps that I took!

    Short of ripping this board out of my system and destroying it with a hammer, what are my options? How do I flash it?

    Oh, the BIOS is set to allow flashing...
    Dai, Dec 17, 2006
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.