Dual-side printing on Officejet 7310 running SUSE 9.1 & CUPS

Discussion in 'HP' started by Jerry E. Miller, Feb 19, 2005.

  1. My home network consists of two identical Dell Dimension 4800 boxes, an HP
    Officejet all-in-one 7310 printer, a D-Link router and a Motorola cable
    modem. One Dell box runs only Windows XP home, while the second box is a
    dual-boot Windows XP Home and SUSE 9.1 Linux. The printer works flawlessly
    when running under Windows XP on both machines. Of the many HP printers I
    have owned, the OJ 7310 is the first to satisfy my requirements. In my
    opinion this one heck of a printer for home/small office use.

    However, when running Linux, the printer will not print dual-sided. I am
    using CUPS and have defined 2 print queues, 1 queue for single-sided
    printing and a second for dual-sided printing.

    The OJ 7310 replaced a OJ 6110, which had the dual-side modification and
    functioned correctly for both single & dual-sided printing under CUPS.

    From what I have found on the WEB it appears the PPD file I am using
    supports double-sided printing under Linux/CUPS.

    From the HP-OfficeJet_7300-hpijs.ppd file:
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ *% You may
    save this file as 'HP-OfficeJet_7300-hpijs.ppd' *%
    *%
    *FormatVersion: "4.3"
    *FileVersion: "1.1"
    *LanguageVersion: English
    *LanguageEncoding: ISOLatin1
    *PCFileName: "HPIJS.PPD"
    *Manufacturer: "HP"
    *Product: "(officejet 7300 series)"
    *cupsVersion: 1.0
    *cupsManualCopies: True
    *cupsModelNumber: 2
    *cupsFilter: "application/vnd.cups-postscript 0 foomatic-rip" *%pprRIP:
    foomatic-rip other
    *ModelName: "HP OfficeJet 7300"
    *ShortNickName: "HP OfficeJet 7300 hpijs" *NickName: "HP OfficeJet
    7300 Foomatic/hpijs (recommended)" *PSVersion: "(3010.000) 550"
    *PSVersion: "(3010.000) 651"
    *PSVersion: "(3010.000) 652"
    *PSVersion: "(3010.000) 653"
    *PSVersion: "(3010.000) 704"
    *PSVersion: "(3010.000) 705"
    *PSVersion: "(3010.000) 800"
    *LanguageLevel: "3"
    *ColorDevice: True
    *DefaultColorSpace: RGB
    *FileSystem: False
    *Throughput: "1"
    *LandscapeOrientation: Plus90
    *TTRasterizer: Type42

    -----------------------------------------------------------

    *OpenUI *Duplex/Double-Sided Printing: PickOne *FoomaticRIPOption Duplex:
    enum CmdLine A *OrderDependency: 120 AnySetup *Duplex *DefaultDuplex: None
    *Duplex DuplexNoTumble/Long Edge (Standard): "%% FoomaticRIPOptionSetting:
    Duplex=DuplexNoTumble" *FoomaticRIPOptionSetting Duplex=DuplexNoTumble: "
    -dDuplex=true -dTum&& ble=false"
    *End
    *Duplex DuplexTumble/Short Edge (Flip): "%% FoomaticRIPOptionSetting:
    Duplex=DuplexTumble" *FoomaticRIPOptionSetting Duplex=DuplexTumble: "
    -dDuplex=true -dTumbl&& e=true"
    *End
    *Duplex None/Off: "%% FoomaticRIPOptionSetting: Duplex=None"
    *FoomaticRIPOptionSetting Duplex=None: " -dDuplex=false" *CloseUI: *Duplex
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    I am not experienced in Linux and feel there is probably some simple thing
    I am overlooking in either the CUPS or printer setup, however I haven't
    the remotest idea about where I should start looking to find the problem.

    I would really appreciate any suggestions offered which will allow me to
    find and correct my problem.

    Thanks
     
    Jerry E. Miller, Feb 19, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.