1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Embedded driver Development for a CDRW drive-->Having problems with new CDRW drives accepting any pa

Discussion in 'Embedded' started by LRCR, Apr 29, 2006.

  1. LRCR

    LRCR Guest

    Many thanks for those who replied to this issue. Unfortunately, I
    already tried the suggession and I still have problems with sending
    packet command to the CDRW and getting a returned error. If I can get
    more suggession in approaching this issue, I'll he happy with any
    reply regarding this issue. Below, I am reposting my previous message
    on this issue.


    I am currently developing a driver to a CDRW drive in an embedded
    system. I am currently having problems with new CDRW drives accepting
    any packet commands. (The ATA commands are handled.) The
    initialization sequence that I am using is as follows:



    1) Hardware reset (Delay 10 seconds after reset is released.)

    2) Software reset - setting then clearing the SRST bit in the Device
    control register

    3) Identify Packet Device command (code A1) followed by reading the
    256 words of device information.

    (I have verified that all of the timing is correct.)

    This sequence has been successful in pre 2004 CDRW drives (TEAC
    CD-W552D, SONY CRX230AD). However, in newer CDRW drives (TEAC
    CD-W552GB, SONY CRX230AD) as soon as I set the command register for a
    PACKET COMMAND (command code A0), the check (or error) bit is set in
    the status register and the error register indicates a sense code of
    06. Is there an additional initialization step that I am missing? I
    have gone through the ATA/ATAPI 5 Spec and have not found anything
    that I am missing.

    Chris
     
    LRCR, Apr 29, 2006
    #1
    1. Advertisements

  2. LRCR

    Didi Guest

    Chris,
    let me try a guess - since 06 is Unit Attention, could it be that
    the new device is a bit hasty reporting the (due to reset) attention?
    Have you tried to issue a request sense as a first command?
    I know it should not do that, but this is what comes to mind so far...

    Dimiter
     
    Didi, Apr 29, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.