Enterprise E420R problems

Discussion in 'Technical Support' started by dougy, Jun 11, 2009.

  1. dougy

    dougy

    Joined:
    Jun 11, 2009
    Messages:
    2
    Likes Received:
    0
    I'm attempting to debug an E420R. Have downloaded all manuals & spent days reading diagnostic info but haven't been able to see anything displayed on either locally connected VGA monitor (apparently a Sun option) or via null modem serial cable terminal connection from PC to to serial A.

    Keyboard / mouse / monitor were all disconnected during serial cable connection. Tried Hyperterminal / PuTTY / TeraTerm, VT100 9600 8 N1 Xon/Xoff, I get a cursor but no OK prompt. Cursor doesn't appear particularly happy because keyboard input doesn't do a thing. Hyperterminal actually says 'connected' but I think it does that regardless of whether it is or not.

    Unit is extremely clean inside with no visible dust

    I'm not certain if POST is running, when I hit the 'go' button the fans start up (sounds like an B47 warming up !!), type 6 keyboard beeps once , LEDs flash briefly then flash again briefly about 30 seconds later. The manual says one LED should flash slowly during POST but that doesn't happen. Fault lights are OFF on both power supplies.

    Removed all RAM & reseated, removed the (single) CPU from position 2 & re-fitted in same place.

    There were 8 sticks of RAM in the riser, none in the motherboard, rectified that with four in motherboard bank 0 / 1 & four in riser bank 0 / 1 but no difference. Manual suggests reconfiguring serial A from the standard RS423 arrangement to RS232 but I have yet to do that.

    Seached high and low / googled / etc for several days, found numerous similar complaints but nothing that provided enlightenment except the odd mention of some unspecified period of time between boot and something appearing on screen. Exactly how long a delay is involved (ie is it 30 seconds or 30 minutes or something beween) & does the delay affect both the terminal connection and the VGA connection ?? I've never waited for any appreciable time for things to happen but then I've seen nothing to indicate how long it takes

    I'm quite limited in what diagnostics I can run with nothing to see except the LEDs. Even if some manual input was required, I can't imagine what use it would be since without screen output I can't see any responses.

    I've changed the serial port jumpers so they are regular RS232 now, changed the PROM jumpers so the machine 'should' boot from the backup .. checked the null modem serial cable pinouts, left it running for 30 minutes just in case that makes a difference (it didn't). Only thing I have noticed is that the green LEDs on my cable tester change from green to red on DSR / DTS / CD the moment I open Hyperterminal or TeraTerm. The colour change appears to be directly related to Hyperterminal & TeraTerm as it doesn't matter whether or not the cable is connected to the 420R. Red LEDs change back to green the moment I shut the terminal application.

    Before starting Hyperterminal or TeraTerm I get three greens (TD / RTS / DTR) from the 420R end & four greens from W2K end (RD / CTS / DSR / CD). None of them appear to be in conflict so in the absence of any information to the contrary, I can only assume that the cable isn't causing trouble.

    Tried sending 'break' from TeraTerm but seems it doesn't understand, at least not enough to respond.

    Tried every terminal emulation available in TeraTerm including the break signal but no response

    Would it help if I scrounged up a VT100 dumb terminal someplace ?? I imagine they are connected directly to serial A without any sort of null modem device ?? My idea is that even though I've tried to make sense of the null modem pinout diagrams, I'm somewhat confused after poring over so many postings etc & looking for a simpler way of bypassing any possible problem in that area.

    Tried connecting a common or garden variety & known good CRT monitor direct to the PCI videocard & type 6 keyboard / mouse to the relevant socket but still nothing on screen. I've read about Sun monitors possibly being 'different' but put that down to the peculiar proprietory connection on neanderthal Sun sytems. Aren't all monitors with VGA connections equal ?? One peculiarity ... amber / green light on CRT monitors stays amber, but when I try a LCD monitor, the light turns green (still nothing showing on screen) As well as the type 6 keyboard / mouse, I have an interface box that I understood was to adapt the type 6 keyboard to a PC although I can't understand what would be gained by that. Can anyone enlighten me further ??

    Any clues / tricks / witchcraft / etc from someone conversant with dinosaur servers ??
     
    dougy, Jun 11, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.