1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

"Error Occurred(0)" with RAID 0. What does it mean?

Discussion in 'Hardware' started by John, Jan 7, 2007.

  1. John

    John Guest

    During boot up, one of my two week old hard disks in my RAID 0 is now
    reporting this error:

    "Error Occurred(0)"

    I googled for this error message and found only one other person that
    reported this error and his screen snapshot is nearly identical to my
    problem.

    http://www.hardforum.com/showthread.php?t=1132761

    None of the responses that I read in that thread were helpful to me.

    Using Western Digital diagnostic tools, I tested each drive and no
    errors in either drive were discovered. Chkdsk also reported no errors.

    From the time I first observed this error message some days ago, the
    computer has been working without any apparent problems (boots up and
    runs just fine) but the error message is driving me nuts.

    I have two of these disks:

    Western Digital Caviar SE16 WD3200KS 320GB 7200 RPM 16MB Cache SATA

    RAID 0 with Intel Matrix Storage Manager

    Motherboard: ASUS P5B-E (latest BIOS installed).

    Intel ICH86/DO/DH SATA RAID Controller:
    Driver date: 5/11/06
    Driver version: 6.0.0.1022

    JMicron JMB36X Controller:
    Device type: SCSI and RAID controllers
    Manufacturer: JMicron Technology
    Driver date: 12/5/2006
    Driver version: 1.17.8.1

    Device manager reports no errors for either of the above controllers.

    XP Professional. All service packs and updates installed.

    Intel Core 2 Duo E6600 Conroe 2.4GHz 4M shared L2 Cache LGA 775 Processor


    Does anyone have any suggestions on how I can resolve this error message?
     
    John, Jan 7, 2007
    #1
    1. Advertisements

  2. John

    HDRDTD Guest

    It 'might' be that one of the drives has developed a SMART error.

    Years ago when the WD 36gig Raptors first came out, I had two iof them
    running in a RAID 0 array.

    My symtoms were slightly differenrt than your, mine would randomly lock up.
    Usually re-booting the system got it going again but I could never find the
    problem.

    One of the thing I did notice, was that none of the programs I tried could
    read the SMART status of either drive.

    After a while, I finally decided to change to a single Raptor 74gig in part
    becauise I wanted to replace the RAID array drives with some other drive for
    troubleshooting.

    Once I got the system running on the new drive, I installed the old drives
    as seperate drives, and lo and behold, one of the drives started reporting a
    SMART error.!

    I downloaded the WD diagnostics, it found a bad spot that SMART had been
    trying to report. I got an rma from WD, they replaced the drive and the
    replacement drive is still running in another system years later.


    My point is, One of the drives may have developed a SMART error, but because
    they are in a RAID 0 array, nothing can report the SMART error in detail,
    and you may not see the actual error until the RAID array is broken into two
    ordinary drives.
     
    HDRDTD, Jan 7, 2007
    #2
    1. Advertisements

  3. John

    old man Guest

    I agree hd's in a raid array do not allways show SMART errors
    The hd manu checking utilities do not allways work perfectly when they are
    on an array
     
    old man, Jan 7, 2007
    #3
  4. John

    John Guest

    I went into BIOS and deselected the RAID option so that I had two
    separate drives. The computer, of course, couldn't boot but I was able
    to run the WD diagnostics from a bootable floppy for each separate HD.
    No problems were detected. I used DLGIDIAG5.EXE

    01/06/2007, 11:09:33
    SELECTED OPTION - "QUICK TEST"
    SELECTED DRIVE -
    Model : WDC WD3200KS-00PFB0
    S/N : WD-WCAPD2868494
    Firmware : 21.00M21
    C H S : 620181 16 63
    Capacity : 320G
    Drive : 0 Port: 0xEC00
    RESULTS - "NO ERRORS FOUND"
    ERROR/STATUS CODE = 0000


    01/06/2007, 11:11:40
    SELECTED OPTION - "SMART STATUS"
    SELECTED DRIVE -
    Model : WDC WD3200KS-00PFB0
    S/N : WD-WCAPD2437481
    Firmware : 21.00M21
    C H S : 620181 16 63
    Capacity : 320G
    Drive : 0 Port: 0xE800
    RESULTS - "NO ERRORS FOUND"
    ERROR/STATUS CODE = 0000
     
    John, Jan 7, 2007
    #4
  5. John

    Arno Wagner Guest


    Ok, it seems to be something transitional. It may be a drive in the
    process of dying (so a SMART check to find that out) or an interface
    problem. Maybe one of the (S)ATA connectors does not sit quite right?

    Side note: I would not depend on a controller that gives this
    type of obscure and entirely unhelpful error messages. Hints
    at an overal unclean design....

    Arno
     
    Arno Wagner, Jan 7, 2007
    #5
  6. John

    Michael Daly Guest

    You might narrow it down if you knew which of these two controllers the drives
    were connected to. Is it possible to switch between these two or is the
    existing RAID setup exclusive to one of them?

    Mike
     
    Michael Daly, Jan 7, 2007
    #6
  7. John

    John Guest

    That's an excellent question.

    I wonder what the consequences will be by disabling a RAID controller?
    Will the operating system start? I do have a full OS partition backup,
    but still....
     
    John, Jan 7, 2007
    #7
  8. John

    Michael Daly Guest

    Since it's a RAID0 config, your drives will look like gibberish to the OS if you
    turn off RAID. Disabling one controller in BIOS will result in a boot error if
    you disable the one with the disks attached (no drives found or some such
    error). You'll always be able to boot to BIOS to reset.

    If you have the motherboard manual (you can usually find one online at the
    manufacturer's website) you can determine which sockets are for which
    controller. Then just look at which one the cables are plugged into.

    Mike
     
    Michael Daly, Jan 7, 2007
    #8
  9. John

    John Guest

    I found that out the hard way. I had accidentally set the BIOS settings
    to default and I "lost" my drives. Once I reset the BIOS settings I was
    good to go.

    What I had meant was what would happen if I had go into 'Computer
    management console'->'Device Manager'->'SCSI and RAID controllers' and
    disabled one of the controllers then restarted the computer?

    I'm a little squeamish about doing this at this point until my large
    hard disk arrives so that I can first backup the entire hard disk.
    I have the manual but I'm not sure what you mean. I plug the cable into
    the left-most socket for drive 0 and I plug in drive 1 to the socket to
    the right. Like so: http://i10.tinypic.com/2qvgtpt.jpg
    To answer someone else's question: Yes, I replaced the cable on drive 0.
     
    John, Jan 7, 2007
    #9
  10. John

    Michael Daly Guest

    There are four SATA sockets there and you are using two of them. There should
    be some other sockets someplace else. One set is controlled by the Intel
    chipset and the other by the second controller. I'm guessing the four we see in
    the picture are for the Intel chipset and the others are elsewhere - possible
    for eSATA and are exposed outside the box. If this is the case, the Intel RAID
    controller is kicking out the error message.

    Mike
     
    Michael Daly, Jan 8, 2007
    #10
  11. John

    John Guest

    I installed 'Intel Matrix Storage Console' version 6.2.

    It's stating 'Error Occurred' on 'Device Port 0'

    'A drive in a RAID 0 volume is failing. Try to back up data immediately.'

    The '(0)' (I believe) refers to the device number and is not an error
    code. This is what threw me off.

    I backed everything up and I'll clone the dying drive to an identical
    replacement.

    I ran the Western Digital diagnostics again and it says that everything
    is peachy.
     
    John, Jan 8, 2007
    #11
  12. John

    Arno Wagner Guest

    After you have backed up, maybe connect the drive directly and
    post its SMART attributes here. Maybe we can spot some problem.
    I don't know the WD usilities, but for Maxtor both the disks and
    the diag-software are over-optimistic in their thresholds. The
    attributes themselves tell the true story, however.

    Arno
     
    Arno Wagner, Jan 8, 2007
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.